Presence sensors: Just stopped working [Platform issue now fixed!]

It seems odd to me that at least three people on this thread have had one or more of these sensors stop working at the same time. Surely that can’t be coincidence and suggests its something server side as suggested elsewhere in this thread?

Spoke to Tom Lane at UK support about this and it was evidently trending. The engineers are investigating but the method I wrote above worked for me.

I had previously uninstalled and re-paired without the 6 button presses but it made no difference btw

In my case, I started investigating my other (less used) zigbee devices e.g. motion sensor & power outlet, and noticed that they were having problems as well… However, funnily enough, my presence sensor didn’t seem to be having problems?

Anyway, like I said before, they were all working solidly for the first few weeks before these problems.

Also, my hub location hadn’t changed in that time either so like you said @leedjones, it is rather odd that a fair number of us are all now having problems…

1 Like

Few things about the presence devices.

  1. mobile presence uses cloud integration. Presence tags use ZigBee to communicate directly with the Hub. The results of the failures might seem similar (ie presence events not reporting), but the underlying causes are very different. Contact support on both.
  1. We saw a rush of reports about presence tag failures and are trying to get to the bottom. I’m leaning towards incidental timing but I could be wrong and we are investigating.
  2. The tags are super subject to interference. Keeping them near WiFi routers or cordless phones can kill their connection. Pairing them near interference sources can cause bad handshakes with the Hub, and it won’t report states. Check out the range and interfernce article above.
  3. I just found some sensors came with dead batteries. The battery tabs are super fragile. The best way to change the battery is with a small flathead screwdriver.
  4. The plastic around the sensor was refreshed, but the chip inside of essentially the same as the original version. The reset process for the sensor is the same as the old version (ie doesn’t involve removing the battery like with the motion and multi). Try a reset before popping out the battery.
  5. Contact support because the team is awesome, good looking, and ready to provide a gif if needed.
1 Like

So I re-paired both sensors and they’re working fine again now. However, it isn’t that simple as to delete a Tag you first need to delete all Smart Apps that its being used on so theres a whole lot of un-configuring and re-configuring after they’ve been re-paired. Not a massive, deal, but if its something ST/Server side, then I’d be happy to find out so it can be prevented from happening again…

I did the same and it worked for me.

1 Like

Well I’m not impressed to say that despite moving the hub as far away from my router as the supplied ethernet cable would permit, both sensors have stopped working again.:frowning:

If this keeps happening, the system is unusable for me…

Have you tried a soft reset by (gently) removing and readding the battery? Also, can you try tapping the button on the circuit board (rather than a full press/hold to reset)?

I’ve had the same problem… Softreset the sensor and also pressed the button once to reset - It then updates, but a day later its stopped again. I’ve had to do this 2 days in a row now… :frowning:

Big problems trying to pair the presence sensor

Thought it had done it yesterday, but never returned a battery status (I have tested with a meter , its 2.95 volts) and said ‘present’ regardless of whether I was or not.

The web API report no status or data, and the iOS app doesn’t show any battery voltage either.

I deleted, and rebooted and took the battery out then it did finally appear to pair as per instructions, I went through the ‘next’ options and then the iOS app crashed leaving a half complete device.

Deleted this and its - its currently stuck at ‘identifying a device’.

Am hoping its the coin battery, so out to buy a new one - but 2.95v seems fairly healthy to me.

Any clues not his one ?

S

No, I haven’t. I’ll try that if it happens again. However, I’m having other problems with the setup now and I’m starting to lose patience to be honest. I’ve bought £250 worth of hassle at the moment as NONE of my installed smartapps are working correctly now. It was all working fine until the presence sensors started to fail…

2 Likes

Update - new battery makes no difference.

Tried in another part of the house, away from the wifi router and no difference.

All the other things in the starter pack seem to be okay, feeding back temp, motion etc…

Looks like a software fault to me…

Im beginning to wonder if its a software or platform fault too. Neither of my sensors are working now - they’re both showing as present all the time, even when I’m away.

Mine stopped functioning again on Friday. Reset and re paired but always shows present and no battery reading either.

Can’t be a coincidence.
Maybe a duff batch given to some on the insiders trial.

Exactly the same for me - mine came from Currys, so presumably a production run - points to s/w

Hmmm…Looked at mine and you’re right, no battery reading on my two either.
Anyone from SmartThings Support able to comment on this and help resolve what looks like a platform issue??

Just put in another ticket, let’s see if there is a definitive resolution. At the moment it is more bother than it is worth.

I’ll add my name to this one, new to ST and my sensor was working for a few days but sometime over the last week it is always present. Tried all the resets as above but still get nothing. Similar that I do not get a battery reading from it either.

Annoying thing is I could get away with it except due to another SmartThings bug I cannot use a second iPhone as a presence sensor :frowning:

Just to add, tried removing the battery and it made no difference. Deleted the tag, removed the battery, re-paired and again, no difference. It detects the tags but its effectively dead - doesn’t register any events (always shows present regardless) and no battery reading either.
Seems to be quite a widespread problem but the silence is deafening :frowning:

Can confirm I am affected by the same thing… Quiet annoying.