Presence Sensor suddenly started Away/Home/Away/Home


(Stuart Buchanan) #1

and it goes on…

I have 5 fobs in my house and they have been working extremely well up until yesterday where one in particular is going to not present for 10 minute intervals. its driving me insane!!

so one of the ones that works fine is shows the following

battery: 63 %
presence: present
lqi: 100 %
rssi: -57 dBm

and the one thats broken ( i have just changed battery and same issue is showing)

battery: 88 %
presence: present
lqi: 29 %
rssi: -84 dBm

but its the same distance away from the hub… is it the hardware that’s faulty do you think?


(Wayne) #2

Nope I think it’s the norm. I’ve only got two and sometimes the exact thing happens to me. Sometimes it’s both sometimes it’s just one. I’ve even had it ontop of the hub when it happens. At other times it will go for weeks without a hitch.


(Stuart Buchanan) #3

First time it’s happened to mine. Very annoying as my door is unlocking every time it is arriving. Only happens when I’m home obviously and I don’t block during night mode etc. But I have a voice announcement telling me my wife is home…over and over again

I’ve tried also changing presence timeout via hub utilities but it’s the same issue


(Aaron S) #4

This is almost always related to some type of interference (which is what LQI indicates). Here are some steps you can use to troubleshoot: https://support.smartthings.com/hc/en-gb/articles/200751335-Troubleshooting-SmartSense-Presence-Sensor-says-it-s-leaving-and-arriving-constantly

If you have continued issues, shoot a note over to support@smartthings.co.uk and they can look into it further


(Wayne) #5

Thanks Aaron but I really doubt it is the case for me. I’ve seen it happen even when the fob is sitting on the hub itself. It can go on for a day then just correct itself. The hub is nowhere near any other 2.4 device and my main wifi was is located several rooms away is all 5ghz.


(Wayne) #6

It’s gotten so unreliable in the past that I’ve created a virtual presence for people and use the arrival sensor to merely update the virtual one. Only if the arrival sensor leaves for over 5 minutes does it update the virtual one using an RM rule.


(Stuart Buchanan) #7

Yup I use a virtual one of 4 different presence options per person, it’s been rock solid up until now, @Aaron if I reboot the hub it stops for quite a while about 4 hours or so and starts again.

Also I have 4 others which I have had in the same vicinity, they all show a lqi of 100 so I doubt it’s interference as all would be affected


#8

Sitting on the hub itself is almost I. always an area of a large amount of radio frequency transmission. Also, the zigbee signal spreads as it gets away from the actual antenna, it’s actually easier to miss if you’re too close to the hub.

presence sensors will work best at a distance of 5 to 7 m from the hub and any other RF sources, in particular Wi-Fi boosters or routers.


#9

lqi (the quality of the signal received) is usually calculated from a combination of the signal strength (rssi) and the number of errors. with rssi, -40 is better than -50, but sometimes RSSI is high because you’re actually receiving the interferer’s signal.

With Zigbee devices, it might be fixed just by moving a couple of meters in One Direction or another, just like Wi-Fi dead spots in the home.

I have a Wi-Fi booster and when it’s placed on the west wall of one room all the smartthings-controlled zigbee devices to the west of it fall off the network. If I just move it 90 degrees to the north wall, suddenly everything works again.

When I was in college, one of our exams was to imagine an empty house, fully networked, where everything worked great until a family moved into the house. We then had to identify everything that might be blocking signal. Most people got most things, but everyone, including me, missed a cast-iron frying pan that was sometimes put on two different shelves in the kitchen. On shelf A, everything worked fine. One shelf down and about half a meter to the right, and suddenly signal was blocked. It happens.

So given that you’re seeing a very low Quality of signal on one device, I would look for areas of local interference. If you can’t reproduce the quality issue with any of the other devices, it could just be a bad device. That also happens.


(I got a hair cut from Alexa) #10

The presence sensors I use that are based on connection to the zigbee net have had this same problem. The fobs I’ve re-coded to report battery status once a minute and use that as the key to presence or not – those have not had the problem.


#11

Many people have problems with the zigbee presence sensors getting lost from the network. And there are all kinds of things that can cause that.

But here you’ve got a single device of several with a poor RSSI and a really poor LQI. That’s almost always either interference or a bad radio.


(I got a hair cut from Alexa) #12

I’ve had a fob configured each way setting 3 meters away from the hub for a few weeks. The one that detects on zigbee connect status flips present non-present a few times a day. The battery status transmitting zigbee fob never wavers. I’m using a missed message tolerance of 150 seconds (2.5 minutes) I’m still testing battery life. I wouldn’t have thought of using the battery life message if an engineer at one of the manufacturers hadn’t told me that it’s far more reliable to do it that way. Totally independent of hub manufacturer.


#13

Makes sense. You’re going to lose some battery life, but it could be worth it. (Battery check does 3 things: receive message, check battery, send message–vs do just one thing and sending the ping. So I know you’ve doubled the check in period, which helps, but it still’s somewhat more energy-intensive. But again, might be worth it for some households.)

People who are using it to open a garage door, though, may not like having to wait twice as long to be recognized. But again, choice is good. :sunglasses:


(I got a hair cut from Alexa) #14

The messages are transmitted once a minute now, with the 2.5 minute tolerance – but that can be reduced even further. Hard wiring one into car power for the garage door…would mean battery life wouldn’t be an issue even if you set it for 30 seconds or less.


(Stuart Buchanan) #15

Pretty sure it’s not interference as said the other 4 fobs would be affected also, but these never miss a beat when placed in the same vicinity of the fob that is misreporting, that fob however isn’t flip flopping away home quickly like every few minutes as was the issue with presence sensors a little while back as I goes offline for about 10 minutes.

But what I find strange is when I reboot the hub the presence sensor that has the issue the reports a lqi of 100% for roughly 4 hours then it start flip flopping again. And when you look the lqi is showing as dropped.

So why would rebooting the hub fix an issue with the fob temporarily. This is consistent I have reproduced this 4 times now. Reboot the hub and he issue goes away temporarily for about 4 hours


#16

A lot of zigbee devices are flaky right now with exactly this kind of behavior. Motion sensors that will report temperature but not motion, contact sensors which appear stuck at either open or close, pocket sockets that become unresponsive. Removing from the network and re- pairing or even just taking out the batteries and putting them back in Will fix the problems for a few hours and then they return. So maybe this is related to that? It’s really hard to tell right now. None of it makes any sense, but it’s definitely happening.


(ecksomperudenlign) #17

hi @Fuzzyligic,
This is unrelated to your issue. How did you view the lqi and rssi of your devices? Thanks.


(Stuart Buchanan) #18

go into the devices view in the IDE and select your device. the rssi and lqi are visible under the state section of the device.


(Stuart Buchanan) #20

ok so i have a question, does the Zigbee channel on the hub change or is it static? reason i ask is that i am pretty sure it was using channel 23 when i first ran through my setup (i wrote down these value) i had ST on channel 23, Hue on 25, and my 2.4ghz Wifi on with 40mhz spacing in the area below channel 6 which i thought was good separation. i have 2 neigbour wifi signals which are very weak just on the edge of reception on channels 11 & 12, but i can only pick them up from my WIFI router near the front of the house, and that has a good external antennae attached, so i am pretty sure that they could not be causing interference as i cant even see those networks from any tablet or laptop in my house.

so i bought a new fob and immediatly after adding this fob, another of the fobs that wasn’t having a problem started flapping with the same issue…?!? so i went and checked my Zigbee channel on my hub and saw it’s set to 15? this directly conflicts with my WIFI. this was not the case in December when i first set this up i am pretty sure as i did write the values down

so did this change? or was i mistaken (i very much doubt this), looking through this community i cant find any info except from old info regarding v1 hub which said the channel was set at the factory and cannot be changed, but i cant see anything on v2, it is intimated it is changeable on the hardware, but we as users have no exposure to do so. so how could this have changed?

so i’ve just changed my Wifi to channel 13 with the 20mhz extension channel below… Hue on Channel 11 and ST on Channel 15, so i will see now if the issue persists

@duncan can you shed some info on this?


(Stuart Buchanan) #21

Ok so it seems I must have been mistaken as I have a post in Jan on the community post firmware update at the end of Jan where it was showing as channel 15 also. So I have no Idea why I wrote down that channel and configured my wifi to conflict. But my Zigbee network has been working well.

So now I the two fobs that were flapping before the frequency change are still flapping so buying a new fob has made the situation worse :frowning: