Presence Sensor Event Overload


(Matt) #1

Since the upgrade to the new hub software has anyone noticed a lot of “has left” and “has arrived” events for their presence sensors? I have some apps that trigger lights to turn on when people come home and my lights have been turning on a lot due to a lot of false “has arrived” events.


(Eric) #2

maybe your “arrival sensor” departure delay time was set to zero in the new hub.


(Matt) #3

Thanks Eric

Is the departure delay tied to ‘mode switch’? I switched all my mode “false alarm thresholds” back to 20 minutes after the hub update.

However, the app in question is not tied to mode - its purely tied to arrival events (and the current day’s sunset time).


(Eric) #4

my usage is hubv1, and the old phone app refers to this delay as “action delay time (minutes)” in the “Everyone Leaves” requirement of “Goodbye!” action. I don’t know if hubv2 / new phone app calls this the “false alarm threshhold” (minutes).

In my case When “Everyone Leaves”, then the delay waits 7 minutes before performing “Goodbye!”. This prevents a fob from disappearing for 2-3-6 minutes and reappearing, and causing a bunch of unwanted action.

I do change mode with it.


(Phil Day) #5

I had the same problem with hub 1.0 and app 2.0. I use one to open a garage door when a car arrives and it kept opening the door all the time as it would continually think the car had arrived. In the end I turned off that feature.

Since switching to hub 2.0 it works correctly. I have only had hub 2.0 up and running since Saturday, but have not had one single false “has left” or “has arrived” event.


(Matt) #6

Thanks for all the replies.

It got so bad tonight that i just uninstalled the app.

Does anybody know of APIs that can be called to add in some hysteresis? I saw some that would return the last X events. Does that API call return time stamps so i can filter out false events?


#7

If this is the Zigbee fob, Support can make some adjustments that may help, so definitely get in touch with them.

I have had problems at my house with the zigbee fob forever. It seems likely due to interference from boosted WiFi from one of my neighbors. So we’ve taken a different approach, as I’ve mentioned before, using two devices so we avoid the teleportation problem.

Here’s a quick look at a typical log for my presence sensor. And this is after support worked on it for about a month. I was home the whole time with the fob sitting in one place. You can see why we had to come up with a different way of handling it. :sunglasses:


(Matt) #8

Hey JD - very interesting.

About the same time as the Hubv2 came out I had to reset my router and it went back to the default WiFi channel (Channel 6). I usually have it at 1 or 12 to avoid other hotspots in the area (that i assume also default to Channel 6) but didn’t bother with it this time. I’m going to switch channels and see what happens.

Thoughts? thx!