Presence no longer working (new app, iPhone 7)

The app shows my phone has been at home since last Tuesday. I have left home, with my phone, many times since then. Uninstalling and reinstalling the app and disabling and re-enabling location services does not fix the issue. What else can I try? My phone’s GPS works just fine, because I have no issues with navigation.

Which app is showing this? The new app does not show the status of the presence sensor unless you are seeing the sensor for the Classic app. So then I wonder if you deleted the Classic app and did not remove the presence sensor for it.

My phone does not show up as a presence sensor device in the new app like it does in the classic app, so I am looking in the classic app. (But I have made sure location services are disabled for the classic and enabled for the new, which has worked just fine since switching to the new app about a month ago, up until last week.)

Just to verify… on the iPhone, go to settings, scroll down the list and find the new Smartapps and open it, check the location services is set to always

That’s one of the first things I checked.

Ok, check for an extra Home location. If there is an extra one, make sure there are no devices in it and remove it. Then disable location services and enable again.

Do you mean in IDE? Just checked; there isn’t one.

Try editing your geolocation in the new app and save it

Alright, I gave that a shot. We’ll see if it works when I go out tomorrow. I’m not too hopeful, because presence works just fine on my girlfriend’s phone, which uses the same geofence. We’ll see.

Unfortunately, as expected, that did not fix the problem.

When I reinstalled the app, I did not have to log in and all my stuff was as it was. This tells me that app data was not deleted when the app was uninstalled. What’s the point? How can I completely delete the app data? I do not see a log out in the new app like there is in the old.

Anyone have any ideas how to get this working again?

Same issue here at the moment. One out of two phones does not update.

Me too … same issues.

We have 4 iPhones in our family, with Automations set up to notify whenever someone leaves or arrives. They work less than half of the time. The only thing that’s consistent is the inconsistency.

I’ve tried all of the “fixes”. Nothing changes. iPhone presence worked perfectly for me until I migrated to the new app.

1 Like

Same here every time they do upgrades things breaks

Just to add to this. I also have the same issue with my wife’s phone which is also an iPhone 7. the 2 iPhone 11 pros and an iPhone x all work fine. I suspect this is phone related.

We have two iPhone 7, and two iPhone 8.

When we used the Classic app, I had one 7 and one 8 set up for mobile presence. Both iPhones worked perfectly, and consistently.

When I switched to the new app, I had to “re-set-up” those two phones in the new app. I did that, and deleted the legacy set-ups. And I added two additional iPhones - another 7 and another 8 - for our two kids.

Now, none of them work consistently for mobile presence. It’s broken.

Not the iPhone 7, and not the iPhone 8. (But, again, both models did work very well and very consistently in the previous set-up using the Classic app.)

Methinks the problem isn’t the phone model. It’s something that SmartThings has done as they’ve built the new app.

I’ve been struggling for weeks to get mobile presence to work for us. The problem clearly isn’t on the user side … so I’m throwing in the towel for now. We’re pausing our use of ST entirely until (if?) Samsung can get this fixed.