Presence issues since June 2021 app update

I’m about at wits end at this point…I’ve had several issues since the latest app update but the presence issue is currently the most frustrating. I’m not very versed in any of the behind the scenes stuff like coding but I have been pretty successful so far with the help of these forums so here goes…

Prior to the latest app update, I had been using my and my wife’s phones (iphones) as presence sensors to trigger simple automations (unlock door, turn on lights). With the help of this forum I also created “virtual” presence sensors (Virtual Presence Plus) that were triggered by the phones so I could see/confirm who was/wasn’t home.

Now, since the latest app update, its a mess. At first, neither phone was working as a presence sensor. Eventually, mine seems to be working pretty reliably. My wife’s is spotty…at best…for the sake of this post, let’s just say that it isn’t working as a presence sensor. Here’s what I have done to try and remedy the situation (based on what I have found online and what I was comfortable fooling with without someone guiding me):

  • Removed and reinstalled the app on my phone (this seemed to correct most of my initial minor issues as well as my phone presence issue)
  • Removed and reinstalled the app on my wife’s phone and confirmed that she had all the proper location permissions set (this does not seem to have helped with her phone presence issue)
  • Rebooted (unplugged for a bit then plugged back in) the hub on 2 separate occasions (this does not seem to have helped with my wife’s phone presence issue)
  • Created 2 simple automations…one that sent me a text when her phone presence left and one that sent me a text when she returned (it worked the first time that she left the house but has not worked since)

Sorry to be so verbose but I just wanted to give you as much info as I could right up front.

I would really appreciate any help. Thank you in advance.

What kind of phones? Power management, battery optimization, etc. works slightly different between iOS and Android…

When you uninstalled/reinstalled the apps on both iPhones, did you remove any lingering phone presence sensors in IDE?

I generally turn off get location from this iPhone, remove the app, login to IDE and remove the presence sensor, reinstall app, enable get location from this iPhone, set up automations.


I have the iPhone SE (2nd Gen) and my wife has the iPhone 11

Side note…you helped me with the virtual presence sensors last year…thanks again!

I did not mess with the IDE…I was afraid to mess something up, lol

I agree that varied phone settings and other factors outside of the ST app itself you can lead to issues with presence. On the other hand, I believe there are issues with the app itself.

I have two automations designed to disable the sthm upon arrival home. I have L360 installed so one automation uses that presence sensor and the other uses the native presence sensor. The trigger condition is simple. I am present and sthm has been armed away for 5 minutes.

I also have two hubs in two locations. In BOTH locations an automation to arm the sthm after being away for 5 minutes works perfectly.

I have IDENTICAL disarm on arrival automations for both locations. At one location, this works perfectly with one or the other sensor triggering the automation. At the other location, despite the fact that the automations are identical to those at the location that is working, neither of the arrival notifications triggers. Additionally, I can see the status of the L360 sensor and confirm that I am present

Just one phone, mine. It works in one place but not in another. I doubt it’s the phone. Would love to hear a logical explanation.

I’m following this as my location services are not working since the update.

Same here. Been using Smartthings with the same automation and phones for a couple years. The last update killed it. I’ve re-installed and checked settings. Tried different automation settings. Can’t get it to work.

My disarm automation started working at my 2nd location as well. I guess it just needed to get comfortable with the fact it has to work in both places . . . . j/k . . smh. :thinking:

I have a parallel one using L360 presence, but the ST one usually fires first.

I wanted to give you all an update…I rebooted (unplugged for a bit then plugged back in) my hub a 3rd time and that seems to have done the trick. Both mine and my wife’s phones are functioning properly as presence sensors.

I can’t say for certain that it was the rebooting or that it just took a few days for the system to “settle in”.