Plume App no longer works

I have the 3 pack of Smarththings Wifi, for the last 3 weeks the Plume app has not worked. I reached out to Plume who said Samsung SmartThings provides support for the app. I reached out to Samsung Support and can’t get a reply. Did i seriously waste my money investing in these SmartThings Wifi’s that I can’t even manage properly anymore?

I’ve had my mesh for over a year and I can’t bet into the hub as well. The Plume app is not working. I get a message saying Samsung acccount already exists in account manager

Tagging @Michael_ST

i keep seeing more and more of those on ebay. people are learning.

Works just fine for me. What issue are you seeing in the app. Unable to login? Make sure to select “I’m a smartthings user” or something along those lines to sign into the app. Also you MUST sign in with the primary account for the smartthings hub. Shared accounts don’t get access to Plume.

@Dave_Riehl @nordlor Can you confirm the exact name of the Plume app you are using? Is it “Plume WiFi” or “Plume for SmartThings Wifi” as mentioned in this Plume support article? This can help us clarify where you are seeing the issue.

It’s the “Plume for SmartThings Wifi” app. This is apparently only an issue for Canadian users. There are dozens of reviews from Canadians in the App Store complaining of the same thing.

I am using “Plume for SmartThings Wifi.”

Good to know, I’m looking into something that I think may be related. Would you mind sharing the model of phone you are seeing this on?

Samsung s9 plus, with android 10. Plume version 2.2.5 smartthings 27.


I am having the exact same issue, since August. My phone is an S20 Ultra, with Android 10. All else is the same. Also, this happened around the same time i received the One UI 2.5 update. Please help with this. We need our Plume back.

If you sideload the Plume app from a site like apkpure, it will work in Canada. Can’t believe Samsung would just abandon support for a whole country where tons of people have obviously paid for the product. I’ll definitely look else where for my home networking and smart home needs in the future, just can’t trust them.

1 Like

I tried to sideload. Still the same issue. So frustrating.

Screenshot_20201119-234231_Samsung account|225x500

By any chance are you trying to use a different Samsung account, than what is used by your phone as default?

There is a limitation on Samsung phones that only one Samsung account can be assigned to them.

Thank you for getting back to me. I am using the same account.

Giving this a bump.

App 2.2.5
Smartthings 27

App does not load. Also to be noted, Plume does not exist on the Google play store. At least not in Canada. This includes 'Plume for Smartthings WiFi.

Mine is working fine

What are you using, are you in Canada and able to find the app on Google Play?

I’m in the usa and yes I downloaded from Google play

This only seems to be an issue for users in Canada, since they have to use a different app on their respective app store.

I’m also having this problem, and I can’t find an APK that works, either.