Philips Hue Quick Flash of White Light

I’m trying to set up a simple nightlight routine. Motion sensed in the bathroom turns my Philips Hue bulb a dim red. Everything works, but the bulb turns on to white for a split second before turning red every time. I’m connected through a Philips Hue Hub. My guess is that one fix would be to connect to the smartthings hub directly, but I would prefer not to do that.

This seems like a basic problem, so I feel like there is something I am setting up incorrectly.

What are you using for the rule that turns the light on? Can you post a screenshot of that?

Also, I don’t know whether connecting the hue bulb directly to a smartthings hub without the Hue bridge will solve this particular problem, but it introduces a whole host of other ones and it is not recommended by either hue or smartthings.

Finally, this is probably too obvious, but are you sure it is the bulb flashing and not the motion sensor? There is an indicator flash when motion is detected.

Definitely not the motion sensor. Basically it’s the light turning on and then switching to red quickly instead of just turning on red. I’ve tried a second bulb just in case that was somehow an issue. I have another motion sensor coming as well and will try switching that, but I don’t see why that would be the issue. Again, this seems like the most basic of automations… Motion detected, turn bulb on to a specific color.

1 Like

Try using a scene, so that instead of the automation turning on the bulb directly, it activates the scene. I don’t know if that will make a difference, but it might.

I assume the nightlight only comes on when in Night Mode. Try setting the light to dull red with an auto off timer when the Mode changes to Night. I have one light (an Innr) that does the same and this trick works for me.

Thanks for the tip but it does the exact same thing with a scene.

I believe it’s in home mode. I haven’t touched the modes at all. I’m not sure how to set it to automatically go into night mode or what switching modes even does?

Modes are used as a filter on rules. There are two kinds of modes: one for the security features and one just for the general home automation system. The second one is called the “location mode.“ When you set up a smartthings Account you get three location modes: home, away, and night, but you can add more if you want.

Just as an example, at my house we set the location mode to “home” at 7 AM every morning. We set the location mode to “night” at 15 minutes before sunset. When the location mode is home, a motion sensor event In most of the Upstairs rooms doesn’t do anything. When the location mode is night, those same events turn on the overhead light in those rooms. We have another mode we call “asleep.” Once we go to bed, we change the Location mode to that and then the motion sensor events do not turn on the overhead lights, but instead turn on a soft nightlight. You can change the modes with an automation. Same sensors, different outcome, because the location mode is different.

You can read more about modes in the following FAQ:

FAQ: Armed/Disarmed states vs Away/Home modes confusion

Ok, I checked, and it looks like anytime you change the level on a dimmer the system is now turning the light on first. It didn’t used to do that and it can be pretty annoying. There may be some particular trick that works, hopefully someone will know.

Thanks for all the tips. I think I solved this enough to be usable for now, but would still love any advice to get it to 100%. Instead of using an ‘Automation’, I’ve switched over to using the ‘Smart Lighting’ SmartApp. This still turns on white right away, but at least now it only flashes a very dimmed white (I’m assuming 1% per the setting). Also, it only seems to do it the first time and any subsequent times in the night it is already set to red. It’s still bugs me I can’t get it to work perfectly, but it’s definitely usable now. Before it was an annoying flash of bright white light and couldn’t justify using it that way. I’m sure I could add Andy7’s method to this and automate the bulb to turn on, set to red and turn off quickly every night at a specific time so that the red is already set, but that feels just as annoying to me and seems like it should just be able to go to red without the hassle. For now, this is my recommendation to use if anyone else searches with this problem. I would still love to hear if anyone else knows how to make it work 100% without turning the bulb on and off one time first.

1 Like