Philips Hue Groups Control App

Thanks for the reply and no worries. I see the activity on the echo! Anxious to try that next.

Yes I deleted everything and installed your code fresh.
I actually rolled back to the previous code before the last update you did and finally got the lights to respond both as single and as groups. However polling doesn’t function
Love the transition changes and the ability to control and entire room at once. I’ll keep tinkering with it!
Good stuff man. Transition command for hues is so underutilized.

The polling is an issue and I use pollster… It’s some weird problem in with the hue… But with my code when you poll one light it will poll all… That was my solution

Hi Zpriddy,

Everything installs properly and appears to work; however, none of my bulbs or groups respond to any on/off commands. From the logs, I keep getting:

NOT PROCESSED: [{“error”:{“type”:5,“address”:"/groups/1g",“description”:“invalid/missing parameters in body”}}]

I deleted everything and tried to re-install. Same issue. Do you any have insight on what the issue is? Let me know. Thanks for your help and time.

Im trying to dig into that right now… Im thinking it may be an update on the hue hub

Ok, I have ZPriddy’s Hue Groups app and devices installed, and it has correctly identified the groups on my bridge. Nice! Thanks!

The problem is that Smartthings still can’t detect the state of my lights, unless I manually go into the light device (e.g., “Dining Room”) and refresh it. Say I turn my DR lights on via Smartthings, then go into the Hue app and turn them off. Smartthings still thinks they are on.

Just pulling down the Smartthings refresh doesn’t do the trick. Is there any way to make it more immediately responsive?

It does seem to do some kind of background polling, because as I’ve typed this, it did detect the change. I just can’t seem to make it happen manually without some in-depth intervention.

Don’t get me wrong: this is still way better than what ST and Hue provide by default. So again, thanks. Just wondering if this is an issue that others are having and can be fixed.

As far as I know it does a 5 minutes polling. The state will reflect correctly based on how close you are to the 5 minute polling. Another tip is when it starts failing for some reason, just go to the connect app and when it starts dicovering bulbs and see spooning wheels for a few seconds, click done and exit out of hue connect app. This clears any stuck polling. Try this and watch in the IDE, how quickly all your bulbs will appear there.

Ron, are you using this app?

Oops! Sorry! Wrong thread. I use the native ST hue connect app. Sorry for the confusion! At the doctors and did niot pay much attention! I so do apologize! :frowning:

Hey @zpriddy. Thanks for all your help on this. I just tried installing the setup myself and got the same error/issue as @soedmond

NOT PROCESSED: [{"error":{"type":5,"address":"/groups/1g","description":"invalid/missing parameters in body"}}]

Did you happen to figure out what was going on here?

I wish I had a better answer for you… I have the same code in mine and moved over to the v2 hub… and it worked just fine for me. I’ll take a look and see if I can update the code in it.

I’m on the new Hue bridge and can’t update my light setup via the smartapp anymore. It found the new bridge and I can still do everything I could on the day I migrated, but if I move a light (say, a regular Hue bulb to my front porch to make spooky Halloween lighting effects), I can’t get the app to save my new setup. It talks fine to the bridge and finds the new light names/groups correctly, but hangs when I try to save: “Failed to save page: bulbDiscovery”.

I have tried to reinstall the app (without removing the one that still sort of works), but the new installation won’t discover the bridge at all - nor will the default Hue app, so I think that’s a bigger issue.

Just wondering if you’d seen this behavior before and had any suggestions. Thanks!

Hi Guys,

I’ve done a little bit of work on @zpriddy’s device types tonight. My changes may not suit everyone, but here’s a quick rundown of what I’ve done so far:

  1. Update the tiles to the ‘new’ style
  2. Enforce a minimum of 1% when calling setLevel(...)
  3. Do not change the switch state to on when setLevel(...) is called.
  4. Reduce default transition times.

I’ve found these changes make using the bulbs/groups from the app much more enjoyable, but it is obviously a bit out of the norm from how these devices normally work in SmartThings. As an example, you could now change the brightness of a bulb/group in the background and the next time it is powered on by any means it will come on at the desired brightness. I use this as a way for me to simplify my automation by not needing to configure a dimmer level with my triggers.

I do have some some plans to continue improving the device types. In particular, I’d like to make the default transition time dynamic so that it’s effectively zero when the level is 1% and is several seconds when the level is 100%. This would maintain the nice smooth transitions while avoiding the ‘delay’ that is seen when turning off lights that are dimmed to 1%.


I just submitted a pull request which would add Hue group support to the official Hue Connect SmartApp and Hue device types. Worth noting that this does not include any of the transition time functionality.

Hey @kelchm, I just pushed your devicetypes and the group was discovered and installed ok, but i’m getting an error trying to turn the group on/off:
NOT PROCESSED: [{"error":{"type":5,"address":"/groups/1g","description":"invalid/missing parameters in body"}}]
Have you seen this error before?



That’s a new one for me. I’m not sure what the cause would be off the top of my head.

I’ve actually fully switched over to using the SmartApp and Device Types in my pull request. These stick to the standard SmartThings behavior for SetLevel() and do not implement the transitiontime additions.

I just sent a pull request to your pull request : ). Changing the PUT call to use the nicely parsed version of HubAction rather than the raw string version fixed my issue but I’m not sure what the root cause was other than it wasn’t sending the body at all.

Thanks for the pull request. :slight_smile:

That’s actually the ‘old’ version which I don’t plan on maintaining. You can see the version I am currently using in this branch.

@Matt_LeVan Thanks for fixing that issue!!! It was what was stopping me from using this app

@kelchm Thanks to you as well for updating with your changes. I definitely prefer this method.

A question to both of you:
I notice an issue when using Smart Lighting and trying to set the level that the app doesn’t trigger properly. Have either of you guys noticed this? I noticed it with the Lux & my Cree lights that are on my Hue hub.

Just posted a modified version of zpriddy’s Hue Groups app that includes Hue Scenes as well:

1 Like

I think I love you :smiley:
Ok - that’s me saved from my development project for this month - I’ll be testing that this week.