SmartThings Community

Philio PSP01-1 3-in-1 Multi Sensor Device Handler - Help Needed

(Philip Street) #1

Hello SmartThings Community!

I’m a noob to SmartThings, having recently migrated from a Vera Lite, and am generally very happy with things so far. I’ve managed to get most of my existing - and somewhat legacy - devices included and working using DTHs I’ve downloaded from the Community.

But I have one device that is not working 100%; my Philio PSP01-1 3-in-1 Multi Sensor correctly reports temperature and light, but constantly detects motion and never reverts to “no motion” / “inactive” state.

I tried using the PSP01-2 DTH (Philio PSP01-2 Motion Light Temperature Z Wave Sensor), as apparently some people have had luck with it but it didn’t work for me and I’ve had no reply to a question I posted.

So, with that in mind I thought I would have a go at writing my own DTH;

I was hoping someone could review my first attempt at writing this DTH, and hopefully give me some suggestions as to how I can get it working.

Many thanks in advance,

Phil

(Philip Street) #2

Any thoughts?

#3

Same problem, I have 4 of these and never got them working. It doesn’t seem to report loss of motion, and the hacked DTD sets a parameter that isn’t present on the PSP01 datasheet (it’s present on other Philio sensors though). It could be firmware dependent for example, which may explain why it works for some but not others.

#4

I had a chance to test the driver. It works well once parameter 7 is set to 22. To get the device to take, I set the dips to off-off, did the 3 short 1 long press reset, then readded my sensors with the test disable lever pressed down. It’s properly triggering off after 24 seconds. Good job my friend, saved me having to buy some monoprice multis.

(Philip Street) #5

Cool! Glad it worked, I’ll have a go myself. Perhaps I could try setting parameter 7 as part of the initial config; I’ll let you know how I get on.

Thanks for testing and the feedback.

Phil

#6

Yep, i set parameter 7 during initial config, but 22 might not be the best setting. There should be a way to have it report temp and lux each time it detects motion the way some other multisensors do. Right now, the lux update is too infrequent (default set to hourly, but setting it more frequently drains batteries faster). Also, it can read the lux when the light happens to be on, and cache that for an hour which is silly. If it can be sent along with motion trigger, the rule can decide if it’s too bright already and skip the light). Parameter 7 is mostly undocumented in the psp01 manuals I’ve found, I’m not sure if there’s a better reference. For now just having motion triggers is giving me some good mileage.

(Philip Street) #7

I was going to ask how you knew to set parameter 7 to 22. Where did you get that from? Another manual, DTH or forum post?

Phil

#8

That was from the device driver for the psp01-2 that was posted earlier. The comment was “this make the sensor report end of motion” but I’ve found only limited data about what the individual bits do. One bit was for high sensitivity, the others are unknown afaik. I also recommend looking into openhab device scripts since zwave parameters that work with one platform usually work with the others.

(Philip Street) #9

I found this post on the OpenHAB forum (https://community.openhab.org/t/openhab2-zwave-philio-psp01-multi-sensor-3-in-1/11333/5) that seems to suggest that the “motion off” trigger is sent via the Basic event.

I’ll have a look for parameters settings from other platforms as well. Thanks.

(Philip Street) #10

I’ve updated the device handler - see new URL to GitHub folder in original post.

I’ve added a few things:

  • configurable logging level
  • default parameter values assume Security mode + Celsius, Enable temp monitoring + Enable PIR integrate illumination, Enable PIR super sensitivity mode

It now (mostly) reports temp & lux readings when motion is detected. It occasionally misses one of them for some unknown reason.

I have noticed that it reports inactive motion much quicker than the supposed configuration suggests - 3 ticks (24 seconds) - as mine reports inactive motion after as little is 5 seconds irrespective of what I set for parameter 8.

Mii - give this a go and let me know how you get on.

Phil

#11

Thanks,

I will definitely try that tomorrow. Regarding the faster response time, perhaps you may be in test mode? That can occur if the tiny lever switch on the back is not depressed. That overrides the setting on the two dip switches or on the parameters.

(Philip Street) #12

Thanks, I’m pretty sure the switch is depressed. I was testing the device on the dining table; it was on the table with the switch underneath, so the switch should’ve been depressed. I also opened the device and the two dip switches are off / off, which I think is correct (program mode).

I’m just happy it now reports inactive motion, albeit very quickly.

Phil

(Nick) #13

Hi Philip_street and Mii, I also have two of these Philio PSP01-1 multi-sensors which worked fine on my old Zipato, now I am going to try and add them to the SmartThings with the help of this thread and you guys. (also adding my first DTH btw … :slight_smile:

So which mode should the dip switch be in for this DTH to work? Out of the box they are in ON-ON (Test Mode).

(Nick) #14

Added and it’s working! Thanks guys.
I’m in Europe so had to cut-and-paste the code because github integration not supported outside the US.

How should I have my dip switch? Now ON-ON.

(Philip Street) #15

Apparently there is a way to connect to GitHub outside the US;

I haven’t changed the dip switch on my sensor, so they are default (whatever that is). I’ll have a look later.

Phil