UK Github Working!

Was going through a the CoRe thread this morning and noticed a post by @nitin.samani mentioning Github,

Low and behold it worked and I’m now in sync with various repos…

The URL is:


yep I’ve now got the Git hub column on the IDE.

Testing time

1 Like

Excellent news. I will give it a go.

can confirm that i’ve just been able to authorise it too. Big news

Yep, all good

Thanks for the news

I’m up and running as well. Now to find some more SmartApps :slight_smile:

Finally!! Thanks!!

Moved into UK section. Thanks @mattjmiddleton for finding this!

Is it just me, or is the integration really flaky? The repository’s I’ve subscribed to keep disappearing from the ‘settings’ screen, and the commit / update from Repo only seems to work some of the time - mostly the Update from Repo doesn’t recognise when there’s a new commit to my master.

Anyone else having similar problems?

Got it working on the EU site. But does anyone know how to add multiple repos? I don’t really like having my code in the main repo.

Never mind, just found it under settings on the “My Device Handlers” page. :slight_smile:

Okay question. I have CORE installed (Not via GITHUBAuth) The old fashion code way. Now if i Github install core and remove my Code way will i lose my pistons? Whats the best way to keep my pistons (I have a lot and at the moment everything is running perfect) I also take it the GitHub way updates automatically?

Hi Stuart - should make no difference at all.

Before the Github integration I had mine installed the old way - adding the repo will not delete your pistons etc, it justs syncs the smartapp code.


PS: Don’t delete your code - just add the repo and sync.

Add the Repo? Sorry not that tech savy

Dont worry. Think i worked it out

Hi Stuart.

Firstly click

Follow instructions to add your SmartThings account and GitHub Account.

When done you should see Commit Changes and Update From Repo buttons in IDE > SmartApps

If you the click the Settings button you will see “Add new repository”

The options then available are Owner / Name / Branch

For CoRE the owner is ady624 - Name is CoRE and branch is Master.

Once added you should be able to update to latest CoRE version by clicking update from repo.


Right done all that. Just dosent want to update :frowning:

Thats what i end up with? See anything wrong?

Click update from Rep - select CoRE - then on the left will be any updated versions, select all that apply.

Then in the bottom right tick the publish box and click execute update.

Getting nothing