Peanut Plugs - Can't add new plugs?

I’ve been using the Peanut plugs for a few years with no issues at all. I recently bought a couple more, and cannot pair them for the life of me.

I’ve tried paring them to multiple hubs with multiple phones using the classic app. Plugged in a few feet away from the hub. Reset multiple times.

Anyone else having similar problems? Any other thoughts or suggestions?

Are you using any custom device handlers? If yes, login to IDE, open the device handlers and Publish for me. Then reset them and try to pair them.

1 Like

Thanks. I have a custom handler which is published. Works fine for the other half dozen that I have hooked up previously.

The problem I’m seeing is that they don’t show at all when trying to pair them.

Ok, follow my instructions and see if they pair please.

Thanks, will do tonight and report back. Curious - why would republishing a device handler that’s already published allow me to see/pair with a new device?

There is a known issue where device handlers can become stale. Existing devices will continue to work but you can’t add new ones until the DTHs are Published for Me again. :slight_smile:

May or may not resolve your issue but worth trying.


Thanks, @jkp! After republishing the DTH it worked with no problem.