[OBSOLETE] Zooz Zen22 v2 Dimmer

I’m going to look at this dth a little closer tomorrow but part of the issue is that it is reporting both the physical and digital status. I think it’s a firmware thing, to be honest because I couldn’t do anything to stop it in the handler itself.

The physical/digital thing is an issue for non-dimmers. For this one, the firmware is returning an extra (basic) report on every action, in addition to the multilevel report. So I removed the basic report. Should now get only one event displayed in the device history.


Device history looks good! i’ll take a peak at live logging when i’m home tonight.

Did this all get sorted out?

Just ordered a couple, can’t wait to try them out!

@doncaruana, thanks in advance for the dh! Wondering if this switch like many others needs/has the option to specify what load type is being used?

Also wondering if the 15W minimum Led load they state hasn’t been an issue for anyone? I know I have one circuit that only has two leds on it and I’m a little concerned…

Haven’t tested any load minimum but there is neither a need or ability to set the load type that I have seen.

1 Like

Are you able to take a look at your devices and see if you’re able to set dim level to 100%? It won’t let me set it past 99.

Also, any chance of adding arrows beside on off button to adjust dim level? Like this:

No devices can be set to 100. The Z-wave standard actually only supports 100 levels, including 0. That means it can only be up to 99%. Unfortunately, smartthings doesn’t allow you to limit the slider in a light control to 99, so it “allows” you to slide it to 100%, but then is corrected back to 99%. However, 99% is actually the brightest you can go anywhere. All z-wave dimmers work this way - GE, Leviton, Fibaro - you name it. It is the nature of the hardware platform.

I’ve been told someone managed to trick a handler to get around this and I played with it, but couldn’t get it right and, frankly, it wasn’t worth the effort. I tried contacting the author for some help but never got a reply.

As far as the arrows, I’ll try and take a look at it, but I’ll be honest - it won’t be soon.


I have a question. I added the device handler to smart things IDE but it is green(file is not in repository). Do i have to save this somehow to my github account? If so how do i do that? sorry, newbie here

This is excellent. Thank you.

I noticed a typo “LED Diabled”. Missing S.

@doncaruana will you be releasing a new handler for the new ZEN22 that has adjustable dim rates?

Working on it this weekend, around some family activities. And I’ll take care of that typo too. :slight_smile:


The handler’s been updated. As per my original post edit, the handler has no way to tell between the new switches and the old switches, so older switches will show the fast ramp parameter but it won’t do anything. The new switches are any purchased after 2/1/18.

I’d like any feedback from folks on the double reporting issue that showed up before as I juggled a couple of things.

Thanks everyone and enjoy!

1 Like

Is fast ramp the only option in the spec for the switch? Is there a way to remove the ramp and just make it switch on to 100% immediately?

The spec for the parameter is:
0 (Default)-100% brightness within 2 seconds and off in 4 seconds, 1-instant 100% and off in 1 second

Not sure if this would be off topic, but I have a Zen22 that I purchased last September (so version 2.0?). I get it on the hub just fine with this handler and it seems to work for a few times around before it stops responding to SmartThings requests. (on/off/dim). I see the events in SmartThings, but it’s not processing them.

I’ve removed and readded it a few times already, and even kept the default name. Anyone else have this issue (and maybe a fix/workaround)? My hub is about 25 feet from the switch, so I don’t think it’s a distance issue.


Update: It just seems spotty due to it being “Cloud” controlled perhaps? Sometimes it works, sometimes it doesn’t.

Depending on the construction of the house, 25 feet may pose a range issue. Is the switch box plastic or metal? Have you tried installing a Z-Wave plug or repeater halfway between the hub and the switch to see if it helps?

It’s an older gang box unfortunately, so it’s metal. I should have some z-wave plugs hanging around, so I’ll give that a try. It’s interesting in that when it wasn’t responding, if I toggled it manually on the switch itself, the status would update immediately on the app in real time, which could have just been the luck of the draw for the signal when I was looking at it.

I live in a split level home. Main entry level is where the switch is, then theirs upstairs to bedrooms and downstairs to the den (where the hub is), and there’s a basement off of the den. I may move the hub to the main level and see if that helps.


1 Like

Very disappointed to see that although I purchased version 2.0 last year that my switches are not eligible for the adjustable ramp rate!? I don’t even see anything describing the change on @TheSmartestHouse product page. Will you guys swap mine for ones with this feature? I said from the first day I received mine that it should have been an included feature.

Sorry to hear that! We had technical issues fitting this feature in the software before the initial release of Version 2 and didn’t want to delay the launch so we decided to go without it. We don’t really advertise it because for now, the change is only accessible through advanced settings which means that users outside of Vera, SmartThings, and a few other open options, won’t be able to benefit from it. So we don’t want to create more disappointment by bragging about it.

Of course we’ll replace the dimmers for you if this feature is important to you. Just get in touch with our support and request a replacement.


To get the fast ramp to turn on/off immediately I set the preference to ‘true’ in the IDE. Is that the correct manner to set this? I do not see this option in the app.