[OBSOLETE] Xiaomi Sensors and Button (beta)


I want to use the button with webCoRE in the end, but this “troubleshooting” that I was doing was directly in ST app.
I am using version 1.2 by bspranger.
It is also possible that I got lost in the topic at some point and maybe I am not interfering where I should. These topics tend to get very long in a very short amount of time.


Yeah they can be tricky little devils to get working… wish they sold them in the US…ordering from over seas is rough. I’d like to get about 4 more of these.

What’s the rough part? Waiting the month for the container shipment to arrive? :wink:

Did u get the WXKG11LM to work properly?

what is the catchall log, and how to find it

There is already a working device handler for the Aqara Button model WXKG11LM, available from the bspranger/Xiaomi Github repository (see this forum thread for more information.)

In fact, I’ve been working on an update that will work with both Aqara Button models (WXKG11LM & WXKG12LM), and the pre-release device handler code can be grabbed from here.

Please note that with the Aqara Button model WXKG11LM, there is no possible way to implement a hold function. A hold function is only available with the round “original” Xiaomi button, or the Aqara Button model WXKG12LM.

Thanks for the replay.

I have that device handler. My problem is that a press on the button does nothing but a checkin, a second press about 5 secubds later registers as a press.

So you used pre-release device handler code that I gave the link to?

I think I can help solve your problem, but please do the following steps:

  1. Download and install my pre-release Aqara Button DH code again (I have updated it since yesterday) from here.

  2. Viewing the button in the SmartThings mobile app, open up preferences, scroll to the bottom, and make sure the display of both info and debug log messages is turned on, like this:

  3. Open the Live Logging window of the SmartThings IDE for your hub.

  4. Press the button of your WXKG11LM a few times

  5. Isolate the log messages that are just for that button by clicking on it’s name in the Live Logging window

  6. Take a screenshot showing the log messages that happened when you pressed the button, like this:

Based on those log messages I should be able to know what is happening.

Everytime I have a power/internet outage (which is not infrequent), all my Xiaomi sensors stop responding once the power is back. I have a huge mixture of smart devices and these are the only ones that do not reconnect (Keen Smart Vents have an issue with going into a ‘sleep mode’ that requires pushing the sync button to activate, but only after power being off for at least a day).

I can easily get the Xiaomi Aqara devices operable by pressing the button on them a few times, but I don’t always have access and it’s a becoming a pain. I can see any way to do this remotely within the IDE or the app.

Any ideas?

Does the Xiaomi button support double press and long press also can it be used to say turn a light on and off toggle with say a single press?

The button supports pressed and held. You can set a routine to have it control anything you want.

I have tried to set the single (short) press to turn on a light and the long press feature of the Aqara button to ‘turn off’ a light. Turning on the light is working but the long press to turn off the light is’t functioning after I made a rule and assigned the long press feature. What am I doing wrong?

Can you see the held event under the “recently” tab for the button?

No, only “button was pushed”. Nothing else. Could it be this function is missing in the the device handler (bspranger v1.2)?

There are currently 5 different types of Xiaomi branded buttons devices. Each one has different functions available in SmartThings.

Which model number of button are you using?

Hi Keith,

Sorry for responing a bit late on your question. I currently have 3 model WXKG11LM buttons. Recently I ordered a new 12LM version. Have read somewhere it might be a hardware issue. The 11LM version does not support the hold function. The 12LM version should support this. I hope :wink:

I have 2 of the G01LM buttons and I am using the original A4refillpad DTH. If I switch to the newer BSpranger DTH I lose the held function.

It’s not a hardware issue. The Aqara button model WXKG11LM simply doesn’t provide any way in the hardware to implement a hold function. However, the Aqara model WXKG12LM does support it. If you look at the header information section of the Aqara Button device handler code, there is a detailed explanation of the capabilities of each model when used in SmartThings:

For more information, see my announcement post about v1.2 of the Aqara Button device handler here.

Which version of the bspranger DTH are you using?

Version 1.2, which I worked on and was extensively tested, does have button hold function, and improves on it. It was announced on the Original & Aqara Xiaomi Zigbee Sensors (contact, temp, motion, button, outlet, leak, etc…. thread four weeks ago:

It was a while ago, so not this newest version you show above. I may give that another go them as it looks quite clean. FTW the original A4refillpad one has never missed a beat in the last year and a bit I have been using it.

My Xiaomi Agara Temperature / Humidity sensor shows up on the SmartThings IDE in My Devices and on the SmartThings app on my Android, but when I select the device I get a pop-up ‘Can’t connect to device. Check device and try again’.
I am using the bspranger : Xiaomi Aqara Temperature Humidity Sensor Device Handler.
The IDE events list shows continuous temp & humidity readings.
Any help would be appreciated.