[OBSOLETE] Xiaomi Sensors and Button (beta)

I’m having difficulty setting up my button. I’ve got the device handler installed, but I wasn’t able to pair directly on the device, so I ran pairing mode and accessed the catchall event. I’m getting the 7th pair of digits in and manually created a new device using that as my ID. I get no response from the button. I went back over my steps and the new event has a different number, I ran it again and a 3rd number was generated. I’m not sure what to do here.

Screenshots?

One of my Xiaomi contacts does not update properly in the smartthings app but it works properly. Any idea how to fix that? The override function will correct it but not permanently

Thanks

Is there still a known issue with hub V1? I have everything working then after a few hours sensors stop responding. Repair and it works…few hours same issue.

Just received the V2 hub and repaired my devices… Everything is working much better now. V1 wouldn’t last longer then 30 mins or so. All day and no issues with V2. Manually paired.

My xbees are still working. Been rock stable for ages (months). I wonder if there is some strange interaction with the IKEA bulbs I have that means they work. They have sorted all my stability issues this is all over a single story 3700ft property…so quite a challenge

Surely smartthings know why a V2 hub is different to a v1 … This would provide some info

1 Like

Hi there,

I’m having a bit of trouble with the Xiaomi Temperature and Humidity sensor.

I’ve managed to get it to pair to the hub
It appears initially in my list of things in the Smartthings App as just ‘A thing’.
I’ve installed and published the device handler
I go into devices and then change the device type to ‘Xiaomi Temperature Humidity Sensor’
It’s at this point that things go wrong.

First time I clicked on the device in the app, it loaded great… took a while for the numbers to come through from the device… but it all looked like it was working fine… only thing which wasn’t working was the battery info. I went to check it a few mins later to see if the battery info had come through, and the device had completely disappeared from my list of ‘Things’ in the app.

If I switch it to another device handler… the device reappears in my list of things… switch it back to ‘Xiaomi Temperature Humidity Sensor’ and it immediately vanishes!

Despite others having problems, I haven’t had any problems pairing it with the hub, so I have deleted the device and re-added it a few times… exactly the same thing happens… it works great (other than battery info)… but then just vanishes from the ‘my things’ list when I look for it next time (even just a couple of seconds later!)

Does anyone have any ideas?

P.S. I have it on the ‘Netamo outdoor’ Device handler at the moment and it seems to work fine… is there any reason why that would be a bad idea?

Paired a contact sensor and motion sensor yesterday. The contact sensor seemed to work great. The Motion Sensor seemed a little wonky at first. Both are now unavailable. Do I just need to re-pair them like I did the first time or do I need to exclude and re-pair ?

Is this the round Temp & Humidity sensor or the square-shaped one?

Which device handler are you using? I highly recommend using the most up-to-date ones on the bspranger/Xiaomi GitHub repository - please see this thread for more information and links to device handler code. The new Temperature and Humidity sensor device handler will make sure SmartThings recognizes it and not be added as a generic “Thing.”

The first battery level report does not happen until about 60 minutes after pairing the sensor.

I have never heard of a device disappearing from the list of devices in the mobile app. Again, I recommend using the most up-to-date device handler. That may help fix this problem.

Probably not a good idea. All of the Xiaomi devices are different in the way they report, and the way battery level is reported is different from the standard method of Zigbee devices, so using any other device handler means the battery level will never show up in the app. Please note that the a4refillpad device drivers do not correctly calculate the battery level - again, I recommend using the device handler from the bspranger/ Xiaomi repository.

1 Like

Which models? There are two versions of each - the “original” Xiaomi model and the Aqara model. Please see this webpage which has photos to determine which model you have.

The Xiaomi Motion Sensor goes into a hardware Test Mode when paired, which lasts for about two hours. During Test Mode, it can sense and report motion detected every 5-6 seconds. After two hours, it goes into Normal Operation Mode, and when motion is detected, the hardware is “blind” to any activity for 60 seconds. After the 60 second “blind” period, it can then again report motion detected if it senses it.

Which SmartThings hub do you have? The v2 hub is the only one that seems to be able to maintain connections with Xiaomi devices.

Do I just need to re-pair them like I did the first time or do I need to exclude and re-pair ?

Xiaomi devices are Zigbee-based. Zigbee does not have an exclude mode, only Z-Wave has that. If you have a v2 hub, I recommend deleting them from your devices list, and then re-pair them (meaning holding the Xiaomi device’s reset button in to put it into pairing mode).

For more information on pairing and the most up-to-date device handlers, please see this community thread.

@adam_walker - it’s great that they are working for you so well w/ the xbees. At least for me the xbees are taking on some of my Quirky Trippers and giving me back a few slots for Xiaomis (and probably strengthening network in general as you say). That’s an interesting theory on the Tradfris from Ikea - I have a few but have them all paired to my hue hub so it wouldn’t help. Maybe I’ll ‘liberate’ one and see.

Anyhow I’ve really enjoyed learning about and working with the xbees.

Any news on this?

No, haven’t heard any news about it.

If you have an always-on X86 or Arm-based server, there is this solution for SmartThings:

Thanks for this reply. I have changed out the DTH’s for the bspranger ones. I had been using the a4refillpad set originally. Also moved the sensors to a different location to continue testing them.

All,

I’m using the Xiaomi original round button with Veeceeoh’s latest Device Handler committed yesterday. 3.26.18.

I’m attempting to utilize the button with room manager to set room states. For example, upon button push, state of room changes to alseep.

The button fails to function as expected. Observed behavior is the fact that the button appears to be always pushed, thus failing to register as a button push within the room manager.

Further the button exposes only as only one button. I’d figured with the held functionality afforded by the new DH, that there would be two buttons exposed to Smart Things. That is one for push, two for held.

Please advise upon the information I can contribute to troubleshoot and resolve said issue.

The version committed on 3.26 is still a beta version and currently being tested.

It would be most appropriate to PM me with questions / feedback, or if you have a GitHub account then post questions / feedback on the comments thread of the Pull Request for the DTH beta version update.

I have the same issue. Pressing the button manually generates only a “Last Event” action, but no actual push of the button to be detected. :frowning:

Which version of the Device Handler?

Are you having the problem in the Room Manager Smart App as @Turtle described, or in another Smart App?

I cannot help if I don’t have all the details…

Thanks for all this info. With your help I managed to get it all working great. Thought I’d just check in to thank you. :slight_smile:

2 Likes