[OBSOLETE] Woo! Sylvania/Osram Lightify motion sensor works (model 72923)

Posting this because I could find NOTHING when I searched
this sensor:

works with the SmartSense Motion Sensor DTH flawlessly.
it’s not auto-detected so you’ll have to go into the IDE to change it


After several attempts I figured it out!

I went to GitHub (Smartthings Repository) and searched the Samsung smart motion sensor device handler. Below is the link to save others time.

Go to your SmartThings IDE click on my device handlers then click create new and select “from code”.

Back on the GitHub website:
You then click on the raw format.
Select all and copy /paste it in to the “my device Handler” section of your SmartThings IDE.

You then save and publish it.

Next go into “my devices” in your SmartThings IDE, select your lightify motion detector and click edit.
Next scroll down to where it specifies “type”, and using the drop-down menu select the last device handler which you just added.

At this point I could see the battery but nothing else, no motion or temperature.

What I had to do to get it to work because it was to fully remove the sensors and then readd them back, they appeared again as generic “things”.

I then went back into the device properties for the thing edited the name and selected the proper device handler I just created which is found at the very bottom of the drop-down. After clicking save and waiting about 30 to 60 seconds in the SmartThings app the temperature the battery and motion sensing started working.

Below I’ve included the device Handler link I used located on SmartThings GitHub.



I got everything working but motion. The app always has it selected as blue so im not sure whats going on exactly. I’ve tried re-adding it several times but the same thing, any thoughts?

Nm, it all works now.
I was waiting for some sort of indication that it was active/inactive visually on the device but apparently its super sensitive so it was picking up my typing! and keeping motion on the whole time

awesome stuff, got it all working.
The real trick is to add device, update type, delete device, add device, and update type and by this 2nd time, all should be working.

*Using these tools you can manage your hubs and devices, give them unique names, and organize them into locations and groups.

Access your developer tools: create your own apps, create your own device types, view your logs, and access developer documentation.

I’m in the same boat… any luck. I save the Smart Sense Motion as a new device handler as IS and then later with a different name - tried adding the device once, deleted and then re-adding and re-changing as suggested above. The device continues to show as “continuous motion” on the ST app, and it does not show any events at all. Any other suggestions ?

Same steps as skhandu above and same result. :slight_smile: seems like now we need more work on this device to get it to work.

That’s tooooo much work for a Temp/Motion sensor… Why not just purchase another brand. Iris has them and they integrate flawlessly…

Iris Motion Sensor https://www.amazon.com/dp/B01GCKAF6K/ref=cm_sw_r_cp_api_EDEKAbNQG4XWD

yeah things I would do for saving $10 bucks right :slight_smile: actually it’s working now. Just have to press that single button on the unit after adding the second time (to turn it on?) I know it said hold over 10 seconds to reset but I don’t know why it would need a reset and I am sure I didn’t hold the button for 10 seconds. pressed and hold for couple of times and I suddenly see violet light on the unit (to indicate motion) and the smartthings mobile app refreshed with temperature and battery status.

My research for a solution to make the Sylvania/Osram Lightify motion sensor work with Smartthings led me to your post with Device Handler. Just wanted to report that this device handler solved my problem and it is working great. Thanks.

Worked fine - thank you for the details - I just wanted to point out that it might take some time after updating until the device actually shows temperature etc. On the app it took me a few ‘refresh’, maybe 30 sec, until it was working.

My Sylvania sensor only seems to update temperature when you ask it to refresh in the mobile app. I have already deleted , changed DTH, re-added, deleted, re-add. Has anyone gotten theirs to work similar to the Samsung Motion/Temp where it updates when the temp changes by a degree? I am not using the Custom DTH. I am using the Samsung Motion DTH as others suggested.

1 Like

Thank you! This is awesome. Got mine working as well. I got it for pretty cheap on Amazon.ca

Does the temperature capability work with this code? Looks like it’s just using the smartsense motion sensor code…

Need a little help… How do you get the lightify to show up? It’s not on my list to click edit.

I set up the device handler and published it, however this next step is missing for me