[OBSOLETE] SmartLife (H801) RGBW LED Strip Wifi Controller & Bulb

@michaelahess got a simple question. I want to drive a high amp relay from any spare channels of the H801. I don’t want to mess this Sunfounder relay board up that just came in today. I was going to originally just run the VCC , In1, In2, Gnd right from the H801 but before I did I saw this detailed info about the Sunfounder relay I got. and I wasn’t understanding without doing damage. Not sure why there was a J5 jumper on only one of the inputs? Can I use the 12V that is coming off of VCC of the H801 that powers the RGBW strips into the VCC of the dual relays?

You can use the 12v out from it but if using a relay why not power the h801 in parallel, then just have the 5 channels function as the relays trigger? Amp draw through the device would be my concern, and negate the actual purpose of the relay being that is high voltage. Or I don’t fully understand your use.

It would appear that relay requires 5v on the trigger so you would only pass about 40 percent on one of the channels or risk overloading the relay. A custom DHT that only allows a power state at that level would be recommended. Test with a multimeter first if you plan on doing this.

Thanks Michael. I wasn’t sure if putting 12v on that relay circuit board was going to hurt that circuit. I tried to use the 3.3v from the H801 board and nothing happened (I assume due to the voltage being too low)

My use case is I need to get some dry contacts for operating an up and down lift. Instead of using two separate z-wave relays (expensive $75) to operate the lift I wanted to use an H801 triggering either relay. For about $20 I get two independent outputs that I can control (MUCH less expensive)

I don’t quite follow you here?

You dont need those boards, they have a transistor on them to drive a relay from the gutless output of a microcontroller. The 801 has 5 even bigger transistors in it (mosfets) to drive many amps worth of LEDs.

Just get 12v relays and put them on the output of the 801, you will need to add flyback diodes to them to stop the kick when they switch off going back into the 801. I will dig up some links with schematics to post later on, but pretty much any 12v relay will be fine once you put a diode across the coil.


It might be easier to get yourself a couple Sonoff and avoid all this faff as they can deal with 10A plus and only cost $6 each…


This is good advice, the Sonoff’s are wonderful as just a simple, very easy and reliable switch.


Easy and cheap? This simply won’t do. Any of my projects need to end up costing 4x what I originally planned and take at least 3 months to implement.

Seriously, thanks for pointing these out. I hadn’t seen them before.


I considered that at first but I need to have dry contacts to input to the lift controller not voltage. I don’t think the Sonoff can give me dry contacts?

You can have dry contracts by cutting two traces that are on the edge of the pcb and are separated from the rest of the PCB so wouldn’t take long to do. Then a wire to connect the cut traces to ensure that the screw terminals are connected to the relay.

EDIT: Take it back, the wire is a bit more awkward as the trace to cut is less accessible. Let me check the PCB when I am home to give you the easiest instructions.

Take a picture if you can so I know exactly where you are talking. I have a Sonoff to try it on.

Ok, so here is the image of where to cut and add a wire. It isn’t an ‘easy’ cut as it is quite tight. However the black box is where the relay is and red box is the bit that needs to be removed, while the blue bit is a new wire link you need to add. This will make the Sonoff have volt free contacts.

The key thing to check after you have cut the PCB is that there is no connection between 2 and 3, but there is a connection between 1 and 2. I have shown the top of the PCB so you can see which trace needs cutting. A small hacksaw would be perfect, just go slow so that you do not tear/cut any components. The result is you have mains in on one side and volt-free on the other.

It shouldn’t be too hard, but if you don’t want to do it then the only other option is to buy a separate 3V3 power supply and connect to the breakout pins (used for programming) and then you only need to cut the tiny trace to the left of 1. Do not do this unless you have a 3v3 power supply!


Seems my Sonoff is a slightly different revision level. The other terminal trace in now exposed on the bottom layer with a heavy load of solder.

Ok no problem, the same applies but it is even easier since the trace you need to cut is more accessible/visible. You need to cut the bit in the following image, in the same way as above

The only difference is that you need to cut less of the PCB in order to break the connection between 2 and 3. Using a sharp-ish hacksaw will carve through solder with no problems as it is so soft, so that shouldnt make a difference to the process. After completion you should see that the two screw terminals on the right are either disconnected or connected depending on the switch status (and no voltage will exist there) - maybe check with a multimeter first as I cant see the top of the PCB, though 99.99999% confident the above is correct.

one of my H801 unit stopped working. well I was not using it to be frank. I bought it, flash the firmware from Eric as in first post, tested it and stored it as backup.
Now when I wanted to use it, I tried power it on.
When attached with 12V power, it only green LED is on, red LED is very faintly on which you can see only when you remove the cover.
Device doesn’t get detected/discovered in app, I’m not sure if it’s connected in wifi network or not.
it doesn’t start with it’s own wifi hotspot as well.

Can anyone suggest what could be wrong about this unit?

If you don’t see it in your DHCP server list, just reflash it and start over. You can try a reset but if things are wonky it’s best to just flash the latest firmware.

Is there a trick I might be missing to get the virtual switches working? I see the switches under my list of devices, but nothing happens when I press the one that I programmed.

Here’s what I’m doing:
-Go in to the SmartLife SmartApp and select the device I want setup a virtual switch
-Select programs and made a simple program with 1 action - fade to red, 10% level, no duration
-0 times to repeat (I want it to come on and stay on)
-Hit done multiple times until everything is saved

The virtual switch I just made will show up under my devices, but doesn’t turn the light on. At first it did nothing when I turned the virtual on/off. Now it will shut the light off if it’s already on, but will not turn it on.

Am I missing a step?

I’ll have a reflash using first post as I don’t know if they are getting connected to my wifi or not.

Sounds right…go into the IDE and Live Logging, see what it shows for the H801 itself, and the virtual device. Maybe removing the virtual switches from the app and recreating would help?

So when I turn the “normal” device on, I see this line in live logging:
{“rgb”:“000018”, “r”:“00”, “g”:“00”, “b”:“18”, “w1”:“00”, “w2”:“00”, “power”:“on”, “running”:“false”, “program”:“1”, “uptime”:“1 days and 1:15:15”}

(This is defaulted to 10%, blue.)

But when I click the virtual device, I see this:
{“rgb”:“000000”, “r”:“00”, “g”:“00”, “b”:“00”, “w1”:“00”, “w2”:“00”, “power”:“off”, “running”:“false”, “program”:“1”, “uptime”:“1 days and 1:13:1”}

I think I see two things wrong there - 1) It should be 10% red and there are no levels being set at all and 2) “power”:“off” should be “on”, shouldn’t it?

I’ve already tried deleting the virtual switches from within the SmartApp and then re-creating them but it didn’t have any affect.


Figured it out! You have to put a duration in. I plugged in 1000ms and it’s working perfectly.

These things are great. I have 3 more now that understand how they work. I’m waiting for some more wiring supplies to come in so I can do the next ones as clean as possible, but they’re going to average less than $20 per 3m strip. Can’t beat that!


These switches are amazing! Big thanks to everyone here for the super helpful guides and posts!

One thing I might be missing is how to use the overall dimmer. I just have a white led (red: VCC on the left, black: W1 on the right), but I can’t use the main dimmer in the SmartThings app to control it (just the white slider in the app). This is too bad, since I can’t use Google Home to set the brightness to 50% or whatever.

Is there a setting I’m missing somewhere? I can probably go in and butcher the device handler but I’d rather not if I don’t have to.

EDIT: Well, I can just connect my strip to the R port and almost everything works. What I can’t do, apparently, is say, “Set the lights to 10%”. I can do that if they’re already on and it adjusts everything just fine, but it seems unable to turn them on to a given percentage. I can do this with my Cree bulb. That seems like an easy device handler change; I’d be happy to make a PR if I figure it out, unless this behavior is intended?