[OBSOLETE] SmartLife (H801) RGBW LED Strip Wifi Controller & Bulb

Finally had some time last night and have added the ability to add a device manually through the SmartLife Connect app. I moved about a week ago and have my main SmartThings system torn down, so I can’t fully test it. If anyone would like to give it a try and let me know, that would be great.

You need to update:
SmartLife RGBW Light (Connect) - SmartApp
SmartLife RGBW Controller - Device Handler

I got my RGBW controllers today and followed your great instructions.
I successfully flashed the firmware, joined my Wifi network, setup the device handlers, SmartApp etc and all was looking good.

However, although I can switch on / off the lights and set the colour through the sliders or colour picker I can’t seem to get the 6 virtual switches to do anything.

I have programmed the switches, and setup the virtual switches but when I click on them nothing happens.

Anybody have any idea what I could be doing wrong ?

My mistake, i hadn’t set a duration.

So to fade to a colour i set a duration and then repeat forever?

Thanks a bunch for adding this feature. I think I have a network issue or something weird between my smarthings hub and the esp8266. I can send commands from the hub using the app, and verify they change stuff using the {ip}/status call from a web browser, but the UI of the smarrthings app is not updating. Looking at debug messages in the developer console, I can see the command going out, but it never calls the parse() function, so for whatever reason data is not making its way back.

From a laptop connected to the wireless hub over the wired LAN connection, I can use my web browser to set things and read the status.

Maybe I’ll try another esp8266 board …

So if you want to just fade between colors you would set the transition to fade, set the color to whatever, and then set the duration to what you desire. So, if I wanted the color to fade from red to green until stopped.

Number of Actions - 2

Action 1 - Red, 100%, Fade, 5000ms
Action 2 - Green, 100%, Fade, 5000ms

Number of times - Forever

A cool one is to just create 1 Random Action. I really like this one:

Number of Actions - 1

Action 1 - Random, 100%, Fade, Random Duration Between 2000ms and 5000ms

Number of times - Forever

Remember to hit done through all the windows when finished so it pushes it over to the controller.

@dumb_thumbs Do you have any wifi repeaters or wifi bridges on your network. I have seen problems when those devices are used.

NEW FIRMWARE - I have been playing with methods of doing factory reset on this device. The new firmware has two methods of accomplishing this. Since the device doesn’t have any buttons by default, I wanted to create a way for everyone to be able to do a factory reset.

  1. This method might be easier to do with a surge strip with a button attached. Unplug controller and plug back in. Within 2 - 5 seconds after plugging in, unplug and plug back in. Repeat this process 4 times. You can know you are doing it correctly because on the second plug in the LED Strip will light up GREEN, the third it will light up BLUE, and the fourth it will light up RED. After it turns RED, you can just leave it alone. The little red led will blink 5 times slowly and then the RED LED strip will start to flash as the storage is being wiped. After that is finished the LEDs will turn off.

  2. After the device is turned on, jump J3 for a) between 10-20 seconds will reset the wifi b) between 20-60 seconds will reset everything. If you reset the wifi correctly the little RED LED will blink 3 times quickly. If you reset all the device settings correctly the little RED LED will blink 5 times slowly.

Let me know if you have any questions.

Also, does anyone have any cool programs to use for Halloween? Looking for some good ideas.


I had a brief power outage and now 2 of 3 controllers are non responsive to commands through the smartapp or atomations. Only the red light os on. Thoughts? Loss wifi connectivity? How do I restore them?

First thing to check is to just unplug them and plug them back in. It is possible that they were up before your wifi was restored and just gave up connecting to your wifi.

The next thing to check is to see if they are broadcasting their access points (espRGBW.[mac address]). If so, just connect to them and reconnect them to your network.

Fixed it by connecting to the device VIA wifi and then going through the config again.

I also had a power outage last night and I had to reconnect all of my H801’s to the network again even though I have them setup with Static IP’s. Is there any way around this problem? Real pain to have to connect and label each device to the network again.

1 Like

That is not typical Behavior. Did you try to unplug and plug them back in after the power failure?

If I run my jigsaw on the power strip I have one plugged into, it turns on, then randomly off, then on. It’s kinda fun.

Yes. That was the first thing I tried. I think the two that I had issues with are running 1 version old firmware. They are in locations that are difficult to get to.

No, once the power comes back on they come back on which is when they all have to be rejoined to the network.

I don’t see that after power failure. Assuming power failure is the same as turning the power off!

Is there any chance somebody could share ‘candy cane’, ‘fireplace’ and ‘christmas lights’ settings?

Amazing work with this project btw, really great!.

I have not experienced it either. Have had several power outages and unplug and plug them in all them time.

@onetrav @pcgirl65 I am trying to gather some more information.

  • What firmware were you running at the time of the issue? You can see the firmware by going to /info. It will show you the version and the date.

  • Did you have to enter the static IP address or any other non-default settings again after connecting it to wifi?

I had a power failure, of my own making, on one of mine. After I powered the device back up, I just got a green light then after 4-5 seconds it went out. I had to actually reflash the device to get it back to life.

That’s on the latest firmware, and right before the power went out on it, it had been flickering. I think I had a loose connection, then I accidentally yanked the power out completely. That could be similar to a brown out condition.

When I flip breakers to do work, and flip them back on, none have had any trouble coming back online. I have 8 of them now I think…

Hey Michael, we seem to be in the same circles::grinning:

Eric, the firmware is 2.0.2. I only use the white connection and my lights aren’t dimmable so I don’t think that I need to update the firmware often. I have had the power go out before but this time the power was out for a couple of hours. Once I reconnected them to the wifi, they had their correct Static IP that I had setup originally.

1 Like

Hi Eric.

I’ve just started following this thread as I was searching for something along these lines. Geat job based on the solution and all the interest in this.

Can ask a question relating the native Smartlife WiFi controller. I’ve been searching for the manual for that product online but not found anything yet. I will be ordering one regardless to have a play with it/the solution.

My question relates to how this works out of the box. If its a WiFi controller, can it response to basic http get/post requests to turn it on or change colors from a typical browser?

I was looking for something urber simple to show a red or green light which I’d then control upstream from another trigger. My use case, if a gate was left open (monitored by simple open close sensor) I would then build a in-wall led and have the status controlled by the sensor all packed neatly inside a homemade decora cover plate to give a visual to the gate status, mounted flush near our rear garage door to glance at before letting the dogs run havoc.

I already have ST virtual switches to issue http commands and they work great. Hoping I could achieve the same out of the box??

Thoughts/comments most welcome.

Can you please describe the process of checking the firmware? /info doesn’t mean much to me. Sorry.