[OBSOLETE] Philio Smart Color Button PSR04 V0.1

I have created a device handler for the Philio Smart Color Button PSR04.

This is the device: http://www.vesternet.com/z-wave-philio-smart-colour-button-gen5

For this first 0.1 version, the capabilities of the handler are:

1. Detect button presses
2. Detect Level when in dimming mode

In the future (if possible) I’d like to expand to:

  1. Detecting button holds
  2. Turning the annoying beep on / off
  3. Timer configuration


  1. Install in IDE as a new Device Handler
  2. a) If you have already included your smart button then find it in the devices tab in the IDE, click edit and change the handler to this one from the default one
  3. b) If you have not included the device then follow the instructions that came with it to include with the hub. Hopefully it will automatically recognise the smart button correctly, but if it does not then just name the smart button and then do step 2a)
  4. Got to the device in the Smartthings app
  5. In very quick succession put the smart button into inclusion mode again (follow instructions) and tap the configure button in the device page in the app

The device should be correctly set up. A quick way to check if it has worked is to put the smart button into dimming mode (follow instructions that came with it), and set the dimming to any increment, and see if the device page in the app updates.

Using the Smart Button

Realistically this device handler is only useful in conjunction with a rule maker like CoRE, Rule Machine, or Smart lighting.

Pressing the button will send Smartthings a button 1 pushed event. So you can use that as a trigger.
I personally use CoRE to send the current smart button level to another dimmable light, therefore creating a wall dimmer… (finally!)

Any questions, feel free to ask. device hander here:


Hi Adam

I haven’t been able to get this DTH to work, no battery reports, and no events are being logged when pressing the button, is there maybe a trick to get the button to update when changing the DTH

Did you configure it whilst it was in pairing mode?

I can’t be certain tbh, as I had a lot trouble adding the device, I think it was added then I subsequently changed the DT.

This step:

  1. In very quick succession put the smart button into inclusion mode again (follow instructions) and tap the configure button in the device page in the app

Is hard to get right - but without getting it right the configuration wont be received on the device and you wont be able to get any use out of it!

I’ll give it a shot, thanks.

Hi Adam,
I’m back after a long gap on smartthings! I got a bit bored, but back with even more enthusiasm! Thanks for the message on the heatit thermostat. I have 3 running on this now and all working.
I just came accross this button and saw that you made a DH for it.
Does it have a colour light built into the button?
Im thinking of using this at the top of my stairs to turn mys system into night/home mode, showing a red light if in night mode.
Do you think this button has the capability of doing that?

I dont think that you will be able to do this with this button - it does have a multi colour light ring on it but it is not configurable in the way that you care describing

Adam, thanks.
Shame, is it configurable in any way at all? Even just an on/off?

Hi AdamV,

Trying real hard to configure my button without success. I’ve rotated it to area A (straight down) and pushing button 3 times within 1.5 sec and hitting configure in the app, but without success. Any idea why?


Do you have the button flat on a table or vertical on a wall?

Vertical on the wall, pointing down, light is whiteish, which should mean zone A.
BTW, why do we need to put it into inclusion mode to configure it?
The problem I see is that it sends notification of button presses, but even if it’s in dimmer mode, it does not send (or receive) anything for rotating it. I’ve added extra debug logs and nothing comes in. Could this be a config issue, you think?
It used to work well with my fibaro hcl hub, but that did not work with the devolo buttons, so I switched to smartthigns.
Thanks in advance

  1. You need to configure it to set the button to work correctly with ST

  2. You need to put it into inclusion mode to do this because, as this is a battery powered device most of the time it does not listen for commands from the z-wave gateway (ST) if it did, it would burn through the battery in a day. So instead it only “wakes up” periodically for short periods to check status etc. You can force a wakeup by going into inclusion mode… and thereby allowing the device to receive a new configuration.

  3. So you say that it is getting button presses… but not rotations? Sounds like the configuration step has already worked!! So stop trying to configure it!

  4. Sounds like you havent activated dimmer mode on the device (please see instructions) - https://domboo.es/wp-content/uploads/2015/11/Manual-Mando-PSR04-de-Philio.pdf

Thanks! Could I implement config as something the app does the next time the device is awake? Like whenever we receive something from the device, I guess it must be active. It would also allow for a confirmation of config through reading back params.
I did put it into dimmer mode. I can see it also by the red blink after rotation stops. However, I see no message on the ST. Could it be a problem with association groups?

I wouldn’t do that (config) - unless you plan to change it back again. Simply because of the battery issue. You don’t want ST to update the config every time it wakes up - it will be a battery drain.

Maybe it is an association issue… however. It’s working well for me so I’m a bit lost here!

My idea was that pressing the config button will mean that it’ll do and verify the config the next time the device is awake. This way the user would not have to time the two things. I would not send the config every time, just once.
I’ll check the associations and config on my unit and will share the results.

That may work - let me know how you get on

Hey @AdamV thanks for the DH!

Not got my hands on one yet, hopefully this week but wanted to ask if you had or had any plans to expand on the DH to add button holds and the Timer config. etc. ?



I do have plans to do that… Just not in the foreseeable future… unfortunately I’m having other issues with my system so this is right at the bottom of the priority pile

1 Like


It’s been a while since anyone responded in this thread.
Im trying to get the Philio button to work with the instructions provided here, without lock.

I can get it to register button press, this is what the log shows.

19:34:58: debug This is what I receive: SecurityMessageEncapsulation(commandByte: [21, 0, 1], commandClassIdentifier: 91, commandIdentifier: 3, reserved13: 0, secondFrame: false, sequenceCounter: 0, sequenced: false)
19:34:58: debug Button 1 was pushed
19:34:58: debug sequenceNumber: 21
19:34:58: debug sceneNumber: 1
19:34:58: debug keyAttributes: 0

But it doesn’t register rotation.
This is what i get in the log

19:26:15: debug This is what I receive: SecurityMessageEncapsulation(commandByte: [], commandClassIdentifier: 132, commandIdentifier: 7, reserved13: 0, secondFrame: false, sequenceCounter: 0, sequenced: false)
19:26:14: debug Resetting Sensor Parameters to SmartThings Compatible Defaults

It’s configured in dimmer mode.
Super thankful for any advice on this.