[OBSOLETE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

I had started a thread in another category so bear with me. I got bit by the Chamberlin API change and updated the MyQ app and handler in the IDE. I was hoping this would fix the Smartthings integration.
I updated the MyQ Smartapp but I have a problem that probably isn’t related to needing an update as this happened before I updated. I cannot put my username and password into the app anymore. I removed the SmartApp and I am attempting to add it back in and username or password error occurs. I worked with Chamberlin support to be sure I could log into their MyQ website okay, which I can. But the app is acting like the credentials are wrong. I am currently not at home on my network, can that be an issue? I am remote.

?? This all worked before.

1 Like

Seems like it’s rejecting your account for some reason. What kind of door do you have? If you’d like to PM me a temporary username/password for your MyQ account, I could take a look at the API response.

Do you by chance have a Craftsman door? I know there was a change where those users need to transition over to MyQ accounts. Are you able to login ok on the native MyQ mobile app?

Thank for the quick reply!

No, I do have a Chamberlain door. Here
Is the strange part, and may take a while. I noticed there are 2 different myQ websites. I was able to log into one of them and I did a mental note of password. I tried this pw in the Smartapp and it failed. I tried this password in the myQ app and it failed. I tried one of my variations of this password in the myQ app and it worked. Did not work in the Smartapp, no password variation worked.
Also, when I was updating I saw the Smartapp in the obsolete column, and there was still a mismatch on ide and repository versions. I am slightly confused on how the IDE github stuff works. But I did get the local and repository versions to match and still no love. I was thinking of totally removing it-clean, and reloading the app with GitHub or do it manually. I tried loading the community installer but don’t see it in my apps on iPhone. Also note I do not see anything in the logging part of IDE, no errors.

A good reason I installed a new garage door and opener is so I can automate it. It’s a little frustrating right now. Thanks for listening.

Mine did that a few times and then the physical wall switch failed. Replaced it and have not had that issue again. I have to assume it (mine) was hardware related.

Since, I also setup alerts (using webCoRE) to let me know if it opens and I’m not home.

Starting fresh does sound like the most likely option to work. The Community Installer is a separate app you’ll need to install first if you want to go that route.

If you still can’t get it, feel free to PM me, and I can try to take a closer look with some temporary credentials. It should definitely be possible to get it work for you…just gotta figure out what’s going on.

I’m receiving daily “MyQ Lite Updates are available” notifications. I have updated the app through the Community installer as well as through the IDE but keep getting the notifications. Any ideas on what I’m doing wrong??

I have just installed this on the new smartthings app. I also have a gocontrol installed and that is what I’m using for the door sensor.

When it made the virtual switches the two open and close ones do not work. I can however open and close the door from the device handler that shows status of door and door controller. Is there something I did wrong in setup that caused those virtual switches not to work?

If you’ll open the SmartApp page in the mobile app and scroll down to the version section, it should tell you which piece has updates available. There’s also a toggle there to disable those notifications if you’d rather not bother updating at the moment.

This SmartApp is not yet officially supported on the new SmartThings app. Do you see the same behavior when you try those things in the SmartThings Classic app?

Is there any way to get a wired open/close sensor to work with this. I hate to have another thing that I have to change the battery. Maybe something like this: https://www.amazon.com/gp/product/B000GUSNQW/ref=ppx_yo_dt_b_asin_title_o06_s00?ie=UTF8&psc=1


Thank you. I hope by PM you meant email. At any rate I deleted the smart app and handler (I have a door sensor so I only

use the one handler). Waited a couple hours and installed all over again using the instructions on GitHub. In SmartThings I tried to

add the app again under myapps but still get a password error. Note I still use the classic app on my iPhone.

Note I am fairly adept at techie stuff as I am a Systems Engineer/support guy. So this just frustrates me more knowing it could

be something stupid I am doing. I don’t know what else to try at this point. Maybe a totally unique password change, IDK. My

password is a combination of uppercase/ lowercase/ numbers. I don’t think I used any special characters.



Alright it works! So lessons learned for me anyways. If you have a Craftsman garage door opener and use Craftman app to open/close door you need to delete the garage device from that app so you can re-add it later in MyQ. Create a new account on MyQ app. Add the garage door and then use those credentials in MyQ Lite Door apps. Thanks Brain!!

1 Like

Hey there, is there a beta release that provides support for thew new ST app? The lame classic app killed mobile presence awereness so I was basically forced to upgrade and now i’m dealing with all the incompatibilities.

Let me know!

Hey @brbeaird,

Thanks again for all you do with the MyQ app. I’ve finally got around to updating from the last major push. I have the Garage On/off working again but the momentaries are not working and it isn’t creating new ones when I modify my devices. I get a “problem creating push button” error. I have the momentary button tile device handler installed and published. This is what I had Alexa using previously. Any ideas?

You might double check which Momentary Button device handler code you’ve got. For awhile, I was referencing one with the SmartThings namespace, but because that caused issues with the Community Installer, I switched back to a version that has the brbeaird namespace.

Make sure yours looks like this:

Okay, that might be it. Not sure how to add it so that it updates from repo?

Never mind. Figured it out. Thanks for the quick reply

1 Like

Any thoughts? I installed the latest from the repo but I get errors if I try to open or close. I get a garage door opener id but can’t control it.

SmartThings still doesn’t fully support custom apps like this one. Presence still works fine for me in the Classic app - maybe there’s something you could still do to get that working again?

Presence works for me as well but sometimes clunky. It works flawlessly most of the time, but sometimes on occasion, it takes a few extra seconds to kick in or after waiting and nothing happens, opening the smartthings app somehow kicks in the presence…I think that depends how frequent the app is polling my location. I have an iPhone and allow smartthings to see my location “Always”, but it still happens once in a while.

My chamberlin (without sensor) works great with Brian’s code along with webCORE script. no momentary switches needed.

Thanks again!