[OBSOLETE] Lock User Management (LUM)

so it’s a problem of my phone? Or server?


Still does not work…

PM me your live logs when you’re entering the settings and hitting done. I hope you’re on the latest version.

That’s because you’re using a Zigbee lock and ZigBee locks don’t support remote programming yet (see the first post, it only work with Z-Wave locks right now). We’re still developing a customized version of the ZigBee DH that will allow remote programming but in the meanwhile you can try this alternative version (not certified but you can try it):

1 Like

@wangshin248 Let me know how this works for you. I’m interested in having additional community installs to help squash bugs.

1 Like

###Multi User Lock Code Management with Notifications and Actions - Version 5.3.0

  • Added ability to define up to 3 schedules per user for scheduled codes
  • Improved the reliability of initial programming to avoid lock from getting stuck in a loop for some users
  • For multiple SMS/Text notifications now separate the numbers with a ; (the + can be used to send messages to international numbers)
  • Improved reliability to check for smart app and device handler updates and notify the user

Recommend use the [Universal Enhanced Z-Wave Lock] ([RELEASE] Universal Enhanced Z-Wave Lock Driver for Schlage, Yale, Kwikset, IDLock, Popp, Danalock, August Pro, Keywe, Philia, Samsung) device handler version 3.1.1 or newer for full SmartApp and automatic update notification functionality

After installing this code update, please (in this order):
1. Update the [Universal Enhanced Z-Wave Lock] ([RELEASE] Universal Enhanced Z-Wave Lock Driver for Schlage, Yale, Kwikset, IDLock, Popp, Danalock, August Pro, Keywe, Philia, Samsung) device handler to version 3.1.1 (required for automatic update notifications)
2. Open the lock device page on the ST phone app and click on Refresh
3. Open the SmartApp and click Next and then Done for the changes to take effect

###Don’t forget Step 3 otherwise the Automatic Update notifications and the new multiple schedules won’t work.

1 Like

I don’t think I have any issues at this point, but wanted to provide some feedback on what I have seen.

Setup: Schlage Camelot ~20 ft from hub with wall switch in between (should be no connectivity issues - network is fully “repaired”).

I am fully updated to the latest version and with incremental updates enabled, I was getting a lot of “not set” errors. I turned that off and now, every 60 seconds per the time delay settings, I see “…Code 1 code is deleted.” “…Code 1 code is set.” Then the same for Code 2. Repeat over and over.

This morning I turned incremental updates back on and so far, it seems to have stopped the constant update cycle.

It seems like with incremental updates enabled, if I go into the app settings and do not actually change a code, then finish the setup, then the not set errors start coming through.

Thanks for the feedback. You’ve got it right. The core issue is when installing the DH and SA existing code programming in the lock tends to create this issue since the lock DH and SA are out of sync. What you did was correct and allowed the SA and DH to come back to sync. We’ve tried to address this issue with the latest release forcing a sync but it may not be perfect due to other issues outside our control. The best solution is a very simple one:

  1. Enter all blank users and hit done in the smart app
  2. Now open the smart app and reprogram the users.

This forces a clean re sync.

Alternatively reset the lock to clear all existing users and then program them using the SA.

It seams as though the battery life is running down quickly. I noticed the Lock Manager was polling the lock about every 3 minutes. I just installed the latest code and it looks like it isn’t anymore. Is this a problem or should it be doing this?

Hi, I’m new to the community.

I purchased the lifetime subscription and installed the “Lock Multi User Management” App.
I installed it on my android LG G3. It seemed to be working ok.
I then installed it on a second device (iPhone). But it does not work on that device.
on that device. Each time I go into the app all of the data is cleared out (like the lock it was linked to is gone, and the number of users is blank, as well as all the users have been removed.)

When I link it to my lock, and enter the number of users, and the name of user #1 and pin, and click “done”, a message appears that it is clearing the users and will take 120 seconds. (also said 150 the first time.)

I have the same email address I entered to create the account on both phones. Is that a problem?

Do I need to create 2 separate emails? I looks like I need to have only one email so that I can login to my smartthings hub, and not two.

When I look on my android device, I now see 4 copies of the program for some reason. I deleted 3, and kept the original. The app is working correctly on my android. I can see the state of the lock, control it, and I get notifications of locking and unlocking. So the issue is that isn’t not working on the iPhone.

I’m trying to get thing working as soon as possible so that I can leave on vacation.

I would appreciate help in resolving this issue.

Thank you,

I sent an email to smartthings@rboysapps.com as it was written on the support page,
but that email address bounced back as invalid.

You’ve got the email incorrect. There is an extra s in it which shouldn’t
be there.

The only think I can think of is that to may be opening a new smart app
each time instead of opening an exiting installed version which is why
you’re ending up with multiple copies of it in your account. I would
suggest try the opposite. Install one smart app from your iPhone and then
open the installed version from your android. Note that once installed it
should show up under automation and you should not go to my app or market
place again. That would install new instance if the app

Ok, I deleted the other 3 copies of the app.

So I should only install your door lock app on one phone, and it should already be installed on the other phone
when I login to that account?
I installed the app on the iPhone after I installed it on my android phone, because I thought I needed to do that.
Would installing it on the iPhone cause that behavior?

I think you’re getting mixed up in how ST works. It’s one account per hub
and each hub can have multiple users. Each user can have one or more phones
depending on how many phones they log into. But at the end of the day the
Smartapps live on hubs and it’s one hub. So if you install the app from 3
phones you’ll have 3 instance of the app running. Hence only install once
and configure/use from all the phones.

1 Like

It doesn’t “poll” the lock, please see the messages again, we’re tried out best to highlight it and even color it differently to say it does housekeeping and everything runs in the cloud. The only time it communicates with the lock is when you see a “Blue” INFO message. Everything else is in the cloud. And Yes it should be running every few minutes, if you don’t see it your ST scheduler has died and you should report it to ST support or @slagle because without the housekeeping timer things like scheduled codes, expiry codes, auto relock and unlock etc won’t work.

@RBoy - Is there anyway that sort of “ping” could be sent to a Yale lock that would illuminate the lighted keys? I’m thinking of a motion sensor on the porch that would trigger the keys to light up for easier entry at night. Thanks!

There no way to remotely light up the keys. They are activated when the
lock is physically touched AFAIK.

Rboy, The app is working very well with one exception. I have 8 users and three locks. User 2 code should not unlock one of the three locks (Schlage deadbolts). Whenever I try to limit that user by choosing a lock in “Only on these lock(s) (optional)”, all three locks delete that User Code. I have tried various combinations of locks under that option and whichever single or multiple lock or locks I choose, it deletes that user code from all three locks. I have restarted the hub, wiped the codes and started new and I am using your device handler. Any advise would be welcome.

Makes sure you’re in the latest code. This issue fixed in the last release.