[OBSOLETE] Lock Manager

So that’s Samsung’s master plan: ‘fix’ the Classic platform until the custom code no longer works, and frustrated programmers are forced by the inconvenience to cease updating.

Erik, thanks for all the work you’ve done on this over the years.

Babar, I made that change. It was at line 134 in my code.
I’ll find out tomorrow how it does as far as reporting which slot (code) was used to open the lock.

1 Like

Erik appreciate the help, thanks for the update. I tried uninstalling, reinstalling from the repo, and now added back my Schlage lock. It appears to be stuck “sweeping”. The sweep has said 0% and 0/30 for over 10 minutes. I just tried removing and re-adding the lock. Still stuck.

Make sure you installed the DTH from the repo and have activated it on your lock. It wont work without the custom DTH.

Updating the DTH did the trick! Thanks!

How did you update DTH?

I have been using ST and lock manager for a long time. It works great! Days ago, however, ST stops pushing notifications. I tried to reset door lock and reinstall lock manager. But the notification didn’t come back. I can create, edit and delete codes from lock manager. But I just couldn’t get notifications. I checked the activity history for the lock. I can only see what I did on the app, but nothing like “door is manually unlocked” or “door is unlocked by code 1”. Could anyone help me with this issue? Many thanks!

I added the DTH in the SmartThings IDE (Z-Wave Lock Schlage). I just updated from the repo.

I now have updated both the app and am using the custom DTH. However I cannot get any notifications. It appears to be programming correctly. However I did not see any events for my users unlocking the door when I put in the code. It physically unlocks when I enter a code but no notifications for the user. I have set notifications on both the lock and the user in the app.

Has anyone updated and gotten everything working with a Schlage BE469?

Thank you for this! I’ve been wondering why I’ve stopped getting notifications and why my lights weren’t turning on when I locked the door anymore…
I updated from repo and had to remove/re-add the SmartApp, but when it tries to do the sweep, it just hangs. It says it’ll take 1.9 minutes, but I let it sit for over 20, and it was still 0/20. I did override it to do 20, and I don’t remember how many slots my lock claims to be able to hold… So, I removed the SmartApp and re-added it again, and this time didn’t select override.
It’s still hanging on, this time, 0/19…
Should I skip the sweep? I have codes already programmed and didn’t want any conflicts (like it says there may be).
Hub v3 (2018) Schlage lever lock.

I’ve been using this for a couple years (love it!). Suffering from the same notifications issues as everyone else. I just updated to the latest version, I now at least see the app updating (locked/unlocked, & battery level) when I use codes, but it’s not reporting which code was used. That’s preventing my automations from triggering.

I’m somewhat hoping this will get fixed but you’ve also peeked my interest about open source. I’ve been debating switching but just can’t justify the effort to re-setup all my automations. But if you’re moving this to a new platform that might be all the motivation I need…

What DTH do I need to install for Kwikset 916 Z-wave? Don’t see the Z-wave Lock Reporting on the repo???
Thank you

Update: i got it worked by using the ST ZWave Lock (not with codes).

I’m getting a Error/Disabled message under User>>Lock settings. I have tried resetting but that didn’t resolve the issue. Is see this was discussed last in late 2017, was there a resolution for this?

Yep, same here.

Are you willing to say which platform?
I started looking at Hubitat or homeassistant after reading about this update and ST’s future plans to kill the groovy platform. (All of my devices are based on custom DTH and Apps)

so only lock manager changed? not the device types?

im using the following too and dont see that device type


  • Copyright 2015 SmartThings
  • Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file except
  • in compliance with the License. You may obtain a copy of the License at:
  •  http://www.apache.org/licenses/LICENSE-2.0
  • Unless required by applicable law or agreed to in writing, software distributed under the License is distributed
  • on an “AS IS” BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License
  • for the specific language governing permissions and limitations under the License.

metadata {
definition (name: “Z-Wave Lock Reporting”, namespace: “ethayer”, author: “SmartThings”) {
capability “Actuator”
capability “Lock”
capability “Polling”
capability “Refresh”
capability “Sensor”
capability “Lock Codes”
capability “Battery”
capability “Health Check”

i also dont see this any longer in your repo… I did update lock manager and still am not getting notified after manually unlocking the door since lastest firmware update… lock does work and notifications when unlocking via the phone.


What about the DTH?

I installed this in May 2017 and don’t do any other automation so I am hoping someone can confirm what I need to do. Am I correct in that if I go to the Smartthings account IDE and press the button for update from repository for the main app and the device handler that I will be done? Or are there more steps or details? Thanks in advance for reading this and helping me out.

yes it seems device handler “with reporting” is missing. in the repo… i did the change above to lock manager and manually did the recommend changes at line 134 above to the device handler and am now getting the notifiations on manual lock/unlock

I finally figured out how to uninstall it and reinstall from scratch and can confirm that the “with reporting” option is missing. I’m now getting notifications, but I don’t have the ability to modify or create any codes, after the sweep…

I tried on my lock but still doesn’t notify on manual lock/unlock. I had updated the Lock Manager SmartApp via repo last night and then add the changes to 134(mine was actually line 234 like Babar’s since I’m using “Z-Wave Schlage Touchscreen Lock”) today but still no notifications.

@ethayer. hubitat is locally executed and a lot of the smart things code can be ported over easily. it’s a pretty solid platform. i helped on some custom apps on it.

hass.io on home assistant is getting a lot of praise and the ball is rolling pretty fast on it. it’s light weight but i’m still going to wait until my friends and i figure out what’s the easiest platform.

if you’re going to switch soon, i’d suggest hubitat for the ease of use to port your smart things code. i’m very close to pulling the trigger because smart things is slow. i heard smart things is starting to push for more local execution though. that hope is the only reason i haven’t pulled the trigger yet.