[OBSOLETE] Lock Manager

Ah. Yes, That’s what I was referring to that gets the “Something went wrong” error. I’ve contacted via the phone number you provided. They say:
#1 reboot the hub (will do that later when I’m on location
#2 reboot the network router (it’s a MiFi until I get real network on location)
#3 reboot phone (done, no joy)
#4 reinstall SmartThings app.

Ah. Could be the MiFi. You may have to have the phone and the hub on the same subnet in order for the installation to complete. :thinking:

Well, that’d be pretty useless if I had to be on the same subnet as the hub. The point is to be able to set up user codes for a short term rental - remotely. Real internet lead time is 4 months so the MiFi is just an interim solution. Even so, everything is working, including remote lock/unlock. Just not setting the User codes. I’m not seeing why MiFi would be any different than any other plain jane WiFi router. I’m headed over there in a few to reboot the MiFi & hub.

I noticed @jkp had tagged @ethayer, is this the lockmanager.io owner?

I only meant when setting up SLGA for the very first time, that is downloading that service onto your hub. Not using it after it was setup, which, as you point out, you definitely want to have remote access for. Sorry if I wasn’t clear.

So just locking and unlocking the device isn’t done through SLGA. That’s a special add-on for managing lock codes. (And I have no idea why managing lock codes isn’t part of the base app features, but it isn’t.)

And, yes, ethayer is the lockmanager.io author, this is his author thread, and he will get a notification every time a new post is added to this thread. :sunglasses:

Ugh, I’ll have to try ripping out SGLA and reinstalling it when I’m onsite. I’m with you - why wouldn’t it be a base feature. To quote from “Meet the Robinsons” “I’m beginning to wonder how well this plan was thought out.”
I’ll wait semi-patiently for ethayer to respond to the lockmanager issues.

1 Like

BTW, I don’t know if this is related at all or not, I don’t really know how SGLA fits into the architecture, but there are platform problems today for people downloading new edge drivers. :thinking: but I think your problem started earlier than those.

Unable to join channels (25 Jan 2023)

Erik, I’ve tried ripping out the smartthings developer setup - to the extend of closing the account and reopening it.
The App Credentials wants to verify the app registration, but that doesn’t work. I realized just now I needed to reset the client id, etc on the lockmanager.io site too, which I just did. Same thing - I save the keys, click next and nothing happens.
The confirmation request says it was sent to my SmartApp, but I don’t get any notice in SmartThings on my android or the my.smartthings.com web app, so I’m not sure if there’s something broken or if I’m looking the wrong place.
Thanks in advance!

A quick check of the API Browser shows that SLGA is a webhook application. From my understanding, a piece of code gets installed on the hub which handles the communication with a backend somewhere else on the Internet (in this case the ST Cloud). So I suppose there could be some relationship with the other issues we’re seeing with Edge driver installs. But my gut tells me the Edge driver install issue is related to the back end that manages the channel and driver subscriptions.

1 Like

@h0ckeysk8er Bruce thanks for chiming in!
I had to install SLGA on my SmartThings app on my phone, on my wife’s phone, and the my.smartthings.com app. So, I’m guessing it’s an app thing, not a hub thing.
Samsung recommended reboot hub, router, phone, and reinstall SmartThings app. I’ve done all those, although not necessarily in that order to no effect.

@JDRoberts I tried ripping out and reinstalling ST on-site. On reinstall it had to reinstall SGLA. No joy. When I reinstalled ST, it already had my login information and connected to the account even though I’d gone to settings/app to try to completely remove the app data.

One thing I haven’t done that I wonder if is necessary is to set a user code on the lock first. It’s a brand new lock; no user codes have been set even manually. I’ll try that tomorrow - I need at least a few user codes set even if locally.

@michelp Michael:
Ha! The post was deleted, but I’d already gotten it via email! Thanks for chiming in BTW, the comment seemed pertinent to me and is appreciated.

The setup is new last week. Yes, fw is 46.00008. I think I updated firmware when I installed the hub, but I slept since then so not sure. I’ll see if I can check for fw update again.

Ah, for the days when companies actually did QA on software updates…

Just remember that this thread is the author thread for Lock manager and posts here should be about that.

You can start a new topic about SLGA if you have more questions/comments about it. That would go in the following section of the forum:

SmartApps & Automations - SmartThings Community

How were you able to verify? This is where I’m stuck…

I think I ended up created a new client ID and secret after the first attempt and then it worked.


Did you ever get an answer for this question?

I have not.

Same here. Any solution @ethayer? :pray:

EDIT: It’s fixed. I changed the lock Device Type on the ST IDE to Z-Wave Lock (it was Z-Wave Lock Reporting before, for some reason…).

Now it works perfectly, thank you very much @ethayer !

Anyone know how to contact lockmanager.io person. For weeks I’ve been “registering” new account but never receive a login link to create account. Is lockmanager.io for real?

Lockmanager.io is a project of community developer @ethayer , who has been active in this community for six years, and shared a lot of code in that time. The project is an update of his previous Groovy lock manager, so that it can work with the new smartthings architecture. But it’s still in alpha, it hasn’t even been released to beta yet.

And he’s just one person. He hasn’t been active in the forum for about a week, but I don’t know whether that’s because he’s just busy, he’s sick, or he’s away.

Hopefully he will let us know soon.

1 Like

Thx for the reply.

1 Like

I tried creating a new ID and still cannot verify @ethayer, any suggestions? I used Lock Manager for years before it became obsolete and would love to continue doing so.