Unable to join channels (25 Jan 2023)

I’m working on migrating my devices to Edge drivers. When I tried to join a channel (for example SmartThings - Add Channel), it will throw an internal server error.

From some other posts I’ve seen, it seems that I need someone from ST support to modify my account or something?

Apologies if this is not the right category.

ST customer service does NOT monitor this forum. It sounds like you need contact ST customer service.

Which model hub do you have? If it’s one of the Wi-Fi mesh models, those have some known issues with edge drivers at this time. You should still contact support, but let them know right away what model your hub is.

This forum was set up a number of years ago so customers could help other customers. It’s not officially monitored by support except for a few sections for developers writing new code.

To get support with your existing account, use one of the contact options at the bottom of the following page.

The first person you get will probably just be a Samsung employee working from a script, but hang in there and be patient and it should get escalated to smartthings technical staff.

(By the way, multiple people have reported the same issue this morning, so it looks to be something on the platform side. You should still go ahead and open your support ticket because the more people who report it, the sooner they will assign resources to look into it.)

1 Like

I have the v3 hub. Interestingly, I was able to join Channel and Drivers Web UI (smartthings.com), but not any other channel.

Thank you both. I have opened a support ticket.

1 Like


I have the same issue with the channel invitation link.

Further more, the link to
Z-Wave Lock PH v1.00
just shows a spinning graphic but never displays any content.

Open a support ticket. It’s clearly not limited to just one driver or channel. The more people who report it, the more resources they will assign to look into it. :thinking:

1 Like

Where do I open a ticket?

See the contact information at the bottom of the following page


1 Like

Is this currently working? I am getting an “internal server error” when trying to do this

Looks like this has might have been decommissioned from ST. :frowning: Internal server error

I have noticed this on several custom edge projects.

Somehow I doubt that, because they don’t generally just yank the rug out announced from under developers.

I’ve been having problems with ST all day, since the wee hours. If I try to edit routines, usually they just completely crash the app on both mine and my husband’s phones. (Both iOS.) I’ve rebooted everything in the house, deleted and reinstalled the app, all the usual troubleshooting stuff. It has settled down in the last hour or so. All of my virtual devices have been working as they should.

Yes, not positive but have noticed this on 5 different custom edge apps when browsing today trying to replace busted routines. They are all still receiving the message.

@TAustin the link to the channel invitation does not work for me. Am I doing something wrong?

Really sorry you’re having problems but this appears to be a problem with the SmartThings website. Try closing and reopening your browser tab or wait and try again later.

Keep me posted if it’s not working by tomorrow.


I’m getting a “There was an internal server error” after I accept the terms and conditions.

@nayelyz - A few folks are reporting problems with the channel invitation/driver install web site. Are you aware of current issues?


It’s not just your channel, @TAustin. I just got the same error trying to enrol in the Zooz driver channel.

As I mentioned earlier multiple channels multiple authors. Some channels appear to be working still which is why this seems a bit odd.

1 Like

Hi, @RebelMagpie, @Eric_Seckinger

Is there any chance that you accepted the invitation to those channels and then made a factory reset to your Hub?

Negative, it is also happening on several other channels with several other developers. Also multiple users have mentioned these same issues.

1 Like