[OBSOLETE] Lock Manager

SAme problem. That is the error I get from the new ST app

So before I head over to Rboys and pay for their app I thought I would just see if I can resolve anything here.
I have the SCHLAGE BE469ZP running with ST on my Shield.

  1. i did the install and setup from GitHub and the app “works” in Smartthings Classic.
  2. It will not work in the new ST app. I even changed the code as suggested to replace the HTTPS for the images because of expired certificates and that failed to work.
  3. I have a user that I can NOT delete… It says “Something’s wrong” We can’t load your screen right now. I have deleted other users but this one is stuck. When I look at the lock details it shows all the slots including the one that is stuck with the correct name but there is no pin code associated with the slot.
  4. When I create a new user it will not save unless I first disable the user, re-enable (little swipe button) and then it will save.
  5. none of the code/slot expiry dates/times I have tried will work but I cannot find any documentation to clarify if the lock supports that.

I am happy to make a $$ contribution here also as I feel rboys is overpriced when I only want the Lock management app and don’t need any of their other stuff.

Appreciate the help.

I’m on the same boat…

@ethayer you did a wonderful job with lock manager years ago and I’m grateful for what you did. If you have a couple of minutes before the end of the year, what’s remains of ST community would probably appreciate an update on whether or not you plan to debug lock manager in the future. In its current state, it’s pretty much unsusable.


1 Like

Just reading over the documentation and then look at some of the notes. Before I begin this, in its current state is this working in 2020?

I know how much work goes into things like this and that is no small feat. Thank you so much for working on and building something like this. You rock!

It works just great, and it works fine with the latest release of the SmartThings app, just as well as with the SmartThings Classic app.

It used to work with the classic app but I’ve never been able to get this to work with the new app. With the classic app being phased out you may want to put your efforts into something which works with the new app and kept up to date like lum from rboyapps. I was reluctant to shell out a few $ initially but it has been totally worth it. The support and the quality of their apps are excellent.

Smartthings seems to be constantly evolving so I can see the pressure on developers to keep their apps updated.

1 Like

Gotta thank ethayer. Lock Manager has been the best. Worked wonderfully for me for years. Between this and the various routines and Webcore pistons that allow presence sensors to control my locks, it has been awesome.

But ST has informed me it’s time to move to the new app. I’m hoping for similar functionality going forward… but am leery due to what I’m reading here. Ah well…

@ethayer did an excellent job with Lock Manager and it has performed flawlessly for me for around 3 years… however it seems as though it’s not getting updated for use with the ST New app. I’m unable to use the New app to add user codes- I have to do so only in the Classic app, which ST will kill soon. I guess maybe it’s time to go to RBoy app :cry:

Hi guys,

Im new the SmartThings, and was hoping the community could help me.

I have Hub V3 setup with 2 Yale Keyless Connected locks. I added them however the only functionality I have is to lock/unlock remotely. I cant add the lock manager app, nor can I do it via the classic app as advised by tech support.

They advised they knew about this issue and that it has been logged and I have to wait for the US team to do something, no timescales or point of escalation.

Is there any other way I can remotely manage user code management and add restrictions

Many Thanks

I installed it and no child scripts showed up to install. This is a common complaint.

However, the smartapp called Lock Manager showed up in the new ST app. When I clicked to open it, I got an error message “Network or server error occurred. Try again later.”

I installed the master and the 3 child apps are not available.

There aren’t child apps with the most recent version. This will only work in the classic ST app. Aside from that, it’s still working flawlessly for me in there. Given that I don’t often add/remove user codes, I’m fine with maintaining the two apps for now. Just hoping that ST take their time to kill the classic app.



i made a mistake and the App (Lock Manager) crushed.

I have a Schlage smart lock, in the the number of user should be between 0 to 19. but i put 10000. it is too big. so it crushed the Lock Manager Rboy App.

what should i do?

Can somebody help me and fix this? my skype: joseph24gt. my email: abc@3rich.com. my mobile: +1 2o2 642 8o81.



If you are using the @rboy version then you posted in the wrong thread. This thread is for the @ethayer version :slight_smile:

I’ve been using this DTH successfully for a few years, but my lock quit reporting status properly in the smartthings app a few months ago. I do see the status updating when I manually unlock or lock while I view IDE activity, but not in the smart app, it doesn’t seem to notice the changes… Any idea why? I’ve got a Kwikset 916

I went back to using the default device handler for my Schlage BE469. The only thing it does not do at the moment that I need is let me set an expiration time/date on a new code. I was using this DTH but it was a little too buggy and reading somewhere in this thread, he is no longer maintaining the code.

Thanks. I will change back to the standard DHT

Any luck? We have the Lock Manger App, but for some reason getting an unknown error when trying to add new users.

I was too hasty in saying it works fine in the new SmartThings app. It does provide me with all the notifications I had before. But today I found out that I can’t add new users (I could probably delete users, but I didn’t try that) in the new app. When I try, there is essentially a loop of creating a new user and no way to enter a code. So I’ll stick with the SmartThings Classic app for now. That still works.

I’m trying to get this to work with August and a Centralite 3400 keypad. Any help would be appreciated. What I need is a way to see who unlocked the door at a specific time.

Please email me if you can help