[OBSOLETE] Lock Manager

Hello, I’m new here, just got Lock Manager set up, seems to working pretty good. I have one minor issue, and I could have swore I ran across a post asking about this about 3 hours ago when I was still just trying to figure out the difference between SmartApps and DTHs was, and why neither terminology showed up in my Samsung Connect app… But I can’t find it again, so I’ll ask here.

After getting Lock Manager set up with my Schlage Connect (BE469NX), when I go into my lock info, where it shows the codes, it only shows the two new codes (slots 3 & 4), not the two default codes (which I assume are slots 1 & 2?). I’ve turned overwrite off, so it doesn’t remove the default codes. All 4 codes work when entered into the keypad. Is there a way to get it to show the other two codes?

I’m using the “zwave-schlage-touchscreen-lock.src” DTH provided from your Git repo.

And one other question, does Lock Manager provide access to change the code length or enable/disable vacation mode?

Thanks! Only been using it a few hours, but seems like great work, and much more featured than the default Smart Locks app provided by Samsung.

EDIT: since posting, I found the beta-2 branch and removed 1.1 to install 2.0 beta. So nevermind, 2.0 is awesome! Did find one miniscule bug. In the lock settings menu, “Vacation Mode” is misspelled as “Vataction Mode”.

Hi all!

Just got my brand new Schlage lock, yay!

I’ve of course installed the semi-mandatory Lock Manager smartapp and DHT.

I’ve searched the thread but I’m a bit confused about the usage of contact sensor? What is it suppose to do once it’s set? Is it notification only or will it prevent locking the door if its open?

Hello. I’ve just ventured into the world of Smart Locks - please excuse any silly questions and be as gentle as possible!

I’ve got a Yale Conexis L1 lock. I’m not sure if it’s directly supported by this app and device manager… I installed the Beta version to see (the lock is Manufacturer 0129, Model 0066, version 0000) and it seemed to go ahead but then said it needed 3 minutes to scan. Used the Yale DH.

10 minutes later it still said 0%, but my ST Hub (UK v2) had rebooted once like it had crashed about a minute in. At this point, unlocking and locking manually didn’t show up in ST at all, it just remained at Unlocked which was the last state.

I’ve reverted back to the built-in ST device but I was just wondering whether there was any way to get this working, or should it work already and I was just doing it wrong?

[Keypad Routines] are meant for KEYPADS ONLY. So don’t use that app if you don’t have a keypad.

I think the problem here, when trying to describe the discrete “Keypad Routines” option, is that it’s confusing to find that when you’re in the settings for an actual lock, as a secondary/cumulative option AFTER the general triggering of routines from lock actions. I think you mean “STAND-ALONE, NON-DEADBOLT KEYPAD” when you use the term “keypad,” and if you’ll please clarify this, it’ll remove lots of confusion here. After all, the locks we’re talking about here all have keypads too, or at least most of them.

I was hoping for the capability to have a separate user code (or a press of the single lock button on the keypad) function exclusively for the purpose of manually arming my SmartThings security system upon leaving, without it being an unlock code. The “Keypad Routine” suggested that capability, but I fear it’s not possible because there is no way for the lock hardware to accept a code without it performing the unlock function.

The whole reason I’m here is to find a way to easiest arm my home every time I leave, and as we all know, the SmartThings Arrival Sensor key fob, as well as the smartphone app’s proximity sensor, are practically worthless with their false positives/negatives.

Huge disappointment; I might just resort to relying on the flawed smartphone proximity sensor for automatically arming my home, while having every successful code unlock entry to always disarm my home. Not perfect, but amazingly, the best current automated option if I’m not mistaken (and it doesn’t actually need this Lock Manager).

Hi! We use the Lock Manager app to remotely manage our lock for Airbnb guests, and I’ve noticed that it’s just recently stopped serving up notifications as it had been. I see all notifications as expected in the SmartThings app under More > Notifications, but we no longer get push notifications on phone or SMS to any of the numbers we’ve been using. Anyone else see this? I don’t know if the issue falls within the realm of Lock Manager, or the SmartThings app. I’ve verified that all of the phone notification settings are as they should be. Tried restarting hub remotely, etc. Looking for suggestions on things that we can try without having physical access to the hub or lock. Thanks!

it could be related to this?


Will there be an update to the Lock Manager app released that will make up for the disabling of the Contact Book feature?

1 Like


As a work around, you can use Pushover Notify Me When smartapp to get SMS or Push notifications of every time the door is locked or unlocked.

Another option is to use the ST Virtual Device Creator and the Notify Me When smartapps. Since Notify Me When does not work directly with locks, you can create a virtual switch to simulate your lock that works with Notify Me When. Create some automation routines that turn the virtual switch on and off. Have Lock Manager run these on and off automation routines as Home Hello Settings to sync the virtual switch to the lock status (on = locked or off=unlocked). Then setup Notify Me When to send SMS or Push Notifications when the virtual switch status changes.

Neither of these approaches are as elegant or informative as the Lock Manager notifications but at least it is something until the Lock Manager smartapp is updated.

1 Like

Ah, good info! I wasn’t really aware of that change (disabling of Contact Book) - thank you for the thoughts and ideas.

For some reason my app won’t allow me to enable or add new users. When trying to add new users, when I select a slot it’s as if I never selected it. After that I select the slot again and it shows up as slot 0 in the main user screen.

When I try to save the user, I get an error. I tried updating from the git repo, deleting the app, and starting over and now none of my codes will work. Anyone experienced this, my app is saying it’s version 1.4 for some reason also.

I’m having the same problem. Please help!

Same issue here so something got broke. I was getting an error saying to fill in all the fields so I went through and put “something” in all of them and it acted like it worked. It seems to have shuffled the slots but all of the codes are working.

I found a workaround to fix the issue… I reset the slot until it sticks and then save it. When it goes back to the main screen that won’t allow you to save, disable the user and re-enable it… This forces the name field to be filled in properly… After that, everything seemed to work as designed.

Is there going to be any difference in this code and the new SmartThings v3 hub?

I am having this issue as well. The App shows the following:

Hello, I notice that the Exit Delay Tone (Countdown beeping) is not working. Any idea?

@ethayer - need your help here, if possible.

I have the Schlage Connect lock and everything works (almost) well; however, incorrect code entered notification does not seem to work.

I’ve enabled the setting under Keypad settings, changed the setting of “How many times can incorrect code be used before notification” to 1 to no avail.

Any suggestions would be appreciated.

I just added a second Schlage lock to my system. I am getting notifications of users unlocking the old lock, but nothing from the new lock. I have checked the configurations are identical and removed and re-added the lock a few times. The descriptions show the same information, the locks are the same model and version:
zw:Fs type:4003 mfr:003B prod:634B model:504C ver:43.37 zwv:2.64 lib:06 cc:85,73,72,98 sec:62,63,80,71,70,86,20

Current States shows up differently:
Old Lock:
Current States
battery: 52 %
lock: locked
codeChanged: 2 set
lockCodes: {“2”:“Code 2”,“1”:“Code 1”}
scanCodes: Scanning
maxCodes: 19
checkInterval: 3600

New Lock:
battery: 100 %
lock: locked
checkInterval: 3600

Did I miss some configuration somewhere?

Thanks, Richard.

Finally got this working. some things I learned:

  • unplugging the battery pack is not the same as disconnecting the batteries
  • add and remove were not working until I removed a battery then add and delete started working
  • reading some advice from earlier I moved the lock closer to the hub to make sure to get a “secure inclusion”
  • unfortunately disconnecting the batteries to install the lock seemed to cause it to stop sending notifications
  • finally re-tried the remove and re-include a few times until it tested as fully working

suddenly broken and not getting notifications about unlockinng doors… here is the error in the event log

11:40:34 AM: debug in populating discovery!

516380e0-a36a-4230-b6a5-022141369d37 11:40:34 AM: debug in populating discovery!

516380e0-a36a-4230-b6a5-022141369d37 11:40:22 AM: error groovy.lang.MissingPropertyException: No such property: currentPresence for class: java.lang.String @line 1317 (doCall)

516380e0-a36a-4230-b6a5-022141369d37 11:40:22 AM: debug codeUsed evt.value: unlocked. evt.data: {“usedCode”:1}

516380e0-a36a-4230-b6a5-022141369d37 11:40:16 AM: debug codeUsed evt.value: locked. evt.data: null

1 Like