[OBSOLETE] Lock Manager

Hi all,

I just purchased a sensor and placed it on my door. Can anyone tell me how I can get my lock to auto lock when the door is closed after X amount of seconds/minutes. I tried using the Enhanced Auto Door Lock app but it has that weird issue of allowing the door to auto open.

I got CoRE installed on my phone but the pistons seem way above my comprehension. Can someone guide me on how to set an auto lock when the door sensor is open for X amount of seconds to lock the door?


Do you have Core or WEBCoRE installed? I was going to recommend using webcore. You should head over to the webcore forum and post there. The folks over there love helping with webcore and building pistons :slight_smile:

I followed the instructions on Dropbox and installed Lock Manager earlier today. I configured my Schlage touchscreen deadbolt, and the lock was learning codes forever. I tried a couple times and then gave up. The lock disappeared from Lock Manager (and ST Classic is generating errors too), so I recreated it. It still never completed learning codes, so I figured I’d deal with it later. Now I’m getting errors from Lock Manager, and the lock periodically reappears and then disappears again. I’d like to UNINSTALL and start over when I have more time to play with this.

I’ve tried removing Lock Manager and its child apps from ST Classic. It seems to get removed, but when I look in My Smartapps, it’s still there! I’ve tried to delete everything from IDE, but everything except Keypad says it’s in use and can’t be deleted. I’ve broken GitHub integration, but I can find no way to disable and uninstall these apps.

Edit: I’ve now managed to delete all the child apps, so all I have left is Lock Manager itself. When I try to delete it My Smartapps in IDE, I get this error:


I don’t want to remove it from @ethayer 's space, just my own, but I can’t. Help please?

Make sure to delete any locks or users you set up in the app, then you should be able to remove the app. You can also remove them in IDE under My Locations: smartapps - scroll down to find Lock Manager and below that will be any users/locks you set up (be careful to remove the right items). IDE → https://account.smartthings.com using a private/incognito tab.

Next, install the beta version of the app. There is only one smartapp to install plus the two device handlers which you assign to the locks in IDE under My Devices.

hope this helps :slight_smile:

HI, and thanks.

Part of the issue is that the lock would install, but it would never learn the existing codes and users. As a test, I deleted a user’s code using the ST Classic app and then added a new one (for that same user). When I opened Lock Manager, the lock had reappeared along with both existing users and codes. The next time I checked, there was no lock or users listed. Strangely enough, I did get detailed notifications when I opened and closed the door! But this might be the cause of my problem, as there was no lock listed for me to uninstall.

I didn’t change the DTH, as I couldn’t find one that didn’t involve paying for it, so when I installed my lock in Lock Manager, the it appeared as “Z-wave Lock” instead of the “Schlage Touchscreen Deadbolt” as shown in the instructions.

I did finally get everything deleted from IDE (and thus My Smartapps in STC), but it was a painful process. Over time, I was ultimately able to delete each of the child apps, and a few hours later I was able to delete the Lock Manager app, when it finally stopped giving me the error that other users were using it. (I assume this means it ultimately stopped running w/o its child apps.)

I’d love to try again using the beta, but I see the warning to completely uninstall EVERYTHING before installing the beta version. Can you point me to instructions for uninstalling the child and Lock Manager apps? Or was I doing the right thing and just seeing errors? The more I search, the more I see others having this same issue removing smartapps via IDE. So I’m reluctant to install anything new until I’m sure I know how to uninstall!

Thank you!! :sunny: :smile:

Were you using the lock Manager in Automation: SmartApps? If you were using the one in marketplace, the users and locks would disappear as you described.

I do not believe there are instructions for removing. Basically open lock Manager in Automation: SmartApps and remove all users and locks you created in the app. Then you can remove all the apps in marketplace: Smartapps: my apps or remove them in IDE.

The new version only has one app to install and there are no child apps. So easier to remove.

Well that explains it! I was using Lock Manager under Marketplace. I guess I did that because I’m new to STC, and Support had me install the Smart Locks app from Marketplace. I’m learning a lot here. Thank you so much!

But I do have one more question. In his initial post re the 2.0rc beta, @ethayer says:

This sounds like I don’t need to install a new DTH, but you say I should. I’d like to try a new DTH anyway, but I’m confused as to which I should install:

“zwave-lock-schlage.src” was posted four months ago, and the comment says “it was a nice try.” That sounds ominous to me! :slight_smile: So should I use the newer “zwave-lock.src”? It was posted more recently, and the comment says “platform bug workaround”.

Edit: I looked at the code for “zwave-lock.src” and see my Schlage lock type, so I’m going to use that one. :smile:

Anyway, thank you so much for your help. I greatly appreciate it! :smile:

I have been using the Lock Manager with my SmartThings Hub and Schlage Connect Lock since November. I have several users set up. However, I attempted to add a new user several times in the past month, and the user code does not work on the lock. Everything looks right in the app on my phone, but the lock will not unlock for any of the codes I have added since I originally installed the lock. I need to set up a code for this week for the woman who is pet sitting for me while I’m on vacation. Please help me figure this out! Thanks!

Hello, I’m new here, just got Lock Manager set up, seems to working pretty good. I have one minor issue, and I could have swore I ran across a post asking about this about 3 hours ago when I was still just trying to figure out the difference between SmartApps and DTHs was, and why neither terminology showed up in my Samsung Connect app… But I can’t find it again, so I’ll ask here.

After getting Lock Manager set up with my Schlage Connect (BE469NX), when I go into my lock info, where it shows the codes, it only shows the two new codes (slots 3 & 4), not the two default codes (which I assume are slots 1 & 2?). I’ve turned overwrite off, so it doesn’t remove the default codes. All 4 codes work when entered into the keypad. Is there a way to get it to show the other two codes?

I’m using the “zwave-schlage-touchscreen-lock.src” DTH provided from your Git repo.

And one other question, does Lock Manager provide access to change the code length or enable/disable vacation mode?

Thanks! Only been using it a few hours, but seems like great work, and much more featured than the default Smart Locks app provided by Samsung.

EDIT: since posting, I found the beta-2 branch and removed 1.1 to install 2.0 beta. So nevermind, 2.0 is awesome! Did find one miniscule bug. In the lock settings menu, “Vacation Mode” is misspelled as “Vataction Mode”.

Hi all!

Just got my brand new Schlage lock, yay!

I’ve of course installed the semi-mandatory Lock Manager smartapp and DHT.

I’ve searched the thread but I’m a bit confused about the usage of contact sensor? What is it suppose to do once it’s set? Is it notification only or will it prevent locking the door if its open?

Hello. I’ve just ventured into the world of Smart Locks - please excuse any silly questions and be as gentle as possible!

I’ve got a Yale Conexis L1 lock. I’m not sure if it’s directly supported by this app and device manager… I installed the Beta version to see (the lock is Manufacturer 0129, Model 0066, version 0000) and it seemed to go ahead but then said it needed 3 minutes to scan. Used the Yale DH.

10 minutes later it still said 0%, but my ST Hub (UK v2) had rebooted once like it had crashed about a minute in. At this point, unlocking and locking manually didn’t show up in ST at all, it just remained at Unlocked which was the last state.

I’ve reverted back to the built-in ST device but I was just wondering whether there was any way to get this working, or should it work already and I was just doing it wrong?

[Keypad Routines] are meant for KEYPADS ONLY. So don’t use that app if you don’t have a keypad.

I think the problem here, when trying to describe the discrete “Keypad Routines” option, is that it’s confusing to find that when you’re in the settings for an actual lock, as a secondary/cumulative option AFTER the general triggering of routines from lock actions. I think you mean “STAND-ALONE, NON-DEADBOLT KEYPAD” when you use the term “keypad,” and if you’ll please clarify this, it’ll remove lots of confusion here. After all, the locks we’re talking about here all have keypads too, or at least most of them.

I was hoping for the capability to have a separate user code (or a press of the single lock button on the keypad) function exclusively for the purpose of manually arming my SmartThings security system upon leaving, without it being an unlock code. The “Keypad Routine” suggested that capability, but I fear it’s not possible because there is no way for the lock hardware to accept a code without it performing the unlock function.

The whole reason I’m here is to find a way to easiest arm my home every time I leave, and as we all know, the SmartThings Arrival Sensor key fob, as well as the smartphone app’s proximity sensor, are practically worthless with their false positives/negatives.

Huge disappointment; I might just resort to relying on the flawed smartphone proximity sensor for automatically arming my home, while having every successful code unlock entry to always disarm my home. Not perfect, but amazingly, the best current automated option if I’m not mistaken (and it doesn’t actually need this Lock Manager).

Hi! We use the Lock Manager app to remotely manage our lock for Airbnb guests, and I’ve noticed that it’s just recently stopped serving up notifications as it had been. I see all notifications as expected in the SmartThings app under More > Notifications, but we no longer get push notifications on phone or SMS to any of the numbers we’ve been using. Anyone else see this? I don’t know if the issue falls within the realm of Lock Manager, or the SmartThings app. I’ve verified that all of the phone notification settings are as they should be. Tried restarting hub remotely, etc. Looking for suggestions on things that we can try without having physical access to the hub or lock. Thanks!

it could be related to this?


Will there be an update to the Lock Manager app released that will make up for the disabling of the Contact Book feature?

1 Like


As a work around, you can use Pushover Notify Me When smartapp to get SMS or Push notifications of every time the door is locked or unlocked.

Another option is to use the ST Virtual Device Creator and the Notify Me When smartapps. Since Notify Me When does not work directly with locks, you can create a virtual switch to simulate your lock that works with Notify Me When. Create some automation routines that turn the virtual switch on and off. Have Lock Manager run these on and off automation routines as Home Hello Settings to sync the virtual switch to the lock status (on = locked or off=unlocked). Then setup Notify Me When to send SMS or Push Notifications when the virtual switch status changes.

Neither of these approaches are as elegant or informative as the Lock Manager notifications but at least it is something until the Lock Manager smartapp is updated.

1 Like

Ah, good info! I wasn’t really aware of that change (disabling of Contact Book) - thank you for the thoughts and ideas.

For some reason my app won’t allow me to enable or add new users. When trying to add new users, when I select a slot it’s as if I never selected it. After that I select the slot again and it shows up as slot 0 in the main user screen.

When I try to save the user, I get an error. I tried updating from the git repo, deleting the app, and starting over and now none of my codes will work. Anyone experienced this, my app is saying it’s version 1.4 for some reason also.

I’m having the same problem. Please help!

Same issue here so something got broke. I was getting an error saying to fill in all the fields so I went through and put “something” in all of them and it acted like it worked. It seems to have shuffled the slots but all of the codes are working.