[OBSOLETE] Lock Manager

What is the IDE? Is it easily accessible through the same app on my phone? Are you able to rename that code with someone’s name instead?

The IDE is the backend view into SmartThings. Think of it like an advanced user portal. It’s accessible through a mobile web browser, but is actually much better (imho) on a PC or tablet. It gives you a LOT of information about what’s going on with your smart home and devices. Oftentimes in the forums, you’ll only be able to do certain actions in the IDE, so I’d recommend learning how to navigate it if you plan on expanding your smart home beyond the basics. :slight_smile:

As far as I know, you can’t rename the code with a person’s name in the logging/recently views, but @ethayer might know better than me about that.

One thing you can do, however, is setup alerts so that if a user does use a lock code, you can get a notification on your mobile device. That’s setup in one of two places; Automation > SmartApps -> Lock Manager -> Notification Settings and/or when you create a user, clicking on the user and going to Notification Settings there.

1 Like

Anyone using a different DHT that works with the lock manager? When I use the one from ethayer, my lock goes offline. I have to then X out, the refresh manually. This happens once a day. I have tried the one from rboyapps without luck. It doesn’t go offline, but the lock manager doesn’t seem to be compatible.

It looks like each user that I set up applies to both locks unless I disable the use on one lock. Is this the way it’s supposed to work? User 1 code will be the same code for both locks in the slot assigned?

As I understand it, yeah, I believe it is supposed to work that way. Easier for the user and less steps if you have multiple locks setup. Unless you are using locks on individual rooms or buildings like a garage or something, why wouldn’t you want a user to have the same code on multiple locks?

I’m using this one for my Yale210 (Zigbee):

What type of lock do you have?

1 Like

Sorry I didnt specify, I am using a zwave kwikset 912. My zigbee locks work perfect, just the zwave ones are having issues.

Does anyone know if there is a way to set a yale keyfree uk lock to silent mode using the DTH (Z-Wave Lock-Reporting) from Lock Manager?

Yeah, not surprising. 90% of the time, issues are with the z-wave locks. Z-wave mesh networks are typically weaker than Zigbee networks (ymmv).

So, I’ll do the usual spiel about repairing your z-wave mesh from the IDE (not the app). However, I don’t think it is an issue with the DTH so much as the lock itself. I’ve seen a lot of people have issues with the 91x series and range. I just installed my first 910 (z-wave), so I can’t say for certain. My lock is about 15’ from my hub and I have a z-wave plus repeater in-between them and I haven’t had any issues with communications or the lock going to sleep.

I did find this little tidbit here: http://s7d5.scene7.com/is/content/BDHHI/912-programming-troubleshooting

The lock is in sleep mode.
If the lock has been unable to communicate with the system after
multiple attempts, it will go into sleep mode. Lock and unlock the door
with a key so that the lock status transmits to the system. If it still does
not communicate, remove (exclude/unpair) the lock from your system.
Then, pair (add/include) the lock with your system again. If the problem
persists, add a repeater or router between the controller and lock if none
presently exist in the system.

Nope. You’d need to program that at the lock itself or use the DTH provided by @RBoy ([RELEASE] Universal Enhanced Z-Wave Lock, Schlage Lock, Yale Lock, Kwikset Lock, IDLock, DanaLock and August Lock Device Handler with Alarm Control, Notification, RFID, Door Sensor and advanced features).

1 Like

ok, thankyou for your quick response, is this DTH from Rboy only available if you pay for it?
i dont have an issue with that im just curious?

Yeah. But, well worth the price. @rboy does some amazing work. Plus, you also get access to his other apps/DTHs.

1 Like

thankyou, ill head over and purchase it now…

2 Likes

When I refresh the lock, smartthings then shows the lock as reporting ok. This is without me touching the lock. This is why I was thinking the dht was having an issue.

Hmmmm… yeah, that’s odd. Have you tested it with the stock DTH? Also, have you noticed anything in the live logs?

I did try the stock DTH, didnt want to learn the codes. The live logs show no errors. It would seem that the lock goes to sleep before one of the polls. Any idea where the timeout setting in the DTH is? I’d like to try and decrease it and increase the polling rate alittle.

There isn’t any way to set the timeout in the DTH that I’m aware of. @ethayer may be able to expose that in the DTH though. If he does, then you could set it. but it would require him doing that OR you forking the DTH (from git) and adding it yourself.

I have two of these locks, and I’m having the same problem. Here’s the thing though - I’ve had them for about a year, and they only started causing a problem in the last month or so after I upgraded from the old (legacy) Lock Manager and installed the new (current) Lock Manager along with the updated device handler. Or perhaps it’s related to a ST update. But either way, it makes me skeptical about it being the lock itself that’s causing the problem… of course, I could easily be wrong lol.

Like you, I find that sometimes refreshing in the app “wakes” it back up again, but not always. Sometimes manually unlocking/locking the door helps SmartThings see it again too. But 90% of the time SmartThings just says it’s unavailable and doesn’t show the current status.

Would love to hear about any resolution you find, but also happy to help troubleshoot if anyone has any ideas, or perhaps @ethayer if you have anything that could be tried with the DTH.

Thank you!!

Jake

Edit: Might be worth mentioning that, in addition to the lock working in the past, I have plenty of z-wave light switches between it and the hub (all of which support repeating)… also, this is an NYC apartment, so it’s not really that far from the hub anyway!

When I try to add or update a code, I get a push notification that “controller failed to set code for …” I can see that the slot that I have tried has not been updated yet. I get this message every minute. I have tried to fix it by locking and unlocking my door with the smarthings app. Sometimes I think that fixes it sometimes before but not now… It does not seem to be updating. Any suggestions?

Just so you know you’re not alone - my problems started with the same issue. The app could no longer push codes to the lock, and now ST can not communicate with the lock at all.