[OBSOLETE] Leviton Decora Z-Wave Plus Dimmers (DZ6HD & DZ1KD)

Have you tried toggling the circuit breaker? If that doesn’t help, maybe try exclusion and re-joining the z-wave network.

Same rattle here, very annoying and I’m also OCD about it. I just exchanged my wifi version for this zwave one, the wifi paddle was fine but this is loose as heck

Hey Jason, I tried toggling the circuit breaker & repairing the Z-wave network, no luck.

Today it’s 2 out of the 5 Leviton DZ6HD that don’t return anything on the live log on the “Refresh” command, making them “unavailable” in Smartthings.
The switches that work/don’t work seem to vary day after day. Since I only have 1 hub (Smartthings), I’m not too sure what’s happening, if that’s an issue on Leviton’s side or the Smartthings code

It almost seems that your Z-Wave network itself is unstable. Is your hub in close proximity to your devices? Also have you tried removing those dimmers and re-joining them to the network? This is different than Z-Wave repairs.

@jasonxh, first off thanks for all your work on this device handler! In have been using it for a couple weeks now and everything has been wonderful with it!

I have noticed that when I turn the light switch on using the smart things app it powers on and off then light in 2 seconds regardless of what I have the power on power down time set too. When I use the physical switch, it follows the power on/ power off time I have set in the app. For example my porch light I have set to brighten to Max brightness in 10 seconds. Pressing the physical switch, it follows that time, but when I use the smart things app the light powers on ~2 seconds. Is this normal behavior?

Thanks in advance!!!

1 Like

I already set load type with the paddle originally to LED, but now I see after installing this dh (thanks btw) that in the IDE under preferences, load type is blank, and I’m unsure what value to enter to set it, if it even needs to be on here.

1 Like

I pushed out an update to respect dimming duration when turning on/off. Please give it a try.

1 Like

The configuration page is in some sense “write-only”, in that any change on the page will trigger relevant updates to the device, but it doesn’t display any changed settings made elsewhere (such as on the device, or through some other utils). It’s perfectly OK to leave any field blank when applying changes, which simply means “don’t change this setting”.

1 Like

Perfect, appreciate the reply, and the DH, it’s working well.

thanks! Ill be back home around 8pm est and will give it a go then!

I was able to test everything out last night. Button presses at the switch, in the smartthings app, and voice commands via Google assistant all now follow the dimming duration. Thanks!

If I want to be able to hit the ON switch and select a duration, is there a smart app specifically for this light switch to do that, or what is the best/easiest way?

You can do this with webCoRe.



Great DTH! Much better than generic driver.

1 Like

Thank you for this. It works great. I thought there should be something that takes advantage of the programming available for this dimmer. What is sad is that Smartthings sells these on their web site and does not have as detailed of a device handler as this is. Thank you so much.

1 Like

Thanks @jasonxh for this DH, it has worked well for me. Lately though, I noticed that it is ignoring the default light level I’ve set with your dh within the st app, I have it set to on at 100%, but instead, it has been resuming whatever it was turned off at. Any ideas?

1 Like

Thanks for reporting the issue @dtm2525. It turns out the device firmware respects the setting only when turning on from device itself. It doesn’t respect it when turning on from app, which I assume is the problem you are experiencing. I’ve just pushed an update to the DTH to explicitly tell the device to turn on to the preset level.


I think I just did the copy/paste route the first time I added your dh…so to get the updated version, I guess I just go and copy the updated code and replace the old?

I’ve added a few DH and smart apps now with GitHub, but still kind of confusing for me to figure out how sometimes. Is there an easier way than trying to figure out the name or author or whatever it is you’re asked for when adding a repo manually before adding a specific dh like this, or can the gh link you provide in your first post be used somehow to link it more efficiently?

A quick search returned this FAQ: Github Integration How to Add and Update from Repositories. Might be helpful as a general guide.

You’ll need 3 pieces of information to add a repository to your SmartThings IDE: owner, (repository) name, branch. When you see a link to a github file, it’s usually in the following structure:

I’ll also update my original post to make it more explicit. Hope this helps.

@jasonxh, thank you for writing this driver. I have a few of these switches around the house, and your code is so much more useful than the generic DTH!

I have a curious issue. I wonder if you have encountered any of it?
I have several DZ6HD, yet none are very stable. One day it’s switch 1 that shows offline in smartthings, the other day it’s switch 2, etc etc.
I often have 3-4 switches offline in smartthings, while the others work fine.
However the offline ones still work from Homebridge (which goes through smartthings by homebridge-smartthings npm !!).
This really makes me wonder if it’s some kind of graphical display status glitch in smartthings. The command actually works if ran (from homebridge for example). But from smartthings, the GUI interface is blocked (not shown), making it impossible to send the command even though it would work…

Is there anything you cam think of that could solve it? I’d be happy to dig into the code as well, but the likelihood of me finding a fix is a lot smaller haha