[OBSOLETE] Jasco/GE Motion Switch 26931

@Nhaley - Would you mind checking whether your switch paired in secure mode? I believe you can check in the IDE under Raw Description. I believe it would say zw:Ls for secure and like in my case just L for insecure. I am not sure why it is not connecting in secure mode in my case. I am guessing it cannot reach the hub directly and I do not have enough zwave plus repeaters in between. If anyone can confirm this might be the case it would help…

@Nhaley - Is your switch close to the hub or do you have other zwave plus repeaters in between that may be relaying the secure messages?

zw:L type:1001 mfr:0063 prod:494D model:3032 ver:5.28 zwv:4.05 lib:03 cc:5E,72,5A,73,27,25,2B,2C,70,86,71,60,8E,85,59,7A,56 role:05 ff:8700 ui:8700 ep:[‘1001 5E,59,25,20’, ‘0701 5E,59,71’]

Thank you for helping me figure out why mine is not working.

Here’s what I’ve got:

zw:L type:1001 mfr:0063 prod:494D model:3032 ver:5.28 zwv:4.05 lib:03 cc:5E,72,5A,73,27,25,2B,2C,70,86,71,60,8E,85,59,7A,56 role:05 ff:8700 ui:8700 ep:[‘1001 5E,59,25,20’, ‘0701 5E,59,71’]

Looks identical to yours.

Mine is about 25’ from the hub, line of sight, but there are a couple zwave devices in between.

edit: I’ve gone through a network repair without incident…

I wonder what the configuration button on the left side of the top button (only visible without the wall plate). I did not find any explanation for it on the instructions however when I try to pair the switch it seems to only become visible to ST once I press that button even though I believe the instructions just say to press either the top or bottom buttons.

It’s there in the manual - it handles occupancy/vacancy/manual adjustments per the manual (see configuration button H).

@Nhaley I’ve managed to get reset cycle setting to work. It changes the amount of time between when motion is detected and when it reports back. I’ll get that in the next update once I clean all the changes up.


I installed mine today with the DTH above. It worked with no problems… I see the light switch and the motion sensing and things work great thus far. Nice work. I do have a lot of other wave devices so pairing was no issue at all.

@kjdayley - any chance your switch is able to talk directly to the hub or that you have other zwave plus repeaters that relay the encrypted messages? Mine is still not working even though I have at least 60 wired zwave devices (all switches / dimmers / fan controllers - - therefore repeaters) all over the house but the vast majority are not “plus”. I keep wondering whether I need to add/replace non plus versions with newer plus versions to strengthen the zwave plus network (I am under the impression that older zwave devices do not relay encrypted messages from newer plus devices - can anyone confirm?).

No. This is my first “plus” device.

updated the OP with the latest. Added ability to associate with other switches.

1 Like

This latest version fixed the motion sensor. It now works as expected. Thanks!

Has anyone been having to airgap your switches now and then? Seems maybe every 2-3 weeks I’ve got to airgap one or the other to get it to work at all. Not related to smartthings, just to even get the sensor or buttons to work.

I have had this happen once.

Not working properly with ActionTiles - here’s the reason why:


edit: Clarification: The motion sensor part is not working with ActionTiles. The switch works fine.

Hmm. If it happens again I’ll dig deeper.

The ability I want the most is to switch the motion mode with house mode. For example this would be great for a bedroom if It I could use “occupancy mode” while the house was in “home mode” then when I switch to “night mode” the switch itself could change to “vacancy mode” ,so the light doesn’t come in while I sleep.

That is possible using this device handler and core

Made a lot of changes since the last update, this is the release candidate now.

Added github integration.


@mlebaugh - Thank you for your continued development of this DTH. I submitted a couple minor issues via github but I am not sure you are monitoring that, plus I noticed a much larger issue soon after posting those. The motion tile with the ST DTH no longer shows movement and the light no longer turns on with motion. However, if I click on “motion” under “Current States” in the IDE DTH, I do see the motion events. It seems like these events are being ignored and not passed back to the ST app. If I manually turn on the light, it will turn off with a delay. This is the same thing, if I recall correctly, that was happening with the first revision. Then you made changes which fixed it for me, and now it is back as before. I wonder what is different between my 2 motion switches and the one(s) you have. Any ideas? Anything I can try to fix it?

The other few issues are:

  1. Mode tile not working. See image.

  2. Orientation typo in settings

  3. DTH title in the comments at the beginning of the code mistakenly refer to the dimmer version which might confuse some.

Would it be possible for you to add a revision number to your code so ones knows which version they have?

Thanks again for your great work!

EDIT: By cycling through the modes and ensuring it was actually on “Occupancy” the motion sensor started reporting motion again and the light goes on/off with motion. However, the DTH does not retain the mode on the tile after each exit from the DTH.

@aruffell Thanks for looking over the device handler a second set of eyes is always helpful! I’ll merge your changes soon, still learning GitHub.

  1. I’m not sure what’s going on with that, it is happening on my device as well, I didn’t notice this as I only set the mode with CoRE or webCoRE anymore. I think it might have to do with the type for the setting, “enum”… But have to look deeper when I can.

  2. Spelling is hard :slight_smile:

  3. A version number is a really good idea, I’ll add that next time I have a chance.