[OBSOLETE]Intermatic PE653 Pool Control System

Good Morning! Thank you for responding. I agree that the logs do look correct.

The physical temperature on the heater is not changing from say 70 to 75 degrees when I put the command into HE.

The water temperature reports fine.

The issue with EP5 is just a different behavior than I recall from ST.

On my physical PE653 I have 5 buttons well button number 5 now is required to be on in order to operate the heater. As I don’t recall this from my ST days I thought perhaps this was a preferences setting in HE that differed from ST.

As to checking with the remote that would be great but I cannot remember how to pair the remote back to the PE653 as a secondary controller. I re-reviewed the instructions from the PE653 manual about RECV Net and Config, but there is nothing in your app to SEND Net and Config.

Keith, I found a way to fix the save issue on my device.
I modified the device handler to remove all the defaults. After that I was even able to put all the Modes preferences to Null.

From : http://docs.smartthings.com/en/latest/device-type-developers-guide/device-preferences.html

Additional notes
Setting a default value (defaultValue: “foobar”) for an input may render that selection in the mobile app, but the user still needs to enter data in that field. It’s recommended to not use defaultValue to avoid confusion.

I have some questions:

  1. Is the configure button on the bottom left supposed to do something?
  2. There is some weird behavior with the handling of Celsius temperature. Could you make the whole thing forced to display in Fahrenheit? The PE653 doesn’t handle celsius anyway.
    2.1 The temperatures setbar have range of 40 to 104, which is try to make a setpoint on the device by converting the temperature from 40C-104C to 104F-219F, which doesn’t work.
    2.2 Sometimes the UI show the temperature in F, but most of the time it’s in C
    2.3 Setpoint temperatures for modes are also 40C-104C on my device.
  3. Sometimes the icons seems to be randomly appearing/disappearing. Mostly the VSP (I have 1 speed pump) and the pool/spa button.
  4. Is there anyway to get the air temperature as well as the water temperature?

These are all great suggestions. As I am working on a major update to the DTH I will incorporate as much of this as possible. Thanks!

Hi all,

I am looking at automation options for my pool. I am considering the PE653, but I will need eight actuators, and the P5043ME expansion module supports only four. Is it possible to hook up two P5043ME modules to the PE653? I am also considering the Jandy Aqualink as an alternative (they seem to support up to 12). Does anyone have relevant experience here? Thanks.


Is this doable in the new update you are working on?

Probably no, as it’s not in the user manual. However it’s probably possible with a software update (from an hardware point of view), if not. You should try contacting Intermartic directly.

Have you considered using normal Z-wave light switch for some of the relays? I never tried, but you can add z-wave components to scene controlled by the pe653.
If you don’t need separate control, you can also use the add-on relay to connect multiple devices to the same control.

BTW, is there even a device handler for the Aqualink? I think you’ll need the use their proprietary app.

Thanks KeithR (& all the other contributors) for all of the time & effort spent on this. Really. Thank you. I wouldn’t have bought a pe653 if it wasn’t for this DTH.

I’ve installed the DTH & am playing around with it. I’m an Android user & had the same initial config issue as others. Once initial values were set in the IDE, all was well. There seem to be some problems with not reflecting the current state of the VSP and some quirks setting the heater temp but since a new version is in the works I’ll ignore for now.

I run a Pentair VSP & a heat pump controlled via fireman’s switch (no spa) and have the pe953 remote set up as a secondary. We can add my config in to the test mix.

Because I have the pe953 remote I’m not dependent on the smartthings app. (yet!) If you want me to try pre-alpha releases or debug releases just let me know. I don’t mind if they don’t work well or if I have to reset.

Thanks again.

I’m waiting too patiently… I have VSP and wish to be able to control the pump like the PE953 when I’m not home. Especially when my pool guy would run the pump with the buttons on the PE653 and walks away. I have seen sometimes, the pump is running for 2 days before I discover it and shut it down. I want to detect it and turn it off manually or automatically.

cslee, How do you turn the pump on with the buttons on the 653? I thought the buttons only activated/deactivated the circuits wired to the corresponding numbers.

Somewhere in the menu system you can turn on the “Cleaner” function and then set the speed of the VSP.

I must be blind. I just re-read the manuals and can’t find it.

Hi tijonx,

Thank you! Is it possible to use a normal Z-wave light switch for the 24V actuators? I thought it would have to be a dry contact switch like the Remotec that is powered by 120V but switches 24V. But I get the point that I could hook up another device.

No, there is no device handler for the Aqualink for now, but I hear the proprietary app is solid. Also, my pool equipment is probably 100ft from the house, so I would likely need a repeater if I go for the Intermatic, whereas the Wi-Fi signal is fine to that range.


Here’s what’s in the works:

  1. Convert to “Composite” DTH which will re-enable Multi-Channel (multiple “things”)
  2. Improves VSP integration. No longer uses funky schedules to control VSP and can read current speed even if set manually or by remote control. (@cslee )
  3. Ability to set the Controllers clock.
  4. Display air temperature.(@tijonx )
  5. Incorpórate adjustments for Hubitat compatibility. My goal is to do this in a way it is compatible with all platforms. Hoping to get results from latest HE firmware testing soon.(@JDogg016, @CAL7)
  6. Remove defaults to fix Android config issues (all Android users)

Most of this work is complete. Should be ready in another week or two

1 Like


Thanks again. Can I paypal you $10 for a beer/coffee/red bull/water or is that not allowed on this forum?


I believe on page 45 is "Configuring for Booster (Cleaner) Pump "

I spent far too much time dealing with this and trying to understand today (had to read every word of all 595 posts to fully get it all).
But I want to say 3 things:
Saying, “hey Google, turn on the Polaris,” and watching it come to life is more magical than I ever expected to see out of this old pool.
I still have some work to do, and I’m excited to see that it’s still being worked on.
@JDogg016, @KeithR, and bigpunk6 and others, you are wizards, saints, and scholars.
Hats off.

1 Like


Just wanted to see if you at able to ask Google for the pool temperature. I have tried and cannot get it to work. Not sure if I am not using the correct phrase or if it is due to how it is setup

Actually, I’ve never hooked up the temperature sensor on my system, so I haven’t even tried. Lemme ask anyway…

No dice. But I do plan on hooking it up in the near future, and I’ll certainly keep trying to see what I can do with voice. I’m very new to smartthings… Just hooked up the link yesterday.

I do have a question/issue that just came up.
Yesterday, I followed the instructions on post 238 to get my 953 remote back up and running so I could program. Got it all done, set up my settings and programmed everything.
Later, I used my daughter’s iPhone to connect to smartthings and make configuration changes, confirming that the “please fill out required forms” Android bug can be fixed by connecting once with iOS. Fixed a few things that way.

But now this morning… No pumps running. And I looked on my 953, and all my timers are wiped out! Does connecting and making changes in the app wipe out the programming on the 653? I even exited out after programming the timers and went back in to confirm they were still there. But it’s a blank slate now.

Is this expected?

I have a bunch of questions.

I have a 953 and 653.
I have 2 Speed Pump. 220V

It should only ever power Circuit 1 or 2 and never both.

If I pair the 953 and set it to 2 Speed Pump the 653 behaves correctly and if I Click button 2 when button 1 is on it shuts button 1 off first then turns on 2. And vica versa.

As soon as I unpair the 953 the 653 forgets it has a 2 speed pump. That’s fine.

But when I pair SmartThings up and configure the custom device handler to 2 Speed pump with no boost it does nothing to keep channel 1 and 2 exclusive. Is it supposed to?

I tried setting up 4 modes for high, low, all Off and light but it momentarily has channel 1 and 2 on.

Is there a SmartApp that goes along with this device handler I need to use? How do I setup a schedule?

Can the SmartThings and 953 both be paired? I did manage to add the 953 to SmartThings while 953 was paired to 653. But all the 953 would do is display out of range.