[OBSOLETE] - Hive (Connect) V3.2c (British Gas Hive)

several ways but not connecting, the app is failing dramatically keeps coming up with error codes,


All customers can use the universal sign on, regardless of where they live:


No matter what shard your account has been assigned to, that URL will locate the correct one for you. Saves a lot of confusion. :sunglasses:

FAQ: How to find out what "shard" (cloud slice IDE URL) your Account / Location is on?

1 Like

Hello @Alyc100

I have a couple of Hive warm to white bulbs which were previously working fine through your app. But I wanted to put them into a group as I always end up turning them on/off together. They won’t turn on and the logs show a Malformed Request :

535229f7-1a64-4add-897f-5ecd773b12f7 8:38:09 PM: info Body: [error:MALFORMED_REQUEST]

535229f7-1a64-4add-897f-5ecd773b12f7 8:38:09 PM: info Status: 400

535229f7-1a64-4add-897f-5ecd773b12f7 8:38:09 PM: debug Beginning API POST: /nodes/tuneablelight/e7e8ce77-3d83-4f3e-8723-4c96be6e1bbf, [status:OFF]

535229f7-1a64-4add-897f-5ecd773b12f7 8:38:09 PM: debug isLoggedIn state

I’ve got hive-active-light-tuneable.groovy device handler in the IDE. Any suggestions how to debug further ?


So I’ve tried to create this smartapp but when I click on create I get this error

startup failed: script_app_metadata_873f64ba_b742_4324_8d09_19832e1be6b5: 1: unexpected token: @ line 1, column 42254. mation" : “Hive (Connect)”}" } ^ 1 error

Hi @Dave_Clarke I may be wrong, as I am new to this but have you tried copying and pasting the contents of the link then publishing it?

Had the same issue, when I copied and pasted from line 1 through to 1488 it worked.

Miss out the “create” and go straight to publish?

Is it possible to use the temperature reading of a remote temperature sensor instead of using the reading at the smart radiator valve as the room temperature? (Some manufactures give their smart valves an offset parameter to achieve this in a roundabout way)

I haven’t seen any function of an offset, or any adjustable parameters for the sTRV’s at all.

They should think about it really. EVO home does. It’s missing along with open window sensoring and sTRV pairing for rooms with more than one rad.

Shame really.

Thanks @barron . Although, open window sensing software is quite hit and miss. A physical window sensor is best depending on the cost benefit / how mental the offender is :smile:

Agreed. My brother has the Evo home system says it works great! :rofl:

I’ve been struggling with this. Although both hot water and heating, including radiator valves work. I don’t have any buttons to boost! Also they all come with hot and cold temperature slides and modes, as well as ventiliation controls, both heating and hot water! Doesn’t seem like the control interface coming through is correct for hot water and heating. any ideas?

Just wondering if there will be any support for the Hive Door and Window sensors?

Just wondering if this was ever done?

Sorry for the delay in responding, go to Smart App and then copy and paste the contents of the github link then save and then publish. You need to “create from code”.

Hope this helps.

I have been having problems with the Hive disconnecting on a daily basis and then having to delete from the app and re add.

Have just reinstalled the Smart App and republished that and the 2 device handlers that I use - Hive Heating & Hive Hot Water.

Will see how I get on now.

BEER! Can you post a screen shot please?

User error, now showing up under automation, one quick question when Samsung remove access to the IDE will you be able to make some connection between ST and Hive?

I will get buy you a beer as this is a great app :slight_smile:

Today, I’m getting Error 403 forbidden in the smartapp…

It has worked OK in the past. I did migrate to the new app - I wonder…

The Hive Heating GUI shows ‘Cooling’ and ‘Fan’ controls. These are not mentioned in the Hive connect code so I’m not sure where these come from.
These 2 controls are not relevant to my system so would like to remove them. I’m guessing it’s Hive code so it cannot be amended by the end user

Had to deletes all and reinstall.works now…

Old app and new app, same smartapp and devices

Just about unusable now…

1 Like