Hive Connect not Working

Hi, I’ve been having problems with a few Hive devices over the last few days and I noticed another thread on this which seems to indicate the Hive Connect integration is no longer working.

I’m on the latest Hive Connect code but it will not authenticate hence why its not working for me.

As anyone else experienced these problems and anemone know to a fix yet?



Just set up my hive today and went to integrate to find I am getting the same message…will not authenticate :frowning:

I looked at this a bit more.

I can get a session ID from so I tried hard coding that into the smart app but the API seems different, we can’t retrieve /products from that URL whereas we can from - I doubt its worth re-writing the smart app to use as that’s supposedly deprecated.

Running this :

curl -X POST -k -H ‘Content-Type: application/json’ -i ‘ ’ --data ‘{“username”:“my_email”,“password”:“my_passwd”, ‘devices’: false, ‘products’: false}’

results in :
HTTP/1.1 403 Forbidden
Content-Type: application/json
Content-Length: 42
Connection: keep-alive
Date: Thu, 01 Oct 2020 12:16:09 GMT
x-amzn-RequestId: 08504a9a-031f-4fee-9e0e-1a3cce47d6cf
x-amzn-ErrorType: MissingAuthenticationTokenException

MissingAuthenticationTokenException seems to be some sort of AWS thing but I didn’t find out much more than that.

So either Hive have permanently changed something, or accidentally. Maybe we need to bribe @Alyc100 with beer to take a look ? :smiley:

1 Like

So Im resigned to sacking Hive off, as Kasa (tplink) is officially integrated into Smart things.

Same here, not connecting via ST smart app, 403 error. p.s. same problem with using Home assistant. Authorisation issue.
@Tim_Jones is right, maybe @Alyc100 would be able to check out the issue. :grin:

@virtusas I don’t suppose you have a link to where it’s been reported on home assistant forums (assuming you saw it there) ? Might be worth following to see if someone there figures it out :wink:

@Tim_Jones i dont think I have seen it anywhere yet. Was trying to see where to report issue, but couldnt find where. So just posted generic post via twitter to home assistant community. No reply yet. Its only 2 days since its not working, and dont know how many people would have this integration before they notice issue. But if i see anything, will post link. As I believe it may be linked in some shape or form this authorization issue.

Quick browse through the HA forums…

wow, those guys are quick :slight_smile:

There is a URL change, so edit your smartapp in the IDE and change line 1253 from :

uri: apiBeekeeperURL(’/global/login’),


uri: apiBeekeeperURL(’/cognito/login’),

There’s still something funky happening as when I enter my Hive credentials, it stays at that screen and doesn’t let me choose devices (Could be due to all the messing around I’ve done) but the live logging in the IDE started reporting my Hive devices. I needed to force quit the app on my phone and I can now see and control my thermostat and lights.

Anyone else want to test this to see if it works for them ?


Dont mind testing it but the app looks different to what you suggested.

Mine is on lines 101 and 102 and look like this

def apiBeekeeperUKURL(path = ‘/’) { return “${path}” }
def apiBeekeeperURL(path = ‘/’) { return “${path}” }

Yep, works for me to. :slight_smile:

Smartthings is my main automation platform (Most of my devices are concealed Fibaro and other Z-Wave type devices) and the fact I could not control my Hive devices through SmartThings in the last few days was driving me mad.

First I tired updating the Hive Connect smart app thinking it was due to I was using a very old version, but that did not help. Then I jumped to the latest post in the Hive Connect Smart App thread (what brought me here) and saw others were having the same issue.

So glad that it’s now working again, at least it is for me right now.

There’s still something funky happening as when I enter my Hive credentials, it stays at that screen and doesn’t let me choose devices

Not issue for me, just the simple changing of line 1253 in the smart app (of course save and re-publish) and then re-entering my Hive credentials in the Hive Connect SmartApp on my iPhone. Bingo!

Thanks so much Tim.

Regards: Elliott.

Thats weird I did the same and updated Hive Connect from this link

But my authentication lines are 101 and 103

Ok so updated the SamrtApp code again and this time line 1253 is correct. Changed the word global to cognito and it seems to allow the smartapp to authenticate with Hive and find my devices. However at the moment the ST app is still listing the Hive devices as off line … might need to give it long to refresh and see.

But might be a good fix … lets see

Thank you Tim

Try closing down the main SmartThings app on your phone and re-opening it. I am still using the classic smart things app on my iPhone.

Tried a refresh and all devices apart from the Hive Heating thermostat is working . The thermostat still says offline… going to check the DH for that

Same, forgot to test my thermostat.

Think I have worked it out, delete the old thermostat device if you have a duplicate. I had two identical “Hive Thermostat Hive Heating” devices.

Ah yeah. I had a duplicate heating device too but I put it down to all the debugging I’d been trying.

My water is showing ‘checking status’ on the main tile but shows the status when I click on it. But it was doing that before this auth problem started…

Well it’s authenticated and allowed me to re-add the SmartApp and the thermostat but it seems to be read-only.

It read backs the temp but won’t change any settings, boost, etc.

Mine is still not working can anyone help?

This took me a little longer than it should have, make sure you have selected your HomeHub from the ‘My Locations’ in the IDE and not on the Generic settings, then save and publish the new code for SmartApp.