[OBSOLETE] Aeon WallMote Dual & Quad - 2 & 4 Button

Thanks for doing the DH for the wallmote.
I am trying to control it with WebCoRe. When I do a switch case on the button value, I get push or held. I don’t get the button number…

Any idea?

UPDATE: the “switch… case” doesn’t seems to work, but if I do a If… then, then I get to choose for button any, #1,#2 etc.
I did one “if … then…” for each button and it works perfectly.


1 Like

Ok, I have a quad Wallmote and use it with SHM and our 2 android cell phone presence detectors. When both cell phones leave, ST routine Good Bye activates and sets SHM alarm to away. When either returns, I’m Home activates and disarms.

I have my 4 standard routines and button assignments. Good Morning (1), Good Night (2), Good Bye (3) and I’m Back (4).

The problem i have is when using the Wallmote to activate Good Night (arm - stay) and Good Bye (arm away). It activates either of those as it should, but then IMMEDIATELY activates I’m Home routine and disarms SHM.

I guess my android presence (cell phone) in house is detected again immediately and activates I’m Home???

How should I set this so android presence works as it does and should with SHM but not interfere with the Wallmote buttons and keep looping to I’m Back even after pressing Good Night or Good Bye mapped Wallmote buttons?

Thanks for the help.

Presence shouldn’t activate I’m back unless you leave and come back (or your presence detection isn’t working right). I tested your process with my WallMote and I am not seeing the same behavior. Are you using the options in the routine itself to activate the routine on a button press? That is how I did it and is probably the simplest way. Try enabling the notifications on the routine to see if it is activating I’m back. You should get a notification saying “I’m back was performed because so and so has returned”. That will help you narrow it down.

Also, check the SmartApps tab for the wallmote to make sure you don’t have anything else setup that would trigger both on a single button press.

Thank you Eric.

Followed your advice and when doing so I checked my settings.

Under Hello Home, I had a routine of Good Night! and Good Bye! set when buttons 1 and 2 were HELD respectively. This is what I wanted and obviously the problem I’m having.

So for now, I changed it from HELD to just PUSHED which is fine.

And it works now? Even with Android Presence of both phones home. But as you say, that should only change upon leaving and returning…and after my 10 minute setting.

Reason I had it set to HELD, so kids etc don’t accidentally press those buttons which in turn ARM SHM.

Thanks Eric for the help and the DH of course!!! : )

I’m trying to connect a wallmote quad.

I added the code device handler
I added the device type

Smartthings detected the wallmote and I added it

Setup button actions through smartapp

Buttons on wallmote don’t work
Under device info it doesn’t show battery %
– in the first two lower boxes
Configure with a red dot that does not do anything when clicked…

Any suggestions? I was so happy when I finally got it to be detected and now I’m just bummed…

Thanks in advance for any help,


P-touch labeler works great.

I think the configure button with red dot is for status only? I think after you change the setup and when ready red dot disappears?

Are you pressing and holding the button on the back of the WallMote until it starts to flash yellow? Then hit the configure button under the device in ST.

Just tried that, unfortunately no luck…

Have you definitely applied the correct DH to the device? If you go to the device in the SmartThings app and hit the little ‘config’ icon in the top right corner what do you see under there?

This is the first time I’ve tried to do this so most definitely not definitely!



This is what I see when I click the ‘thing’ which i notice is not like some others I saw above

OK, so make a change to the config, tap on the ‘Done’ button, hold the button on the back of the WallMote until it flashes yellow then press the Config button on screen.

Failing that, plug a charger into the WallMote for a few seconds, sometimes depending on the f/w it could get stuck. If that fails I would exclude it from ST, factory reset the WallMote and pair it back again. Occasionally things happen and perhaps it did not complete the pairing process properly.

After excluding the WallMote I would also reboot your Hub via the IDE, I have a feeling that ST are making cloud and local changes remotely as I have had numerous funny things happening to my devices in the last week or so. Bouncing the Hub seems to sort these. Nothing to lose in doing this.

Thanks man, appreciate the thorough help.

I’ll try these as soon as I get home.

Thank you Eric,
button on / off is normal , How to set the dimmer control ,Up and down the sliding dimmer, Light intensity does not respond, how to set?

My understanding is that the (awesome) person who wrote the code that handles this device did not include slide functionality.

(But if I’m wrong someone please correct me because that would be a sweet feature to have!)

So it took resetting the hub and the factory reset on the wallmote but it’s working!!

Thanks so much!

1 Like

Glad you got there! Happy Button Touching! :grin:

Already driving my wife crazy

To properly use the dimming functionality you need to do a direct Z-wave device association. A great tool for that is the Z-Wave Tweaker.