[OBSOLETE] 3 Speed Ceiling Fan Thermostat

Is there a way to turn the fan off manually without it turning right back on?

Yep, I see the mode selection isn’t functioning right. I’ll take a look when I get some time

In Configure Option Settings you can set NO for the Enable Ceiling Fan Thermostat. The default is Auto so when you don’t want the automatic control set this option to No.

I guess this is not going to work for me then. I want the option to have it auto and manual so I can turn it off and on when I want and auto.

I am a little confused since that is what the setting provides, you have automatic control and turn it off for manual control. However if I understand you correctly though you want the ability to set that option without having to go into the Option Settings screen?

Correct, I want to use the wall switch to turn it off and right now when I do that it turns back on.

Gotcha. You might be able to do that with WebCoRE? You need the ability to recognize anytime the switch is manually pressed on or off and have that turn off your auto control.

1 Like

I will give that a try, thank you.

I just got a GE In-Wall Zwave fan controller (model #12730) and am using the 3 Speed Ceiling Fan Thermostat app to control it. I’m having an issue with the motion turning it off. I can walk into the room and the fan will turn off but it never turns off. Anyone out there having the same issue and know how to fix it? I’ve tried two different motion sensors - the Iris Motion Sensor and the Aeon Labs MultiSensor 6. Any help is appreciated.

Your hardware is not the issue. The options are not turning off the automatic control for some reason. I will take a look to see what is breaking it when I get a little free time. Sorry the inconvenience. I took out my GE controller temporarily but get it back online soon to check it.

Thank you!

I’m not entirely sure I understand what you are trying to do… In my installation of the app I have two different setups.

Awake fan:

This is set to turn on only when motion is detected in the room and the temperature is above the threshold. I also have it setup to turn off several minutes after the motion stops (so if I’m going in and out of the room the fan isn’t constantly turning on and off…) It this generally seems to work pretty well.

The awake fan is also limited to specific modes specifically modes that I’m likely to be walking around doing stuff (when I’m Home and it’s morning, daytime, or evening.)

Sleep Fan:

This fan is purely temperature dependent but is limited to modes when we will be in the house and sleeping (since motion sensors don’t typically pick up motion when sleeping.)

For temperature control I have a Netatmo Indoor sensor in our master bedroom which reports temperature changes every ten minutes.

I use an Iris sensor for motion and the reason I don’t use the Iris for temperature is because it will often go hours without reporting any temperatures and even now it is reporting a temperature that is 3 degrees lower than the Netatmo indoor module.

I’m basically trying to do the same thing. The problem I’m having issues with is the fam does not turn off after the motion timer runs out.

If the fan is set to low speed will this app start it at high speed and then lower it?

Edit: found the info above. Starting at high speed is important on my fans. Good to know this will do it.

I put together a webcore piston that does this using a virtual thermostat. Im new to coding so it took a while. Could have saved a lot of hair pulling if I would have found this a day or two ago.

If the fan is already running , no. Only when the fan is already OFF and is being asked to turn on to LOW speed will it do a 1 second bump to HIGH then drop down to LOW speed. If it is being asked to go to MED speed the temp bump of High Speed does not occur.

If you are referring to the Zigbee 4-Speed version however, I currently disabled that feature because that device wasn’t handling the temporary bump very reliably so I am troubleshooting zigbee communication issues.

1 Like

Just curious if you have had a chance to check out the motion issue I mentioned?

Hi Scott, been busy on another device using the zigbee ceiling fan control for the time being and I haven’t looked closer at that yet but it is absolutely on the radar.

Any updates? It’s been over 3 weeks. Thanks!

I’m also experiencing the same behavior as @Vette0067, in two different rooms with two different fans/motion sensors. One room has the GE 12730 fan switch, using Ecolink PIRZWAVE2-ECO-2 for the motion sensor and Ecobee 3 thermostat for the temp sensor. The second room is using the GE 12730 fan switch, and Smartthings SmartSense Motion Sensor w/ temp sensor (2014 model). The fan stops when the temp is below the threshold, but never when the motion stops.

I copied the code into SmartApps and Published…when i click on “New Fan Automation” it forever loads and does not take me into the settings. Anyone else experience similar issues?

I have the same issue.
It looks like a bug on SmartThings latest app for Iphone I guess.

Here’s a thread about it:

So I found a weird workaround.
If you tap New Fan Automation and wait until your iphone screen sleep ( be total black) than you unlock the fone again so the Smartthing App will come up. On my case the Automation was created without any name so I clicked and worked.

Give it a try :slight_smile: