Now my modes aren't working as preconditions

I got my issue with sunrise/sunset working by not using Smartlighting. But now I’ve noticed that I have a routine that seems to be ignoring a precondition. This worked fine up until recently.

I have 4 modes: Home, Away, Night, and Late Night. I have a routine that changes the mode to Late Night at 12:01 AM and another that changes it to Home at sunrise. These routines seem to be working, at least according to the History tab in the app.

At midnight, my outside lights turn off. What I want is for them to turn on when either of my Ring doorbells sense motion, and it’s dark out, and the lights aren’t already on. So I have a routine that has Late Night as a precondition and when motion is sensed, it turns on the outside lights for 10 minutes. This routine has been working fine for quite a while now.

However, I noticed last week that when I left the house at 11:00 AM, the lights turned on. Also, when the Amazon guy delivered a package in the middle of the day, they turned on. I checked, and my mode is Home. So the precondition of Late Night is not met, yet the lights turn on. And then off after 10 minutes so I know it’s that routine being activated.

Is this a known thing? Suggestions for fixing?


Does the ST General History show that the Routine with the precondition is the Routine that is actually turning on the light?

can you also post a screenshot of the Routine?

I’m not sure how to check that, but there are only 2 routines that turn on the light and off again after 10 minutes. They’re both identical, except for which Ring doorbell motion sensor is the trigger.

The “House Lights Switch” is a Kasa in wall switch that controls the lights physically on the house.

The “Permanent Plug 1” is an outdoor plug that controls my landscape lights.

The “Permanent Plug 2” is an outdoor plug that controls my Christmas lights, but they aren’t plugged in right now.

Click on the 3 bar Menu at the bottom right of the ST app and then Select History. You can filter for General History, All Devices, select Devices, or a combination of both.

Over the span of the next 6 days, there’s a hub firmware update being rolled out. Why not wait until the update dust settles and see if the problem persists?

Oh, sorry, I do know about that. It’s where I can see that my modes are being set.

Yes, my “Motion back door” routine is running. That is the routine that I posted the screenshot of.

If I scroll down, I can see that my mode is set to home at 6:17 AM. So the routine should not have a precondition being met.

I can definitely wait. I didn’t know about the firmware.

Hop on over to and subscribe. Gets you notices of maintenance and problems… eventually.

Done, thanks!

How do you change location mode?

I just do it with an automation.


OK, so I figured out that my modes are working, they’re just not switching. I have a routine that kicks off just after midnight to set my mode to “Late Night”. I have another routine that kicks off just before sunrise that sets my mode to “Home”. Both automations run, according to the history. But during the day when I open the app and look at the current mode, it’s “Late Night”.

I had used scenes ever since I created these automations. I thought maybe something was wrong so I changed them both to just set the mode. Still doesn’t work. At least the morning one doesn’t. I’m going to check the night one tonight.

When I go to the Automations tab and just click on the scenes to change the mode, they show the green check that shows that they have run, but it doesn’t change the mode. So that seems to be the problem that I can’t get a scene or automation to change the mode.

For what it’s worth, I also have Scenes that set Modes.

I just gave them all a try by selecting each Scene in the Automations page of the app. No issues, mode reported in the app changed as expected.