No devices showing on iPhone app

SmartThings is working fine on my Samsung Galaxy Note 20, but on my iPhone (work phone) I install and login and get presented with correct Location details, as well as rooms listed in each location. But no devices appear within the iPhone app.

I have tried uninstalling, re–installing a few times.
Tried “offload app” within the iPhone Storage section of the Settings app.
Tried disabling various connectivity settings (mobile data, wifi, bluetooth) in various orders, and re-enabling them one at a time.
Tried ejecting the SIM card, removing the app, re-installing, refreshing, etc.

Nothing helps.

Any other tips on what could be causing this?

Could it have something to do with VMWare’s Workspace One (previously: AirWatch)? [Although I only recently was forced to enroll the phone on Workspace One, and was experiencing these symptoms previous to that too]

If the WMWare’s Workspace One is performing any type of filtering/blocking then yes, it is possible it is the root cause for devices not showing. You may want to check f you can whitelist and I believe it is just that needs to be whitelisted.

Recently there was another user with a similar issue where their pihole was causing the same issue with their app (iOS if I remember correctly).