Newer Version Of 4 Gang buttons. Device Handler does not work with newest switches

I’ve bought 22 new 4 gang buttons (Zemismart) but the model and manufacturer are different from the version that worked.
The existing device handler is for model TS0044 and the new buttons that i have are model TS004F so i tried changing the code but this does nothing for the newer buttons.

My older ones (TS0044) work perfect. the device handler recognises the model and therefor wants to control it but it doenst respond.

Here the information of the button that works and the new one that doesnt, like you can see it hasnt connected and therefor has not created a metric.


What i see is that the Route does nothing for the new one and the older ones stand " This Device (146A) ↔ Control Center" and the new one doesnt have that.

if anyone can help, just what i do wrong or how i can change the device handler and update it so it works aswell.

The print is indeed an updated version


So which device handler are you using and what have you changed on it? Your screenshots just identify it as ‘Zigbee Button’.

The standard zemismart 4 gang button device handler.

https://raw.githubusercontent.com/YooSangBeom/SangBoyST/master/devicetypes/sangboy/zemismart-button.src/zemismart-button.groovy

So what I did was replace the line of the TS0044 with the data of the newer button so the manufacturer and model where changed to the TS004F info.

OK, I was just wondering why it is showing as ‘Zigbee Button’ on your devices when that DTH is named ‘Zemismart Button’.

I’m not familiar with the device but I think I’d have made the same change, or rather I’d have added a line with the new one in.

There is also:

private boolean isZemismart4gang() 
{
   device.getDataValue("model") == "TS0044"
}

All that does is set the number of buttons to 4 though and you do seem to have four children.

1 Like

Yeah I named mine zigbee button for easy finding in my handlers.

I did made a second line for the new one in my last try to but it didn’t work alone neither so thats not really a difference.

And the 4 button info. Is also something I added for the new one. So that the layout knows its a 4 button.

So the problem remains that the buttons won’t transmit button pressing to the hub.

Change the name to something else. There’s an error that can occur when you use the same name as one of the stock DTHs, I don’t know all the details, but it’s easy enough to avoid the problem.

Already tried that. That makes no difference.

Looking around, it seems that the TS004F might need further code changes. You could try removing the clusters from the fingerprint to see it if helps get it plumbed in but that seems unlikely to actually make it useful.

I was afraid for that answer. But yeah it seems that om gonna have to wait until they bring out a new device handler.