Newbie Question - cannot mute Samsung OCF TV

Hi Everyone,

Just starting out with the Smart Things API and I am following this doc:

I am trying to mute my Samsung OCF TV.

I am using the following these docs (apologies new users can only put a max of 2 URLs in a post):

And obtaining the Capability spec from:


This is my POST request:{deviceId}/commands

“commands”: [
“component”: “main”,
“capability”: “audioMute”,
“command”: “setMute”,
“arguments”: [

Where {deviceId} if my unique deviceId obtained from using GET request:

And this is the response I get:

HTTP/1.1 200 OK
Content-Type: application/json
Access-Control-Allow-Headers: DNT,Keep-Alive,User-Agent,If-Modified-Since,Cache-Control,Content-Type,Accept,Authorization,X-ST-Client,X-ST-Api-Version,X-ST-Client-AppVersion,X-ST-Client-OS,X-ST-Client-DeviceModel
Access-Control-Allow-Methods: GET, POST, PUT, DELETE, OPTIONS
Access-Control-Allow-Origin: *
X-RateLimit-Limit: 120
X-RateLimit-Remaining: 119
X-RateLimit-Reset: 17664
Connection: keep-alive
Content-Length: 79
Date: Sat, 05 Sep 2020 11:01:42 GMT
Server: openresty
“results”: [
“id”: “d2202c14-58a7-48b9-9c2c-fefafe6ff72c”,
“status”: “ACCEPTED”

However, my TV doesn’t mute even though the command was accepted and the response was a 200.

Is there something I have missed?



Try this

{“commands”: [{“component”: “main” , “capability”: “audioMute”, “command”: “mute”, “value”: “on” }]}