New zwave device magically shows up?

I got up this morning to see that my hub gave birth to a new device while I was asleep last night! Unless I sleepwalk I can pretty much say I didn’t do it…

Anyone else ever have a new device just show up out of nowhere?

I had this issue last night. Two pre-existing devices showing up as not yet configured. I ended up removing them and re-pairing.

Hi @jodyalbritton. Something is weird cause over the last 2 days I’ve had 6 zwave switches just stop working requiring removal and re-adding, and now a new mystery device. I also have 10 ghost devices showing up during the repair process that are from very old devices removed a long time ago. In over a year of using ST, I’ve never had so many problems. I have several tickets into support, including ones related to the latest android version.

I’ve been able to get to a PC and get into the IDE to track down this new device. Looks like it was added according to the event log (“Thing added”) in the middle of a zwave repair process I kicked off before leaving for the gym this morning.

The device ID that ST gave it was an old device ID from one of my previous failed and removed devices I mentioned above!

What’s also very odd is that I see an event for when the repair process starts, and then immediately after it I see an event stating the repair finished, but it didn’t really finish until over an hour later.

I really wish ST had better zwave utilities so we can clean up junk that somehow is not being done correctly within ST.

@April, any help you can provide would be great. Reference ticket numbers 94794 and 94763 and 94738. Thanks.


This happened to me during a Zwave repair process after a few switches had died and I needed to re-add. I had support look at it, and they just removed the ghost one as it did nothing.

So I can confirm mine was similarly related to zwave and during a repair process.

@johnconstantelo @ehoffman73 - I wonder if this is ST messing around with the issue that I am reporting about my Z-Wave wall switches that simply stopped functioning? It sounds like they are screwing around with the Z-Wave protocols on there end.

These ghost things were in result of 5 of my zwave switches, that have worked pretty much flawlessly since last summer, suddenly croaked and fell off the system. That was when I had to exclude, airgap power cycle, and reinclude them to the mesh, and when support ran the zwave repair to essentially insure nothing else was wrong, thats when those things popped. So in a pretty clear sequence that might mirror others’ experience.

So it could well be they are playing with things; support gave no indication of that, but they were fairly responsive as it were otherwise. He seemed to go right to the zwave repair, and then was not surprised about the ghost and quickly removed. So it didn’t seem to be unknown issue on their side.

This is happening to me as well. Every time I delete a Z-Wave device (from the app or the IDE) it comes back. The new ghost device doesn’t actually control anything.

Tossing my hat in here…though, I had a Zigbee bulb show up as a new item (GE Link Bulb), not a z-wave device. Hmmm

I’ve had G.E, Link bulbs show up as a new item about 4 times now over the course of the past few months. Each time I figure out which bulb it is based off the one that will not work. I then delete the “ghost” and go back to the bulb that wouldn’t work and rename it. I then turn the light on manually with the switch and toggle the icon and it works again.

dumb luck maybe

Interesting feedback from the community. Looks as though this isn’t isolated to zwave, but now includes zigbee devices. Leads me to believe that some type of backend database/table management issues may exist? I don’t understand how zwave/zigbee mesh networks are managed within the hub, but I wish we had something Wireshark for zwave/zigbee.

Interesting feedback @johnconstantelo. The support ticket I opened hasn’t shed light on to why this happened. I provided additional feedback to Support, waiting for a reply.

Has anyone else on this thread opened a ticket, and, what was the feedback?

Not a show stopping thing, but I’d like to know why it happened and if it’s something I should look for in the future (since the device worked fine prior to this issue). The bulb has worked fine since, but I’m curious…

I too have a Cree bulb continuously appearing as an unconfigured device. I have deleted it over and over, but it keeps showing up under my Things. How do I permanently delete it?

The Cree bulb itself needs to be reset. It’s still trying to phone home. Besides deleting it from the app you need to reset the bulb. I don’t know how to do that with GE Link bulbs, but not the Cree’s, sorry about that.

Well… I am a bit embarassed to admit htis. But I believe the “ghost” bulb was actually a real bulb. I replaced my ceiling fan over the weekend and after removing the 2 LED bulbs in the old ceiling fan, I noticed the “connected” label on the base of the bulb. I did not realize I had used one of my connected bulbs in the fan. Weird that the STH picks up the bulb even without being in a “connect new” status. Thanks y’all and sorry about the mistake

1 Like