New User Getting Error in Setting Up Multi Sensor SmartApp to Detect Garage Door Open/Close


(John C) #1

Hi All,

I’m in the first 24 hours of SmartThings, so bear with me if this is a bad question or in the wrong location.

I’m attempting to set up a ST Multi Sensor to alert me when my garage door opens. I have the device paired correctly but the last step of the SmartApp setup is returning an error.

I’ve removed the door and device multiple times, also tried doing the same on a different Android phone, with the same result.

Text of the error is “An Unexpected Error Occurred”, and I’ll upload pictures once I’m no longer a “new user”.

I am able to use the ST Open/Close sensor to setup a SmartApp to tell me when a door opens and closes.

THANKS FOR THE HELP! The great community ST has fostered was one of the reasons I chose this platform.
-John


#2

I’m sure that’s frustrating. :disappointed_relieved: The best thing is to contact support@smartthings.com. They should be able to help.

You can also contact them through chat during business hours. Click on SUPPORT at the top of this page, then Troubleshoting, then look for the tiny chat window at the bottom of the screen.


(John C) #3

Thanks @JDRoberts. I’ve sent an email to ST. A little frustrating, but the community and company help.

I’m very impressed by their service/support: I received an email from a Support Engineer offering assistance before I had even gotten home to open the box!


#4

Yeah the support people are really helpful. They can also do remote diagnostics which can help pinpoint problems.


(John C) #5

I didn’t know that and its awesome!


(Mcvoss) #6

see this thread, is this the error in the app you keep getting?

http://community.smartthings.com/t/cannot-load-things-page-sorry-but-there-was-an-unexpected-error/18300/24

(John C) #7

Solved: log in to ide.smartthings.com, click on My Devices, then click on the the garage door multi, select Edit and from the dropdown for Type Select SmartSense Garage Door Multi.

Thanks, SmartThings Support!


(David) #9

Well, this sort of helped me. I was having the same issue. I have a GE Switch for my back porch light that I could connect to and control (turn on/off), but when I tried to configure the device through the app it would say “unexpected error occurred.” I was able to go to the website mentioned above and rename the switch and add it to a room. But when I go to my Marketplace it still says I have a device that is Not Yet Configured. I click on it and it says it is the Back Porch Light. I try just going to the config screen and just hitting Next without changing anything and it still says “an unexpected error occurred.” Kind of annoying that won’t fully configure. :confused: