New to SmartThings - Soo many problems

So I got SmartThings the other day and spend a lot of money on the hub and multiple devices.
I am coming from mostly Wemo Wifi switches and I am finding so many problems with SmartThings.
I figured I would start somewhere. So I made multiple Smart Lighting timers and none of them work.
They are simple turn on light at 6:30am. I tried it for the Wemo and on a GE z-wave switch. The timers NEVER work, am I missing something here?

Also, on my “Things” page, it will say some switches are on when they are actually off.

Also, does the hub need constant internet connection to actually work? I tested just turning on and off the modem (not router) and you can’t control anything with the internet down. What is the point in having batteries in the hub?
With Wemo, you can control all your lights still without internet and their rules still work fine since the data is stored internally.

Am I missing something? I just want SmartThings to do very basic stuff but seems completely unreliable.

1 Like

SmartThings is generally used for automation and triggering things to happen when other things happen, etc.
Wemo can do this too, but it’s only dealing with about 3 compatible devices versus potentially 1000’s of devices that are z-wave, zigbee, lan, etc.

SmartThings is a more complex system than wemo with more variables in the mix.

As for why your timers aren’t firing, I’m not sure why…
Right now I have not had any issues with things going off when they should.

Also, the batteries in the hub are a fail safe to protect the device and information most likely from power related disturbances and interruptions.
But they aren’t full proof obviously… if your modem goes out, your router is probably down too which would render your Wemo devices useless as well in that situation.

In my home, I have an APC Battery Backup system where my server, hub, router, modem etc are plugged in to. So if power is out, those specific devices stay on… probably for about 15 minutes or so. But if power is completely out, again, your wemo devices won’t work either since they aren’t battery powered… kind of doesn’t matter any way.

Also, in a world of interconnected cloud services like IFTTT and any external influencing services that people want integrated, having a centralized “API” hosted by SmartThings outside of your hub helps ease connectivity and authentication to these services. The Hub is getting to be more of just a “portal” / “modem-esque” device for z-wave devices to communicate with the SmartThings Central API (they add the word “graph” to it as if they are trying to gain cool points amongst developers? Not many companies use the term Graph… in fact Facebook is one of the only ones that really use it… That’s beside the point…

Either way, that’s where the dependency on having a constant internet connection comes from. Also since Wemo devices don’t have a hub, really no way to automate it without some sort of external influence such as your iPhone or Android Device firing off signals.

If all you’re looking to do is switch a light bulb on and off, SmartThings is going to feel like overkill.

But if you want the ability to expand later and not worry too much about if something is compatible or can be MADE to be compatible with your hub, then stick with it - it’ll get better.

Yeah, you better get used to that… The system has been completely unreliable over the past few months.

Unfortunately, your timing for getting started stinks because there is definitely an issue with time based apps that started yesterday/today.

I actually posted my issue first thing this morning, and now see about 10 other posts for similar problems… Every time ST does some sort of update, something breaks.

In regard to your issue on the Things page, where is your switch located in relation to your hub? I was having a similar issue and finally realized it may have been a range/interference issue. As a test, try moving it closer to the hub with no interference (walls, etc.)… See if you can manually control it from the app and the things page lists the status correctly.


Thanks for the responses. With Wemo, you have to set it up with the router but the timers and rules are stored on the light switch it’s self. So the internet could be down but the switch will still turn on at 6:30am or whatever time. This is awesome.

With the ST hub, the hub needs the router and internet to turn off a switch. And that still actually does not work for me… Tried it with multiple switches (Wemo and GE z-wave) with Smart Lighting, completely broken for me.

I setup a open/close Samsung ST sensor, that worked for a day… Not touching a thing the next day, it no longer works. Had to reset it up and I haven’t tried it today.

The first post says, “If all you’re looking to do is switch a light bulb on and off, SmartThings is going to feel like overkill.” I find that funny since I can barely get ST to turn a light on a switch at a certain time, sometimes it works but 75% it does not. NEVER had a problem with my stand alone Wemo’s (before getting ST).

Well I think an update is being released tomorrow for the Hub, doubt it will fix any of the problems I have though. I have 2 weeks left on all my SmartThing items I ordered on Amazon to be returned. Lucky I kept all the boxes…


Yup timers are (were?) broken for the last week, roughly. Routines not firing, Smart Lighting not working properly either. My solution is to move everything over to Rule Machine. A lot of eggs in one basket, but so far so good. Slowly translating every facet of my system into Rule Machine.

Is there a good tutorial for Rule Machine?
I tried to set it up but looks confusing and overwhelming…

I am trying to enable the GitHub Integration but when I lick it, it brings me to a screen that says,

“Using these tools you can manage your hubs and devices, give them unique names, and organize them into locations and groups.
Access your developer tools: create your own apps, create your own device types, view your logs, and access developer documentation.”

Why is it not bringing me to the authorization screen next?

1 Like

I’m having the same issue, I sent a email to support and got this reply:

Auston (SmartThings)
Jan 19, 2:46 AM

Hey Willie,

This looks like a known issue and other customers are experiencing problems with it. We are aware of the bug and are working on a resolution, but at this time there isn't a definite timeline for when we can have a fix in place.

I'll be keeping an eye on this issue and we'll let you know when we expect to see it resolved.

Thanks so much for working with us.

SmartThings Support
Help me help you!
1 Like

I have been using Rule Machine for a few weeks not and I still have a lot of the same issues I had before with the ST’s apps. I would guess these are still more platform related than application related. RM can get pretty confusing on how to setup a lot of the features, but Bruce is usually pretty good at helping you. Rule machine - as per the app developer, this app is no longer available for new installs, distribution, or support

1 Like

I think the issue is less to do with ST vs RM, and more about local vs cloud. The reason moving to RM helped me personally was that for some CRAZY reason, local stuff has not been reliable. RM forces it all into the cloud, essentially. Plus I could add some complexity to my lighting automation that I needed.

For basic lighting stuff, I am still using Smart Lighting. Honestly, just expect issues…daily. You never know when it will hit. I’ve said it before, that this is basically just a fun toy. If you depend on this for anything legitimate, you will be burned, badly.

1 Like

I got a simple thing going with Rule Machine and I am having a problem with it working 100% of the time.
Am I missing something here?
I only have a Rule setup for, if 2pm, Kitchen Light-On
If 2:10pm, Kitchen Light-Off

Why does this not work 100% of the time?

Due to the fact that SmartThings platform does not handled scheduled events consistently. These are well known issues that have persisted for many months.


Looks like they are saying they have now fixed the scheduled smart apps problem. Lets hope so. You can see the Platform Status of SmartThings at

Past Incidents
Jan 20, 2016
Scheduled SmartApps
Resolved - This incident has been resolved. 
Jan 20, 15:10 EST
Investigating - Scheduled SmartApps are not performing as expected. SmartThings is investigating the issue and is working on a resolution. 
Jan 20, 12:21 EST

Thanks, does that come with an App update or Hub update?
Not sure if you would know that.

They fixed it on their side. There is supposed to be a update for v2 hubs tonight sometime, but they control that from their side and will pish it out.

If you saved your receipt I would return it.