New to automation and ST: controlling Ecobee?


(Eric) #1

Hello everyone! So happy to be here. I’m just now getting into the home automation deal. I picked up a ecobee4 tstat and also a nest hello doorbell cam. I just purchased the SmartThings Hub since I want to purchase more items down the road. Sucks nest isn’t in the app!!

Trying to figure out how to use smartthings app to run automations. I noticed I can set smarthings to a certain temp when I’m
Away, but anyway to have the ecobee go into away mode when smartthings is away and then back to home schedule when smartthings is back at home?


#2

Welcome! :sunglasses:

There are two different smartthings apps, smartthings classic which will give you more feature options or the new “smartthings ( Samsung connect)” Which is not yet as full featured, but which can work with the Samsung smart televisions and Samsung smart appliances.

So the first question we need to ask is which app are you using?


(Eric) #3

I actually downloaded both apps, but prefer the classic one so far.


(Jared) #4

Yes, I do this with both of my Ecobee 3s. I use this smart app suite which has this functionality along with many others.


#5

I am using Barry’s Ecobee Suite also and I am doing a bit of reverse. The thermostat is smart enough to know home and away based on it’s occupancy sensors and algorithms. I invested in 6 additional Ecobee room sensors, with that I am able to tell SmartThings to change the mode from Home/Away/Sleep, etc.


(Yves Racine) #6

The smartest ecobee integration has been developed over 4 years:

And, I’ve developed a comprehensive and resilient integration with all Nest Devices as well:

Regards.


(Jared) #7

What he doesn’t mention above is that you have to pay for that one. Nothing wrong with charging for your work, but I recommend trying the free one I linked first. The guy above also has an image on his thread stating “ecobee approved” with no actual link to an actual ecobee statement saying as such. That always makes me think twice before trying something.


(Yves Racine) #8

@xamindar, it’s obvious that you don’t know me and my past achievements with Ecobee, Nest, Automatic, Flair and Neurio devices…

The ‘ecobee approved’ is old news. It was posted years ago (back in 2015) related to some cooperation work I’ve done with Mu Saleem, Sr. Manager, Content & Advocacy at Ecobee.

Mu Saleem created that specific logo for my work as they don’t have any certification process like Nest…And, Mu used to post in this forum at that time, just look it up.

Do you really think that ecobee would let me post an ecobee approved logo without any permission? In fact, you can contact Stuart Lombard, the CEO of Ecobee to check my credentials… He knows all the work I’ve done under the ST platform…


(Ron Talley) #9

I use @yvesracine DTH and Connect App and have/had no issues for a couple of years now.

YMMV with other offerings.


(Eric) #10

Ok sorry I’m new to all this, so I need to download this suite. Do I need to copy the code into ST somewhere?


(Mavrrick) #11

You will need to install it through the Smartthings IDE. I would suggest you do a search on here about how to get started on that. I am pretty sure @JDRoberts has a good tutorial on it, i just don’t know were it is. I would also suggest that you setup your GitHub account and get that linked. It will just make it easier to update and download apps from community contributors as time goes on to use their github repositories.

As far as the difference between Ecobee Suite by Berry, and this other one by Yvesracine, I suspect it has allot to do with the person and not the actual functionality. I have been using Berry’s for some time now and have no issue. I am not going to get into details about it, just take a few moments to review what Yvesracine has posted and his conduct in threads about his apps. If that is cool with you and you don’t mind spending the money then go for it.


(Eric) #12

Thanks all!! I was able to get it into the IDE. Do I have to remove the regular Econee app now?

When I save I get a red error at the top saying device in use remove any smart apps…


(Mavrrick) #13

I believe you want to completely remove everything to do with Ecobee. then reinstall it from the Ecobee Suite app.


(Jared) #14

Yes, remove any others you have set up. Remove the built in one through the app and set up the new one.


(Eric) #15

Tried removing the ecobee smart app and get unexpected error in smarthnggs. Also why when I log into my ide I no longer see it in my apps or anything? Also says under my hub “you don’t have any hubs yet”. I still see the suite in the ST app


(Eric) #16

Wow this is crazy I went to my locations and seen the hub and now it appears, but after deleting all the SmartApps so I can start over they are all showing up and say smart app can’t be deleted at this time because it is installed by one or more users.


(Mavrrick) #17

First go into the mobile app and remove the ecobee device and the extra sensors. Once they are removed try removing the smart app.


(Jared) #18

Because you are “using” the app already. You need to remove any usages of it from the phone app, including any thermostat and sensor “things” you have. Clean all that out and then it will let you remove it from the ide.

And by the way, you do need to go to locations and select your location upon first logging in to the ide in order to see your hub and all your stuff. I have no idea why they have it set up that way and I think it is utterly stupid but it’s the way it is. Selecting the location first is the workaround for that site bug.


(Eric) #19

Ok, I was able to remove everything from the ST app regarding ecobee. I reinstalled the suite based n the instructions on the forum here, when I save after getting the API auth I get this error “device still in use. Remove from any smartapps or dashboards then try again”


(Eric) #20

Anyone can help on this error? Where else would I need to delete anything Ecobee or is that even my issue? Do I need to delete it from the Alexa app as well? Thanks I advance I really wanna get this suite working