New ST app didn´t recognized the double relay device handler. It stopped working

Hi, I´ve just migrated to the new app as the classic one forced me.
Everything was running fine in the Classic App, no problems at all, but when I migrated to the new app 3 devices had problems.

I have 2 Vision dual in wall relay installed and 1 Enerwave RSM2 Dual Relay . Both of them stopped working and they were recognized as a single switch, turning on or off both connected lights. google’s assistant stopped to recognize them as each channel dissapeared. Showing the status for the device is affected also, I’ve written to ST support but they just limited to say “we are sorry, we do not support that device, we support some enenerwave devices, but not that one”. Forcing us to migrate to a platform that is not ready was crazy. i’m about to go back to Vera, as it was my first smarthome platform I still have the controller. The only problem is I already have Zigbee devices and Vera Edge doesn’t support Zigbee. Before buying Vera Plus (which support Zigbee) I want to ask: is there any chance we are going to see device handlers updated soon for new ST app? or should I switch back to Vera and get my home back to normal?

I appreciate any comment about it.

Thanks.

Which DTH were you using? There has been some community discussion about the stock handler for multi channel devices, so at least you know you’re not the only one. :disappointed_relieved:

Hi, for the Enerwave dual relay I´m using this one:

For the Vision dual relay I was using the stock handler multichannel DH, then I tried with the Monoprice written by justintime. It worked perfectly in the Classic App, but in the new app didn’t work:

I will really appreciate your help in case there is a solution for this.

Thanks.

“Z-Wave Device Multichannel” is what these devices were originally using with the child endpoints using “Switch Endpoint”. Someone in another thread suggested “Z-Wave Dual Switch”, which I cannot seem to get to stick. What I mean is I select that DTH and hit the Update button, and I get all indicators of a successful update. However, the page then shows the previously selected DTH and when I go back into edit, it also is not updated. Not really sure whats happening here, but its very frustrating. Would love some help here… I hate to claim being savvy enough to understand this and come to the forum with nothing to offer, but the SmartThings app and IDE either dont show anything useful here or I just dont know how to find the information to show me whats happening.

1 Like

Tagging @jkp @prjct92eh2

This might be the “stale DTH“ issue, but to be honest, I don’t know enough to help on this one. Tagging some people who might be able to help.

Not sure it is a stale device handler since it is a stock DTH.

Taking a shot… maybe try logging in with an incognito/private tab in your browser at https://account.SmartThings.com

1 Like

More info in another thread, Generic Multichannel Z-Wave devices stopped working with new SmartThings app
Basically, SmartThings has officially deprecated and stopped support parent/child devices. There are references to other threads with information which can lead you to the DTH modifications needed. Caveat, I do not yet have mine fully working yet.