New Smartthings - outlet control via motion sensor not working

hi there,

I just got my equipment today and installed it - actually quite easily.
However I am trying to create the following without any success so far:

Motion Sensor - on motion - turn outlet on (has a lamp connected) - no motion turn off
Motion Sensor - on motion - turn light (Osram bulb) on - no motion turn off

so I intend to have 2 actions on the same sensor to trigger different things but it doesnt seem to work.

So I started some troubleshooting and after a lot of playing around with it I got the following to work:
Motion Sensor - on motion - turn light (Osram bulb) on - no motion turn off
MultiSensor - on open - turn outlet on (has a lamp connected) - on close turn outlet off

this seems to work just fine - trying to enable to outlet via the Motion Sensor doesnt seem to work at all - any ideas what might be causing this or how to get it to work, I dont consider this to be rocket science and assume it should be as straight forward as with the multisensor - I am missing the options to debug what is actually happening here … any advice would be highly appreciated.


Sorry I don’t have a solution, but I have just been trying to solve what sounds like exactly the same problem.

I had a power outlet being triggered off of a motion sensor, which was mostly working fine (The off action would occasionally fail).

This evening the task stopped working. I added a hue bulb onto the same task and that switched as expected.

Like you I just tried switching the outlet using the open/closed sensor and it fired correctly. So the problem appears to be just with Motion and Power Outlets together.

1 Like

I’m having the same problem. I can turn on the lamps with the app manually but it doesn’t work in a command. I’ve just tried the motion sensor with Philips hue lamps in an alert command and it works. For some reason the hub isn’t auto turning on any lamps with the power outlets

Same issue in my st , maybe st support should says something?

Support web site suggests everything is ok, I can control socket and switch manually but not from motion sensor. I am new to this as well but had everything working before this evening.

All local devices are not working! Something on Smartthings end.

what do you mean if you say “local devices” or how makes it a local device? have seen a similar statement previously and looked at what is shown as local devices interestingly only the multisensor and the outlet showing up on there …

I however run
the starter kit v2
except the presence sensor
2x android as presence sensors
and 2 Osram WRGB bulbs …

some clarification would be highly appreciated as you can see above the multisensor is indeed able to work the outlet … so your statement doesnt really make any sense to me

I was looking through other discussion boards. Some devices run remotely and some run localy. From what I read elseware all of the localy run devices are down.

well if you are referring to the localdevice list as mentioned the ones on there in my list actually do work well in conjunction with each other - the “others” missing dont seem to be able to trigger them … however the missing ones eg the motion sensor can perfectly alter the state of the also missing Osram bulb - so I would take your guess here and say the non-locals work with each other so do the local ones and the “link” is currently broken …

edit:I quickly installed Rule Machine to see if that makes a difference but same issue …

I take it this is all related to the same problem I’m facing?

I can control my GE Link bulbs individually in the Smartthings app, but all routines (turn groups of bulbs on/off) fail. I see the commands are being received by the hub in the even log, but nothing happens to the bulbs when running routines.

It would appear that to control a switch or socket you can click on a button to send an ‘on’ or ‘off’ command which goes directly to the hub and then to the device. However a command from a motion sensor seems to go to the hub, then off to a magic cloud before (not tonight) returning to the hub and then to the device.

uhm - well - so basically all security options available are more less useless if the uplink or cloud backend fails - well that doesnt sound too trustworthy then - I would have thought that everything can be handled locally except all the reporting and push notifications - obviously wrong assumption here …

are there any systems that do support local commands only? already considering returning the bits as obviously not yet fit for purpose … within the first 24hrs something like this shouldnt happen …

Exact same issue for me

thinking about it - why would the motion sensor send the commands for the outlet via the cloud but just locally via the hub to the bulb - doesnt sound right, does it?

Because the motion sensor is sending an input to a piece of software running far far away which in turn replies with an output to turn on/off the switch or socket. Far far away is broken. Maybe.

:wink: thats good explanation , but yeah this is what it is

Just received this email from them.
Hi Russ

Thanks for getting in touch - your ticket went to US support, your message has now made it back across the pond to the UK support team. This issue has just started trending following yesterdays platform update. We are currently investigating it, please bear with me I will update you as soon as I know more.

Best Regards


1 Like

Guys back to normal for me , check yours ST should be fix now

woop same here! at last

I’m trying not to lose faith in SmartThings, however truly since V2 overall usability and reliability has been super poor, I just want thing to work. I wake up most days and wonder if events will trigger, will I walk around in the dark, when I leave will the system disarm before I open the front door, etc… I’m still a supporter, but I’m getting tired of constant troubleshooting!!