New Official Integration: Samsung Multiroom Audio

That’s the bug. ST caches TTS announcements in the Amazon cloud. Any playText() call that results in a cache miss throws an exception.


Are there any updates on this? I’m debating whether or not to go with samsung or sonos, but it does seem like a huge oversight that there is no support for groups of speakers…

Incidentally, I assume there’s support for the new speakers since they’re just the same model of the current line?

Our Sonos integration doesn’t support grouping either.


I’ll be answering some of the other questions over the next day or so.

Regarding grouping, you can group the speakers within the Samsung Multiroom app, and they are supposed to be controllable from the “master” speaker (I believe that this is the one that you went to and clicked the “Group” or “Surround” buttons on). I found that to work “ok”; even controlling from both speakers. But, there was a noticeable delay. I would like to see better logic, if possible, to support that.


1 Like

Are you okay @April :smiley:

Hah! Thanks. Just fixed that.

Looking forward to the official integration. I’ll be picking up a few.

2 M7’s and this bad boy enroute…

Is the textToSpeech API fixed completely? It was defective recently, affecting the Sonos systems up until now.

I haven’t been following the larger issue too closely but I’m able to get TTS working in two separate tests right now.

1 Like

The larger issue is that it still worked if you happen to pick a phrase that had been cached before the problem started. So things like “this is a test” would work. Or “Honey, I’m home.”

But if you pick something that had never been used by anyone accessing the smartthings service, it would fail. It appears ST has lost access to whatever conversion service they were using.

(If that’s Google, there’s a reason for that: they tightened up access recently.)

1 Like

I believe it comes from the AWS cloud per the location of the mp3 that is delivered, but I can’t confirm that. @tslagle13 was birddogging this internally to ST. Good to know when it is fixed it will start working across all platforms.


Can you get it to say “This is a test. Mooooooooo.”?

If you use a phrase that’s been spoken before, you’re fine. If you ask it to cache something new, that’s where it falls on its face. :stuck_out_tongue:

1 Like

Neither TTS nor the canned sounds are working on my M7.
It’s connected and I can mute it, any ideas?


Could you please detail the steps you took (which SmartApps, how they were configured, etc) in as much detail as possible? Specifics like how many speakers are configured, what their model numbers are, how they are configured in terms of arrangement (are any grouped, etc) and how they are configured in SmartThings. (Assume that you will tear this down and I will be setting it up for you; because I basically am going to be doing just that here.)

I was just able to do this with the pre-configured sounds, dogs barking in this case; but I can confirm that custom TTS messages are broken (“cluck cluck bock bock” in this case). I am making sure the that TTS issue is raised and that someone is actually doing something about it.



Sure be happy to.
Model is M7 and no configurations have been made with any Samsung apps.
Used Ethernet connection, using network space (tried dhcp and static reservation, same result), this is the only network that exists in this house.
Verified I could ping the device over lan.
Installed Samsung audio (connect) from Marketplace, device discovery completed very quickly, device was found with the correct IP.
Child device was created without issue.
Child device identified speaker as M7, activating the mute tile causes speaker light to flash, and does appear to mute the speaker.
Installed notify me when from marketplace, selected a switch to activate, action, on this speaker (correct speaker was listed), then for specific modes, no other options were selected.
No sound was produced, though log seemed to indicate that things were working OK.
Replaced the app with the Morgan freeman edition, same result.

Interesting, just installed the Samsung app, it’s applying a firmware update…, will update when completed.

Was it “Notify Me When” or the “Sonos Notify with Sound”? The former doesn’t support speakers, the latter will. I tried using the latter.

I am curious about the firmware update. I can see that being a possible issue.


sonos notify with sound…
Firmware update complete, now ST can’t discover the speaker…


(20 chars)