New Official Integration: Samsung Multiroom Audio

ISSUE / CONCERN.

On completing the Add a Thing, the system automatically installs my HW-MS650 soundbar as one of these devices. The problem is, there is currently NO CONTROL of the device (and there was several weeks ago). When trying to use the Speaker Companion, I do get the log entry “debug playTrackAndResume(https://s3.amazonaws.com/smartapp-media/polly-tts/salli/this_is_a_test.mp3, 1, null)”, but also no sound.

I know - not a supported device. If that is the case, then you need to preclude installation.

Additionally, a request.

Does anyone know the port and path for the Speaker (i.e., R1) RenderingControl and AVTransport upnp services. I know that for the my soundbar, the paths are:

Port: 9197
Paths:
RenderingControlPath = "/upnp/control/RenderingControl1"
RenderingControlEvent = "/upnp/event/RenderingControl1"
AVTransportPath = "/upnp/control/AVTransport1"
AVTransportEvent = “/upnp/event/AVTransport1”

Thanks.

Dave

I don’t know the port and path, but if you can give me some guidance on how to discover port and path I could do some testing for you.

Thanks for the offer. I am able to complete normal scans and searches using my own tools. However, I believe that the ones I need are not published via discovery. You have to know about them.

Today, I downloaded a port discovery tool for my PC and have found several other possible experiments.

I think you are responding to a request from me for data on a command. The problem is the Samsung R1 Speakers (I have 2) do not at as DLNA players from external sources (i.e., a play can not control the speaker). They can use DLNA servers to play music. This is evidenced by the fact that the Generic Media Render app can not detect the R1 speakers (while it can detect my HW-MS650 soundbar, which has the DLNA required UPNP targets).

Can I get a SITREP on this please? Is the project good to go, or is it still having issues? If it’s having issues, what kind of issues? Can someone give me a summary. I’m tempted to go out and grab some of those speakers, but I don’t want to spend the money if the system isn’t operational.

Additionally, I want to know about the text to speech. This is crucial for me wanting to jump in on this project. I’ve spent a lot of money trying to wire my own speakers and it just never worked right. Having this would surely be nice, but I need to know if I’ll be able to send audio from my computer to one speaker, and have it synced and go across all speakers? Is that possible?

Move over to this link for further comments.

I am still working the integration and have completed all but the TTS integration. TTS issue is I can not find the command to invoke the URL play for the speakers. Once I find that (and I continue to search), then TTS will be enabled. There is a work-around to be able to use this product and have TTS capability on the Speakers - I will explain this in the other thread sometime this week. So far, it is relatively complete except TTS:
a. Full control of speaker functionality (including source toggle, repeat, shuffle, equalizer mode select.
b. Eight CP presets (some limitations) - set up in Multiroom app, then set in dh.
c. Three (per speaker) group presets - set up in Multiroom app, then set in dh.

1 Like

Latest update. I have a prototype working with all functionality as well as the ability to play TTS alerts. It is in final testing at my house. It will require a work-around using the (LAN)SamsungAudio devices as children for the Speakers (but not the Soundbars).

SATURDAY or SUNDAY release.

UPDATE: I got called to do some consulting. Will delay the release for several days.

4 Likes

Done and at site with instructions. I use UPnP for the Soundbar TTS / URL playback and I cheat to get the R1’s working. But it works (and is seemless). Would like to get rid of the cheat.

1 Like

Great work on the Samsung Wam speaker integration!
I will be testing.
Thank you!

1 Like

Dave,
Today I confirmed that your app also works with Samaung R3, R5, R7, M3, M5 and M7’s. I mixed them up in groups and was able to set presets. I am not sure what the volume control on the right side that goes up to +6 and down to -6 does? Also I use the Weather announcement feature app and it does not announce as it does with the standard Samsung speaker control handler. Note that I do not use a soundbar. I read the document to set the surragate tts speaker(s) and had no luck hearing the weather announcements. Also noticed that when the weather announcements are keyed and playing, the music that was playing stops and does not resume.

Here is a log:
5:15:35 PM: trace Exiting takeAction()
8ae0cbea-2901-4a41-bf4e-342d8336eb2a 5:15:35 PM: info [Samsung] R3 office_playTrackAndResume: playing TTS Sound on surrogate speaker.
8ae0cbea-2901-4a41-bf4e-342d8336eb2a 5:15:35 PM: info [Samsung] R3 office_playTrackAndResume: playing TTS Sound on surrogate speaker.
8ae0cbea-2901-4a41-bf4e-342d8336eb2a 5:15:35 PM: info [Samsung] R3 office_playTrackAndResume: playing TTS Sound on surrogate speaker.

Plus about 25 more of the same lines after the Weather announcement comes on.
With the standard Speaker app handler there are only a couple of lines logged.

Great work again and Cheers,
Jim

Thanks. Does the standard speaker app handler give the weather forecast audio? Also, when using the standard, what do the logs look like? It would be useful to see if it is different than that for the Speaker Companion command.

Suggest trying the “Speaker Companion” as another test. I tested this AM on the R1’s and get same result on both integrations - plays sound and resumes station.

The plus and minus 6 values on the value are the equalizer values for each speaker. They come into account when (for the speakers) you play STEREO. For Soundbars and speakers, you can do Surround Sound using the same. These are a second Group type supported in the integration. Basically biases the volume of the speakers (while listening), then you only change the master volume.

Here is what I get with the standard Speaker Companion and standard Samsung device handler with the weather announcement audio working:
25672ca8-54c3-445f-bf2e-df4636c37451 7:38:40 PM: trace Exiting takeAction()
e041ef9c-6a4e-4576-b8dc-01c8ccac90da 7:38:40 PM: debug playTrackAndResume(https://s3.amazonaws.com/smartapp-media/polly-tts/salli/07807d4d2faabd317667f8a97aaac77e72287814.mp3, 23, null)
2d5c7cc8-c8a5-44c5-b892-0639c3495260 7:38:33 PM: trace getPhrases(), state.welcomeIssue = null

With my setup it does not resume playing music with either app, but I can restart it using either your app or the standard by pressing the play button. I still do not get the announcement with your app though. Interesting that your music starts playing again too with both apps. Not sure what I am doing differently. I have the same not resuming results with R1’s too. Maybe I should reboot the Smartthing hub?

Dave
I am now getting this after repowering the hub with your app:

967084eb-8d27-4cca-b730-7383222406ea 12:40:46 AM: trace Exiting takeAction()
116b5190-a154-4049-803c-fe6cbc319694 12:40:46 AM: error java.lang.NullPointerException: Cannot invoke method playTrackAndResume() on null object @line 360 (sendCmdToSurrogate)
116b5190-a154-4049-803c-fe6cbc319694 12:40:46 AM: info [Samsung] R1 Bathrpom_playTrackAndResume: playing TTS Sound on surrogate speaker.
2d5c7cc8-c8a5-44c5-b892-0639c3495260 12:40:34 AM: trace getPhrases(), state.welcomeIssue = null

The good news is that the music resumes after the java error. Not sure what is causing the error. There is still no announcement.
Cheers,
Jim

OK that error was caused by not putting the speaker as the surrogate in the automation part of the smartapp manager. I had it set as the tts_1 in the speaker’s part of the smartapp manager. Still no announcement though…

I have noticed that the Home speaker shows stopped instead of paused after the announcement plays. As usual, I can restart the music by hitting the play button again.

Note that all my Samsung speakers are updated to their respective current firmware. Hopefully that is not the show stopper.
Cheers,
Jim

I did a double check. The SW on my speakers is the latest versions (according to the Speaker Software Update in the Multiroom App).

What music station are you playing, or are you playing a song from a server?

I just did a test:

  1. Two R1’s and a single soundbar, grouped with an R1(Speaker Left) as the Master.
  2. iHeart radio station playing
  3. Speaker Weather Forecast with all forecasts selected directed to the Master speaker.

Results

  1. Played on all three speakers simultaneously
  2. When forecast completed, station restarted within 3 seconds.
  3. Following relevant log items:

350bfc91-c738-46cf-a0c0-febb56d6c498 11:24:03 AM: debug playTrackAndResume(https://s3.amazonaws.com/smartapp-media/polly-tts/salli/61d0297bb180a8471737ee0cb1c05d772b619324.mp3, 26, null)
afc383b3-a028-4c00-b552-e02b7be3ea3f 11:24:03 AM: info Speaker Left_playTrackAndResume: playing TTS Sound on surrogate speaker.

Typically, for your setup, I rely on the Surrogate speaker to play the sound and restart the music.

I was using Pandora, but got the same results no announcement results with IHeart. This was with testing one speaker set as the surrogate.

I am going to try totally resetting my Smartthings Hub STH-ETH-250 and starting all over… I am hoping for success;)

Have you tried Amazon Echo voice command integration yet?
Cheers,
Jim

LAN functions may be down right now. SmartThings staff is working on it. (down for me.)

1 Like

LAN functions down? Do you mean their server site is down?

My Live logging is still working.

I see device control is an issue.
https://status.smartthings.com/history

I wonder if that is why some of my speakers suddenly have a red dot next to them on the Home window?

No. Essentially, if you are experiencing the problem, you can not control your speakers. See if you can mute or change volume. If not, then you are affected.

see https://status.smartthings.com/14

Yes as I just added to my above post that is an issue. Maybe I should wait a while before resetting the hub and starting all over again…:wink:

Your link is giving me a 404 error.

EDIT: Well that was quick. All the red dots have disappeared and I have play/pause control again.

1 Like