"Network connection" app pop-up

Here’s what I don’t understand about the “Network connection” app pop up I have been getting consistently for a while when first opening the app (iOS app, persistent through today’s update):

I can open the app from a closed state and immediately change the state of the SmartThings Home Monitor (STHM). Routines that are triggered to run when STHM modes change also run immediately.

I can open the app from a closed state and immediately run a Scene which turns on all of my lights, or groups of lights, or turns them off, or otherwise controls my devices.

I can’t open the app from a closed state and immediately control an individual device. I need to sit through 10-20 seconds of “Network connection… Your action will be completed when your phone is able to connect to the Smartthings server” and a spinning device circle.

How does my phone have enough of a network connection to run Scenes and Routines (which each control devices), and change STHM states, but not enough of a network connection to control or open an individual device?

This makes no sense to me. Certainly seems to be a bogus message to me and indicative of some other sort of issue with the app.

Get on it Samsung! I can’t submit any more cases to lead you to this problem and its resolution.

1 Like

Yeah, it’s poorly worded. It’s not “connecting to the server“ that’s a problem. It’s getting the app screen ready to display.

I suspect, but do not know for sure, that it is checking the “device controller“ (essentially an app plug-in that controls the display of the details for that device) for every device on your account before it gives you access to any of them. To see if any of them need to be updated. So it’s not about actually controlling the device, it’s about the details of its display in the app.

@Automated_House might know more.

1 Like

I don’t think its checking for a device plugin update. As I understand it, it’s updating the device states themselves. aka is the switch on or off, is the motion sensor showing motion or no motion, etc. As JD said, it’s a very poorly worked pop-up and occurs more frequently for certain types of devices than others.


If anyone has any insights for which type of devices are more problematic, I’d love to know. I don’t have many in my system (30-40) but am still using some custom device handlers and would be willing to cut back further if I can get a more responsive app.


Same problem here guys. Is there a fix for this? Nothing is working.

It sounds like the app update last week introduced a second variant of this error. That one was resolved by deleting and reinstalling the app.

Others, like me, experience this error much more chronically, typically when the app is first started, or when it comes back to the foreground after a while in the background. It resolves when the app “warms up”, after about 30 seconds, but makes it impossible to control anything in that time. There is no solution identified yet for this version of the error.

1 Like

Thank you very much!

Removed the app and reinstalled. All good now! Thanks Mooch91!!!

1 Like

This just started happening to me this week. Twice now I had to logout of my Samsung account and then log back in (using the app on my iPhone). There is nothing wrong with my Wifi or my devices. All the automations still work. It’s the phone app that can’t connect to the Samsung server. I would think that Samsung would be all over this problem. It’s been working great for over a year now, but I can’t continue to use it if I have to go through this logout/login process a couple of days.

Reviving an old thread. Has anyone found a solution to this problem? I’m getting this same message nearly every time I try to control a device. I’m about to drop Smarttings altogether because if it and I’ve been using it for years.

Nope, no solution. They’ve said in another thread that, at least for iOS, this is the way it’s supposed to work. The pop-up is telling you it’s still loading device information. I have no hope it will be fixed.

Here is what is odd. I have two houses with Smarttings. My primary residence gives me the “connecting to the network” notice nearly every time I try to manipulate a device. I don’t think I’ve ever had this happen at the other house.

Would love to know if you have anything different about your network setup at either location. Is it the same result whether you are on the local wifi, any wifi, or cellular network? I’ve never noticed a difference among the three, they are all slow. Lately, it’s been the Network Connection message and a lot of “Downloading…” messages that continue to make the app unbearable. With the “Downloading” message, I can’t believe that things are updating that often that it needs to download new code and controllers each time I open up the app.


I also get this message every time I open the app for controlling devices manually. It’s very annoying and makes my entire “smart” home very slow and frustrating.