Nest working for everyone?


(Im Brian) #1

Realized my Nest thermostat was no longer marking itself “away” or “present” based on an app I’d made. Going through the device simulator, it seems I’m getting error Unauthorized on every request that requires authentication. Is anyone else experiencing this? Started happening for me today or yesterday, I’d imagine. Curious if I’m the only one - or if others have fixed this same issue.

Thanks!

Edit: This is the device type I’ve been using, from @Dianoga : https://github.com/smartthings-users/device-type.nest


(Im Brian) #2

Uninstalled all related apps, uninstalled the device - for good measure, removed the device type and started over. All seems to be well now.


(Jam Dawz) #3

Not working for me, but it never has! I tried to install it yesterday with no luck. I can successfully create the device type and add the new Nest device, but the SmartApp hasn’t shown any status. It displays “–”. See snapshot here: https://www.dropbox.com/s/cv6dpm8p29zpgv9/2013-09-29%2008.15.31.jpg I have triple checked my Nest.com credentials. I have uninstalled and reinstalled several times. Nothing working! Please help!


(Im Brian) #4

@JamDawz - I’m on Android, so I think my issues were specific to that platform, but I had a similar issue when first installing the Nest (and a few other “oddball” devices). What fixed it for me was to clear application data from the SmartThings App and start it anew - logging back in forced a device refresh, I’d suspect. Again, unsure if it’ll work for you since the iOS app appears much more polished.

Good luck.


(Jam Dawz) #5

Okay, got it working for me, but only on my phone! My wife’s shows the tile, but has no information. Just a big question mark. Am I missing a step?


(Jam Dawz) #6

My Nest has stopped communicating with ST as of Saturday. Am I the only one?!


(Im Brian) #7

@JamDawz - I hadn’t noticed, but it seems it’s not working for me, either. I may try uninstalling and re-installing the device. That’s worked for me in the past.


(Im Brian) #8

Getting this as a reply from Nest when going through ST:

hostname in certificate didn't match: != <.transport.home.nest.com> OR <.transport.home.nest.com> OR


(Jam Dawz) #9

So what does that mean?


(Im Brian) #10

I interpret this as “SOMETHING WENT WRONG!!!”

There may be a certificate that expired and requires re-authentication. I suspect that removing any related apps, removing the device, then setting everything back up will work. I’ll report back once I have time to try.


(Im Brian) #11

Yeah - it seems a certificate has expired. I’ve uninstalled all relevant apps, deleted the device (not the device type) and re-set things back and all seems well.


(Jam Dawz) #12

I uninstalled the related apps and deleted them from “My Apps”. Then I removed the device. After re-adding the Nest device, everything works fine now! Thanks for the tip!