Nest Thermostat Stopped Working


(Lyle Mann) #1

My Nest Thermostat stopped pulling data today. Is anyone else experiencing this problem. Below is the error I get in live logging. I haven’t had any problems for months now not sure what changed today. I am using the latest code from here.

8:36:53 PM: error java.lang.NullPointerException: Cannot get property ‘uri’ on null object @ line 525


Platform Update - Release Notes - 02/17/2015
(Brian Smith) #2

I just looked in the event log for both my Nest devices and the last update was from 6 hours ago. Interesting that there was a platform update today as well. Coincidence or causal?

Looking back through the logs shows regular entries every hour, at a minimum, from both devices.


(Kevin Weis) #3

Mine has also stopped working and I am getting the same error.

This is very annoying. I finally got this set up the way I like it and now it goes down.

:rage:


(Brian Smith) #4

I put a note in the platform release notes post for tonight to link these two. Hopefully someone can determine the cause. If you don’t see anyone post to that thread, I would open a ticket with support - as I will be doing the same.


(DLee) #5

Confirmed same errors, can’t control temp setting, no activity since 2:43PM PST. Loading Nest thing activity feed causes Android mobile app to crash. Also other HTTP based integrations. Reactivated the ubi association after it failed and now seeing over 10 errors per second in live loggs. And MyQ control works, but no logs since 5:57PM PST.


(Alex) #6

Same here. Nest is down. Just when I finally got an evening to work on ActiON Dashboard thermostat integration…


(Ben Edwards) #7

Guys we are looking into what from today’s release may have affected Nest integrations.


(Rob) #8

I concur, also having Nest issues. Ben, thanks for looking into this.


(Patrick Musselman) #9

Same issue. Nest appears to be down.


Nest device type with a bunch of new features
(Erik C.) #10

Same here, Nest stopped working since 4:44pm EST


(Carson Dallum) #11

Same here, last activity for my Nest was at 4:15 PM CST.


(Acastal) #12

Maybe if Nest is blocking us it will speed up the official integration :smiley:

Request Error: java.lang.SecurityException: Endpoint https://transport03-rts06-iad01.transport.home.nest.com:443/v2/mobile/user.xxxxxx is blacklisted.


(Erik C.) #13

Any updates or an eta on when this will be resolved.


(Matthew Van Dyke) #14

Well at least I’m not the only one. I had my Nest thermostats to set to heat the house at 5am when I wake up. I woke up and it was cold. Tried to adjust the temp via ST and I was getting an error. I deleted the device and device type then reinstalled from scratch and now it’s not showing anything.


(Ben Edwards) #15

There is a patch going out today to address this issue which was not only with Nest but many Cloud-to-Cloud integrations.


(Alex Keybl) #16

Great thanks! (and thanks to cdallum for pointing me to this thread)


(Ron S) #17

@ben You mentioned

What other integrations are having issues? So, that I don’t have to bother trying to fix known issues once I get home today.


(Ron S) #18

Just got a note that everything is resolved. So what else besides the nest was affected? It would be nice to know… Right? Hues, harmony, Sonos do not count. Nest we know. What else is there? :wink:


(Ben Edwards) #19

The fix has now been deployed.

Cloud-to-Cloud connections. So things like Nest, Netatmo, IFTTT possibly.


(Ron S) #20

Lucky Netatmo and IFTTT user base! We the grave diggers (hues, harmony and sonos users) so envy you! :wink: