Nest Issues with Refreshing

Nest had some major outages over the weekend (good thing ST is not alone). However, the issues have been resolved but I’ve noticed a couple of times already I have had to go into the Nest device and re-initialize it by clicking “done”. Otherwise, it won’t get any updates (even with Pollster running against it). I see this error in the IDE logs:

java.lang.NullPointerException: Cannot get property ‘uri’ on null object @ line 576

if I go into the Device and re-initialize it, that error goes away, but seems to break eventually again. I am using @Dianoga’s Device Type.

Just an update, the problem just keeps coming back. Here is the complete log: (I removed the access tokens and obfuscated my email address for security reasons). I even tried @desertblade’s new Device Type and I still get the same errors. I am wondering if Nest made any changes this weekend to block us ST users? I am also getting these errors with my Nest Protect’s as well.

044856c5-cbfc-4917-b77a-b3ee457d4374 2:28:56 PM: error java.lang.NullPointerException: Cannot get property ‘uri’ on null object @ line 576
044856c5-cbfc-4917-b77a-b3ee457d4374 2:28:56 PM: debug Logged in
044856c5-cbfc-4917-b77a-b3ee457d4374 2:28:56 PM: debug [limits:[smoke_detectors_per_structure:18, thermostats:40, thermostats_per_structure:20, smoke_detectors:36, structures:2], is_staff:false, email:xxxx@gmail.com, urls:[direct_transport_url:https://transport04-rts15-iad01.transport.home.nest.com:443, weather_url:https://apps-weather.nest.com/weather/v1?query=, transport_url:https://czfe07-front01-iad01.transport.home.nest.com, support_url:https://nest.secure.force.com/support/webapp?, log_upload_url:https://log-rts15-iad01.home.nest.com/upload/user, rubyapi_url:https://home.nest.com/, czfe_url:https://czfe07-front01-iad01.transport.home.nest.com], weave:
044856c5-cbfc-4917-b77a-b3ee457d4374 2:28:55 PM: debug Calling get : /v2/mobile/user.90990 : []
044856c5-cbfc-4917-b77a-b3ee457d4374 2:28:55 PM: debug Logged in
044856c5-cbfc-4917-b77a-b3ee457d4374 2:28:55 PM: debug Executing ‘poll’

Well apparently, I am the only one getting this. So I went ahead and removed all 4 of my thermostats and 7 of my Nest Protect devices and re-set them up and now everything is working. This is about the third time I’ve had to do this with my Nest devices and now I created a spreadsheet with all of my serial/mac addresses to make it easier for the 4th time :smile:

#whenwillofficialnestsupportcome?!!